Starting two programs via launcher / Unity, ends up in a wrong set focus for tha buttons on the panel, closing a window closes the wrong window

Bug #966093 reported by Sascha on 2012-03-27
8
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

1) Ubuntu 12.04 LTS Beta 1 (nightly build)

2) unity: Installiert: 5.8.0-0ubuntu2
compiz: Installiert: 1:0.9.7.2-0ubuntu4

3) I open in Unity first LibreOffice Writer, and after that the Ubuntu Software-Center.

4) You can follow this behaviour in my short movie: After starting both programs via the launcher, LibreOffice opens first, after a few moments, the Ubuntu-Software-Center is loaded too. When you now move your mouse over the close button in the panel, the window showing the focus to Libreoffice, and press the close button - the Ubuntu Software-Center instead of LibreOffice is closed.
Pressing another time the close button now closes LibreOffice.

Maybe that bug is corresponding to the bug, that after you closed the last program, the name of that program is still visible in the panel, instead showing "desktop" - and bringing up the desktops feature again, when the mouse clicks on the panel.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic-pae 3.2.12
Uname: Linux 3.2.0-20-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 1.95-0ubuntu1
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Tue Mar 27 12:12:32 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120301)
MachineType: ASUSTeK Computer INC. 1000H
ProcEnviron:
 TERM=xterm
 LANG=de_DE.UTF-8
 SHELL=/bin/zsh
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-20-generic-pae root=UUID=2ce57d49-82cb-45c4-b4d5-4b5e7481e016 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/17/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1206
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1000H
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1206:bd10/17/2008:svnASUSTeKComputerINC.:pn1000H:pvrx.x:rvnASUSTeKComputerINC.:rn1000H:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 1000H
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.
version.compiz: compiz 1:0.9.7.2-0ubuntu4
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
To post a comment you must log in.