"Show desktop" in alt-tab doesn't always work

Reported by Alan Pope ㋛ on 2012-03-27
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Brandon Schaefer
unity (Ubuntu)
High
Brandon Schaefer

Bug Description

Open some apps
Alt+Tab through to "Show desktop"
Note that it doesn't always work.

http://www.youtube.com/watch?v=2JjlBc68pMc

----------------------
Desired solution:

- The first time a user selects the "Show desktop" option (either via the Launcher icon, keyboard shortcut or using ALT-TAB) all windows on all monitors on the currently visible workspace only should be minimised.

- When the user selects the "Show desktop" option a second time *if the user has not opened any new windows or un-minimised any windows after selecting the "Show desktop" option the first time*, all the windows that were minimised the first time "Show desktop" option was selected should be restored back to their previous states.

 - When the user selects the "Show desktop" option a second time *if the user has opened any new windows and/or un-minimised any windows* all windows on all monitors on the currently visible workspace only should be minimised.

Related branches

lp:~brandontschaefer/unity/lp.966030-fix
Merged into lp:unity at revision 3380
Marco Trevisan (Treviño): Approve on 2013-06-21
PS Jenkins bot: Approve (continuous-integration) on 2013-06-20
lp:~brandontschaefer/unity/show-desktop-fix
Merged into lp:unity at revision 3425
PS Jenkins bot: Approve (continuous-integration) on 2013-07-12
Christopher Townsend: Approve on 2013-07-11
Marco Trevisan (Treviño): Approve on 2013-07-01
Alan Pope ㋛ (popey) wrote :
Omer Akram (om26er) wrote :

Uh, I can reproduce it as well.

Changed in unity:
status: New → Confirmed
Omer Akram (om26er) on 2012-07-24
Changed in unity:
importance: Undecided → Medium

Im pretty sure this is because Show Desktop also restores windows.

So the first time you use Show Desktop, it hides all the windows.
Then you restore the windows by clicking on the icons.
Then you use Show Desktop again. Now it thinks you want to restore every single window.

So its more a toggle....hide all, restore all, hide all, restore all...etc.

Hmm Im not sure if there is a 'correct' solution.

It could be assumed if any windows were restored then the Show Desktop toggle would reset. So the next call would hide them all again. Or if all the windows that were hidden by show desktop were restored that it would reset the toggle. (Not sure how feasible)

Dac Chartrand (conner-bw) wrote :

I also have this bug.

Show desktop = Minimize all windows and show the desktop. it's a two word sentence with one possible outcome. Simple.

It shouldn't be called "Show Desktop" if it's a toggle... Confusing.

Thank you for your consideration.

Changed in ayatana-design:
status: New → Confirmed
John Lea (johnlea) on 2013-01-24
Changed in unity:
status: Confirmed → Triaged
Changed in ayatana-design:
status: Confirmed → Triaged
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: Triaged → Fix Committed
tags: added: udp
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
John Lea (johnlea) on 2013-04-04
tags: removed: udp
no longer affects: ayatana-design
Changed in unity:
status: Triaged → New
Changed in unity (Ubuntu):
status: Confirmed → New
Changed in unity:
importance: Medium → Undecided
Dac Chartrand (conner-bw) wrote :

Still a problem in Ubuntu 13.04

"Show desktop" is a simple two word sentence that can have only one outcome.

"Hide Desktop" is not one of them.

Thank you for your consideration.

This is intended behavior, marking as incomplete and Ill add design to see what they have to say.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
John Lea (johnlea) on 2013-05-15
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in ayatana-design:
status: New → Triaged
Changed in unity:
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Triaged
Changed in ayatana-design:
status: Triaged → Fix Committed
tags: added: udp
Stephen M. Webb (bregma) on 2013-05-28
Changed in unity:
milestone: none → 7.1.1
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress

A question for design:

What is expected behavior when we do a show desktop and the current workspace is hidden. Then we move to the next workspace? My understanding is once we focus a new window, or a new window is mapped, or we unminimize a window then we no longer want to restore any miminzed windows. Just wanted to check if changing window focus falls under this as well. Thanks!

John Lea (johnlea) wrote :

@brandontschaefer; clarify what you mean by 'the current worskpace is hidden'?

To my knowledge one workspace is always visible, and that is the current workspace.

The show desktop interaction should be limited to the currently visible workspace. All the state described in the bug report should be *per workspace*.

This means that for example, if the user selects Show Desktop on Workspace A, then immedatly afterwards switches to Workspace B, any windows that were previously visible on workspace B should still be there (they should not have been affected by the Show Desktop command the user triggered while on Workspace A). If the user then goes back to Workspace A some time later, and they trigger the Show Desktop command a second time, the hidden windows should be restored because the user has not interacted with any windows on Workspace A subsequent to the first time they triggered the Show Desktop command on workspace A.

If this doesn't answer your question ping me on IRC when you get this message.

thanks!

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.0

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.0.0daily13.06.24-0ubuntu1

---------------
unity (7.0.0daily13.06.24-0ubuntu1) saucy; urgency=low

  [ Brandon Schaefer ]
  * Show desktop now only works for individual workspaces. Also if any
    new windows are opened, or one is restored on that workspace then
    the next Show desktop will minimize those. The only time windows are
    restored are when no new windows have been mapped, and no windows
    have been restored for that workspace only. (LP: #966030)
  * When on the bottom row and you press down, the detail index now
    moves right until it hits the last icon in the row.

  [ Chris Townsend ]
  * Draw the full panel shadow when there are windows docked on the
    panel and no focused windows on the screen such as when the desktop
    has been clicked. (LP: #1036614)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3382
 -- Ubuntu daily release <email address hidden> Mon, 24 Jun 2013 05:42:36 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Łukasz Zemczak (sil2100) wrote :

The fix for this bug causes regressions related to autopilot handling. I think the code in the fix is not entirely correct as well - it assumes that when there are no windows visible, we are in showdesktop mode, which is not correct.

For now, I recommend reverting the fix, as show desktop is not being used that much anyway:
https://code.launchpad.net/~sil2100/unity/revert_r3380_showdesktop/+merge/171781

Łukasz Zemczak (sil2100) wrote :

Reverted in trunk.

Changed in unity:
status: Fix Committed → Triaged

Yeah, I've a new branch that fixes this, though that assumption didn't cause any problems on the user side of things ;).

Ill try to get sometime to run the AP tests over the branch now before it merged!

Thanks for looking into the AP failures :)

Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Fix Released → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.0

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package unity - 7.0.2+13.10.20130723.1-0ubuntu1

---------------
unity (7.0.2+13.10.20130723.1-0ubuntu1) saucy; urgency=low

  [ Marco Trevisan (Treviño) ]
  * debian/control:
    - build-depend on xserver-xorg-video-dummy and libgl1-mesa-dri
    - build-depend on libnux-4.0-dev (>= 4.0.2+13.10.20130718.1)

  [ Michal Hruby ]
  * When requesting a channel from scopes, use the DIFF flag, which will
    cause scopes machinery to do a diff between the old and new model
    states, so results that didn't change will stay in the model -
    previously they would be removed and re-added.
  * Reset the connected property when scope disappears.
  * Added getter for content-type property to Category class.
  * Manually merged lp:~mhr3/unity/fix-ap-preview-tests
  * Preload results after removal, as they might got moved into a
    visible position.
  * Fix scope-related tests. (LP: #1199961)

  [ Brandon Schaefer ]
  * Correctly set back the filter scroll views state when
    leaving/entering the scope view. (LP: #1175666)
  * Don't calculate the velocity if dtime is 0. This way we don't get a
    huge velocity on the initial barrier hit. (LP: #1199050)
  * Show desktop now only works for individual workspaces. Also if any
    new windows are opened, or one is restored on that workspace then
    the next Show desktop will minimize those. The only time windows are
    restored are when no new windows have been mapped, and no windows
    have been restored for that workspace only. (LP: #966030)

  [ Marco Trevisan (Treviño) ]
  * CMake: re-enable DBus Tests, excluding TestScope* This exclusion is
    due to lp:1199961 to be fixed ASAP. (LP: #1199961, #1199962)
  * TestGtest: Addedd TestPanelService and new tests to
    TestStaticCairoText, removed test-unit Improved the u-p-s stability
    and refactored a little its initialization to allow testing with
    only mock indicators. (LP: #1200748)
  * GLibDBusServer: set the proper destroy function when resetting the
    InterfaceInfo ptr.

  [ Didier Roche ]
  * Adjust CMake setup to account for new GMock version. . (LP:
    #1185265)

  [ Chris Townsend ]
  * Modify the Launcher icon of an installing app to display
    "Installing..." instead of always saying "Waiting to install". (LP:
    #966189)

  [ Thomas Voß ]
  * Adjust CMake setup to account for new GMock version. . (LP:
    #1185265)

  [ Nick Dedekind ]
  * Removed the legal link and icon from the dash. .
  * Reverted r3415 "remove legal link" -
  * Removed the legal icon, again.

  [ Manuel de la Pena ]
  * Fix the introspection so that QA can work with autopilot. (LP:
    #1185486)

  [ Charles Kerr ]
  * in panel-service.c's load_indicators_from_indicator_files(), plug a
    GDir leak.

  [ Pawel Stolowski ]
  * Activate (installed) applications on single left-click in Home and
    Applications scopes view. (LP: #1189088)

  [ Andrea Azzarone ]
  * Define/Init UnityWindow::cWindow. (LP: #1203129)

  [ Jeremy Bicha ]
  * Drop unnecessary python-gconf dependency.

  [ Łukasz 'sil2100' Zemczak ]
  * Disable the TestAnimationOpacity test, as it's failing on powerpc.

  [ Ubuntu daily release ]
  * Automatic snapshot from ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Dac Chartrand (conner-bw) wrote :

Testing 13.10... Sorry, how is this fixed?

If I were to sit next to you at your computer, put my arm around your shoulder and ask you: "Show me the Desktop"

What would you do? Load up a Firefox window? What if I asked you again "Show me the Desktop"

Would you do something different than, say, show the desktop?

The same feature on Windows 7: Click the "Show Desktop" button and all windows are minimized to show the Desktop. (The thing with the wallpaper on it) Click the button again twice? Still showing the Desktop.

What feature are you developing here?

You need to either

1) Show the Desktop and only the desktop, no matter the state.

Or:

2) Change the state from "Show Desktop" to "Show Windows," which hasn't been done, so not fixed.

Cheers.

Dac Chartrand (conner-bw) wrote :

Note/correction: Just checked Windows 7, I'm wrong.

The feature toggles to "Show Open Windows" on the "other" OS task bar (when right clicking). ALT+TAB merely says "Desktop" and does indeed toggle.

That said the label of "Desktop" is less confusing than "Show Desktop," which is an instruction.

Regards,

Hi Dac,

For this particular bug, Ayatana Design added feedback in the bug description under "Desired solution" for how they want Show Desktop to work. Since your latest comment in more about the wording, I think you should enter a new bug and then we can ask Ayatana Design for their feedback.

Thanks!

Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers