Panel is transparent when Dash is open; no blur no average BG color

Bug #965323 reported by Omer Akram on 2012-03-26
80
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Andrea Cimitan
unity (Ubuntu)
High
Andrea Cimitan

Bug Description

On one of my old netbooks I see the attached screenshot on today's LiveCD of Precise

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0+bzr2168ubuntu0+675 [origin: LP-PPA-unity-team-staging]
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic-pae 3.2.12
Uname: Linux 3.2.0-20-generic-pae i686
ApportVersion: 1.95-0ubuntu1
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CrashDB: unity
Date: Mon Mar 26 19:08:18 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120325)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Omer Akram (om26er) wrote :
Revision history for this message
Omer Akram (om26er) wrote :

00:02.1 Display controller: Intel Corporation N10 Family Integrated Graphics Controller (rev 02)

Omer Akram (om26er) on 2012-03-26
Changed in unity:
importance: Undecided → High
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in unity:
milestone: none → 5.10.0
tags: added: regression-release
Revision history for this message
David Barth (dbarth) wrote :

Looks like yet another GL issue with this chipset.

Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
Changed in unity (Ubuntu):
assignee: nobody → Jay Taoko (jaytaoko)
Revision history for this message
David Barth (dbarth) wrote :

Assigning to Jay. Jay: if the quality of this chipset/driver is not sufficient for an LTS, I recommend to exclude it from the list of supported chipsets and enable 2d by default instead.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Please don't kill Unity3D support for netbook users. It works perfectly other than this (low severity) bug.

Revision history for this message
Omer Akram (om26er) wrote :

@Daniel, this is by no mean a low severity bug if we are to present Unity (3d) on netbooks. It looks ugly and going for unity-2d is a far superior choice if we don't get a fix for this bug.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Last time I saw this bug it did look very minor and fixable. It's only the panel and only while the dash is open...

Revision history for this message
Omer Akram (om26er) wrote :

The screenshot in the first comment does not look minor at all. Dash is the place to launcher apps, music, video and other files hence the most widely used part of Unity. Not to mention HUD which look bad with this bug as well. Since unity's emphasis is on design and beauty this bug is not minor for a desktop interface.

Revision history for this message
Dimitar Dimitrov (dimitrov) wrote :

Same bug here on my MSI Wind U100 netbook. I'm experiencing this bug only in Unity 5.8, 5.6 was fine.

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

Revision history for this message
Schneider (schneider-ein) wrote :

Activate the "Blur windows" in compiz, shutdown and open again your computer... that's all

Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: 5.10.0 → 5.12.0
Revision history for this message
Andrea Cimitan (cimi) wrote :

I had a look at this, and I found the issue:
Line 369-370 (and maybe 294-295, didn't test this yet) of PanelView.cpp, the bg layer is only drawn when the dash is not opened, which seems wrong. Drawing it when the overlay is opened fixes the bug for me.

Not sure whether is has to be drawn *only* when the overlay is opened or in both cases. Not sure if this has to apply on non-GLSL only or other cards as well.

Was originally changed here: https://code.launchpad.net/~unity-team/unity/new-dash-blending/+merge/94472

Revision history for this message
Andrea Cimitan (cimi) wrote :

I tested further and I confirm that lines 294-295 need to be patched too, otherwise the bug is present until DrawContent is called.

Didier Roche (didrocks) on 2012-04-17
Changed in unity:
importance: High → Medium
Changed in unity (Ubuntu):
importance: High → Medium
Revision history for this message
Omer Akram (om26er) wrote :

I still think its a higher priority bug, Unity experience looks completely broken for quite a large number of users with this bug.

Revision history for this message
Andrea Cimitan (cimi) wrote :
Andrea Cimitan (cimi) on 2012-04-17
Changed in unity:
assignee: Jay Taoko (jaytaoko) → Andrea Cimitan (cimi)
Changed in unity (Ubuntu):
assignee: Jay Taoko (jaytaoko) → Andrea Cimitan (cimi)
Omer Akram (om26er) on 2012-04-17
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity (Ubuntu):
importance: Medium → High
tags: added: rls-mgr-p-tracking
Andrea Cimitan (cimi) on 2012-04-17
Changed in unity:
importance: Medium → High
Revision history for this message
Martin Pitt (pitti) wrote :

Release team wise this seems fine to me, assuming that this was regression tested properly.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.10.0-0ubuntu6

---------------
unity (5.10.0-0ubuntu6) precise-proposed; urgency=low

  * Cherry-picked upstream:
    - Panel is transparent when Dash is open on netbooks; no blur
      no average BG color (LP: #965323)
 -- Didier Roche <email address hidden> Tue, 17 Apr 2012 18:04:01 +0200

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Adolfo Jayme (fitojb) on 2012-04-22
Changed in unity:
status: In Progress → Fix Released
Omer Akram (om26er) on 2012-04-26
Changed in unity:
status: Fix Released → Fix Committed
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers