Show desktop icon should be moved, definitely not on top of BFB

Reported by Michael Rawson on 2012-03-24
138
This bug affects 34 people
Affects Status Importance Assigned to Milestone
Unity
Low
Michael Rawson
unity (Ubuntu)
Wishlist
Michael Rawson
Precise
Wishlist
Michael Rawson

Bug Description

SRU testcase

1. go to Unity plugin under CCSM
2. enable the show desktop icon in the launcher
3. see its on top of BFB
4. install unity from precise-proposed
5. note the icon is not above BFB.

Currently when you enable the "Show Desktop" option in ccsm experimental it is positioned above the dash icon. However, as per the design the dash icon should always be at the top.

Also The "Show Desktop" icon should be movable to where the user wishes.

System Info:
Ubuntu 12.04, Unity 5.8, Compiz 0.9.7.2

I'm making a branch to fix this.

description: updated
Changed in unity (Ubuntu):
assignee: nobody → michaelrawson (michaelrawson76)
Changed in unity:
assignee: nobody → michaelrawson (michaelrawson76)
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-03-26
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
status: Confirmed → In Progress
milestone: none → 5.12.0
importance: Undecided → Medium
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Low → Wishlist
Changed in unity:
importance: Medium → Wishlist
Changed in unity:
importance: Wishlist → Medium
Omer Akram (om26er) on 2012-04-26
Changed in unity (Ubuntu):
importance: Wishlist → Low
Changed in unity:
importance: Medium → Low
importance: Low → Wishlist
Changed in unity (Ubuntu):
importance: Low → Wishlist
Changed in unity:
importance: Wishlist → Low
description: updated
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
status: Fix Committed → Fix Released

Hello Michael, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

Fixed!

tags: added: verification-done
removed: verification-needed
Drzorcz (drzorcz) wrote :

I'd say it's fixed ONLY in 50%. Yes, now the icon is at the bottom of the launcher, but it is still not movable. The fix seems just to move teh icon from top to the bottom (right below the workspace switcher) of the launcher. Or it doesn't work for me only?

It would also be great if sb takes a look at another bug related to this one, reported by me:
https://bugs.launchpad.net/unity/+bug/971534

Making long story short: the icon does not follow the transparecy pattern, as 'Dash Home', 'Trash' or 'Workspace Switcher' do.

Drzorcz, these are all separate bugs. the Issue in the placement of the icon has been fixed.

Michael Rawson (michael.rawson) wrote :

Hi Drcorz, the current implementation only allows for it to be non-movable. We're waiting on a 'mini-app' or so I'm told.

The transparency model works for me.

Drzorcz (drzorcz) wrote :

Hi,

1) Chauncellor, the bug is: 'Show desktop icon should be movable, definitely not on top of BFB', so, IMHO, we cannot say it's fixed until the icon is movable. Now it is still NOT, it has just been moved from top to the bottom of the launcher.

2) Michael, thanks for the info about 'mini-app'. As far as the 'transparency' is concerned, there's been a lot of misunderstanding and the bug I reported was - very unfortunately - considered as a duplicate of the other 'transparency' bug. This is not what I meant. I did not report the situation in 'backlight toggle' mode, where it's all about transparency. My problem is with 'backlight always on'. Please, have a look the screenshot I've attached to the bug - you'll see what I mean.

Drzorcz, the title looks like a typo.

Please report a new bug - Do not put two issues in one bug report.

summary: - Show desktop icon should be movable, definitely not on top of BFB
+ Show desktop icon should be moved, definitely not on top of BFB
Drzorcz (drzorcz) wrote :

Chauncellor,

in Michael's report we can read: "Also The "Show Desktop" icon should be movable to where the user wishes.", so it's definitely not a typo, but I understand what you mean. :) I'll look for another report with this bug and if there's none, I'll re-report it.

Thanks for co-op.

^^ sorry for the confusion guys, I really shouldn't do that. Having done the code, it became apparent that it being movable was not realistic option if I wanted it done quickly. And if I didn't, then I may as well code the "mini-app".

Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.12-0ubuntu1

---------------
unity (5.12-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Launcher, Alt-Tab - clicking on launcher item or selecting a app in Alt-
      Tab raises all app windows, not just most recently focused (LP: #959339)
    - [heap corruption?] compiz crashed with SIGSEGV in _int_malloc() from
      g_realloc() from ... from g_dbus_connection_send_message_with_reply()
      from g_object_unref() from unity::dash::HomeLens::Impl::~Impl() from
      unity::dash::HomeLens::~HomeLens() (LP: #931201)
    - compiz crashed with SIGSEGV in _int_malloc() from __libc_calloc() from
      XOpenDisplay() from nux::WindowThread::ThreadCtor() (LP: #947844)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Window management - unity doesn't realise when applications bring their
      windows to the front (LP: #802816)
    - Dash - Clicking on the desktop dash border should do nothing, *NOT*
      close the dash (LP: #839472)
    - [FFe, UIFe] HUD - The HUD does not respect launcher icon size settings
      in autohide mode (LP: #921506)
    - compiz crashed with SIGSEGV in g_volume_get_mount() (LP: #918548)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - Panel is transparent when Dash is open; no blur no average BG color
      (LP: #965323)
    - Unity crashes with SIGSEGV when hitting debug DBus interface hard
      (LP: #979429)
    - compiz crashed with SIGSEGV in _int_malloc() from g_object_unref() from
      unity::dash::Model<unity::dash::FilterAdaptor>::~Model() (LP: #941750)
    - indicators menu are sometimes cut off at screen edge (LP: #883317)
    - the shortcut keys in workspace section of the shortcut overlay aren't
      translated (LP: #980828)
    - [regression] Dash keeps repainting unnecessarily (LP: #980924)
    - compiz crashed with SIGSEGV in nux::NTextureData::ClearData() from
      nux::NTextureData::~NTextureData() from nux::Texture2D::~Texture2D()
      (LP: #952378)
    - compiz crashed with SIGSEGV in g_object_unref() from
      unity::dash::Settings::~Settings() from
      unity::UnityScreen::~UnityScreen() (LP: #981764)
    - compiz crashed with SIGSEGV in unity::dash::ResultView::~ResultView()
      from unity::dash::ResultViewGrid::~ResultViewGrid() from
      nux::Object::Destroy() from nux::Object::UnReference() (LP: #942286)
    - compiz crashed with SIGSEGV in
      ends_with_iter_select<__gnu_cxx::__normal_iterator<char const*,
      std::basic_string<char> >, char const*, boost::algorithm::is_iequal>()
      from unity::ui::PointerBarrierWrapper::EmitCurrentData() (LP: #983268)
    - Chinese can't be shown completely in dash filter (LP: #984583)
    - [Unity 5.10] compiz crashed with SIGSEGV in
      unity::hud::HudIconTextureSource::ColorForIcon() from
      unity::hud::Icon::Icon() from emit from unity::IconTexture::IconLoaded
      (LP: #983646)
    - [regression] Close button does not close the dash/HUD (LP: #986264)
    - compiz crashed with SIGSEGV in g_volume_eject_with_operation_finish()
      fro...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers