Dash picking a really odd color with default wallpaper

Bug #963140 reported by Omer Akram on 2012-03-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Unassigned
gnome-desktop3 (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

bzr2165

If I set the default wallpaper as desktop background I see a really odd color in unity dash. If I use any other wallpaper dash inherits the right color. Its only happening for the default wallpaper for me. see the attached screenshot

I have also rebooted the system twice but still the same.

Omer Akram (om26er) wrote :
Omer Akram (om26er) on 2012-03-26
no longer affects: unity (Ubuntu)
Omer Akram (om26er) wrote :

that's some config fault. I'll close the issue now as I made it to work fine

Changed in unity:
status: New → Invalid
Omer Akram (om26er) wrote :

It seems I am not the only one who have this issue. reopening

Changed in unity:
status: Invalid → Confirmed
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed

There is a dirty way to fix it:
Go to /usr/share/backgrounds and rename warty-final-ubuntu.png to whatever-you-want.png (as in whatever name you want). Doing that will fix the bug, but will make it unavaivable in the OTB wallpaper list, so go to /usr/share/gnome-background-properties and edit the ubuntu-wallpapers.xml. The first entry is the default wallpaper, rename "<filename>/usr/share/backgrounds/warty-final-ubuntu.png</filename>" to "<filename>/usr/share/backgrounds/whatever-you-want.png</filename>"
After that reboot and it should be fine.
However according to @om26er (and I'm willing to agree with him), the BG color is written in libgnome-desktop there must be a problem somewhere in that code. A few days ago it was saved in dconf now its moved to libgnome-desktop and the issue started after that.

Didier Roche (didrocks) on 2012-04-06
Changed in unity:
milestone: none → 5.10.0
assignee: Mirco Müller (macslow) → nobody
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop3 - 3.4.0-0ubuntu4

---------------
gnome-desktop3 (3.4.0-0ubuntu4) precise; urgency=low

  * debian/patches/04_compute_average_color.patch:
    - compute the avergage color in gnome-desktop itself, not in unity to fix
      some races (LP: #963140)
 -- Didier Roche <email address hidden> Fri, 06 Apr 2012 16:38:09 +0200

Changed in gnome-desktop3 (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers