Launcher shows arrows for applications on all workspaces

Reported by Łukasz Zemczak on 2012-03-22
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
High
Marco Trevisan (Treviño)
Unity Distro Priority
High
Unassigned
unity (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

Failed checkbox-unity testcase launcher/arrows-notin-currentws (on step 5). When an application is opened on more than one workspace and there is an application window on the current workspace, the arrows on the launcher show the count for all applications on all workspaces. By design it should be only the windows on the current workspace.

How to reproduce:
1. Start nautilus on workspace 1
2. Switch to workspace 2
3. Start a new nautilus window on workspace 2

Expected result:
Launcher shows one arrow to the left of the nautilus icon.

Actual result:
Launcher shows two arrows to the left of the nautilus icon.

Didier Roche (didrocks) on 2012-03-22
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → High
Changed in unity:
status: Triaged → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Omer Akram (om26er) on 2012-03-23
Changed in unity:
milestone: none → 5.8.0
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.8.0-0ubuntu1

---------------
unity (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - New "push mouse offscreen" feature really difficult to get (LP: #923749)
    - unity-2d-panel crashed with SIGSEGV in
      unity::indicator::DBusIndicators::Impl::RequestSyncAll() (LP: #864737)
    - Pressing "Alt+Enter" causes compiz to crash in CompOption::value() from
      unity::UnityScreen::showLauncherKeyTerminate (LP: #960957)
    - SEGSIGV after unplugging external monitor (LP: #962693)
    - Background colorization should use a different heuristic (LP: #865239)
    - compiz+unity3d generates > 50 wakeups a second on idle system
      (LP: #917210)
    - [FFe, UIFe] HUD - The HUD does not respect launcher autohide or icon
      size settings (LP: #921506)
    - clicking on folders in the file lens does not open nautilus
      (LP: #921665)
    - No text inside multirange filters (LP: #927710)
    - can't alt-tab restore minimized uis which have an instance on another
      workspace (LP: #933397)
    - Ubuntu Software Center Unity launcher integration is not working
      (LP: #932280)
    - The line separator between the launcher and the dash is cleared when
      selecting a category (LP: #941082)
    - unity-panel-service crashed with SIGSEGV in g_hash_table_foreach()
      (LP: #937119)
    - Alt-F10 locks up Unity (LP: #948522)
    - multimonitor, launcher: Provide an option to display either a single
      launcher or a launcher on each display in a multi-monitor environment
      (LP: #950136)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - Unity 5.6: key bindings (such as Super) don't work on empty workspace or
      on slow/loaded systems (LP: #953089)
    - Alt+arrows keyboard shortcuts don't invoke Back and Forward navigation
      (LP: #953783)
    - HUD is sending 2 menu signals instead of 1 (LP: #956878)
    - 6th item of HUD not fully visible (LP: #957229)
    - HUD: seems to trigger operations more than once (LP: #960503)
    - Launcher gets always desaturated when using HUD on secondary monitor
      (LP: #961169)
    - [5.8 pre staging] launcher is displayed on the left screen, not the
      primary one (LP: #961281)
    - launcher icons do not re-saturate after dash is closed (LP: #961844)
    - Launcher shows arrows for applications on all workspaces (LP: #961977)
    - Dash - Implement overlay scrollbars in Dash (LP: #608124)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - Dash - Missing category separator line in dash (LP: #850984)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - When multiple results have equal string match relevancy ranking,
      those with equal ranking should be then sorted by frequency of use.
      (LP: #871900)
    - Keyboard shortcut - F10 shortcut is used to show m...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-04-17
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Bevor (bugs-devgems) wrote :

Why is this a bug? In my opinion it is a bug that it DOES NOT show arrows of all workspaces. Now you don't see by arrows where you've opened instances of the same application anymore, if they are sahred on different workspaces. How can this be the right behavior?

Grischa Brockhaus (gbrockhaus) wrote :

I think the same. The behavior we had before 12.04 was a lot better in my opinion.
*Please* make it configurable at least, so we can have it back.. :-/

I agree with #2 and #3. I often have two or three Firefox windows on different workspaces. If I want to switch from one to another, I need to manually switch workspaces, whereas if there is another application open only on another workspace, I can switch to that one using the icon in the launcher. That is unituitive.

Eddie Dunn (eddie-dunn) wrote :

This is a horrible change. Now I have no way to know if there are other windows of the same application open on other workspaces, unless I manually go to every single workspace to check, since sometimes a window of the same application but on a different workspace is hidden by some other application window.

We either need to change so that Expo also activates Scale, similarly to what kwin does, or retract this change as it really makes working with applications on multiple workspaces a chore.

Nate Gingras (suboscillator) wrote :

From a non-technically-inclined user perspective (I support over 150 Ubuntu users at my job) I can tell you this "fix" results in users losing track of already open applications/documents and launching them again. I get several users per week asking me why they are trying to open a document and nothing happens. They do not see the icon jiggling to tell them it's on another workspace.

Keep in mind these are the "Human Beings" Ubuntu is supposed to be for.

VladimirCZ (vlabla) wrote :

I do not understand what wrecked mind can expect that the launcher icon should indicate only instances from the same workplace. Such stupid behaviour disables indication that the same file(s) may be used by an instance of the same application displayed on another worspace. This fix indeed implements wrong functionality which is more ill than the replaced one.

Please, keep the original functionality (all workplaces) as default and the new one (only current workplace) as an option.

Friend of mine are affected by this 'fix', so -1 of this 'patch'

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers