Keyboard shortcuts - dash home does not minimize with ctrl-super-D

Reported by 2green on 2012-03-22
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Christopher Townsend
unity (Ubuntu)
Medium
Christopher Townsend

Bug Description

I'm not sure if this is a bug or a feature request. I'm going for a bug because this feature blocks an efficient work proces using ctrl-super-d to go to your desktop.

* steps to reproduce

- open firefox
- open dash home
- minimize your windows by pressing ctrl-super-d

* expected behavior

firefox and dash home are minimized

* current behavior

Neither firefox or the dash home is minimized, there seems to be a flicker in the screen when pressing ctrl-super-d.

all screens and windows should be minimized when pressing ctrl-super-d to ensure an expected behavior when using this keyboard shortcut. Its also neccessary for an efficient work process (kind of important on a desktop computer).

* Extra information

At this moment there seems no shortcuts working when there is an active unity menu item opened. e.g. no shortcut is working if dash home is opened, or any of the dropdowns in the upper right corner (switch user account, time and date settings, etc). An solution that solves these generic problems is prefered.

--------------------------------------------------
Desired resolution:

- Pressing "Ctrl+Super+D" should minimise both the Dash (if it is open) and all windows.

( See http://tinyurl.com/chxs485 for the full list of Unity keyboard shortcuts )

Related branches

lp:~townsend/unity/fix-lp961890
Merged into lp:unity at revision 3618
PS Jenkins bot: Approve (continuous-integration) on 2014-01-09
Brandon Schaefer: Approve on 2014-01-09
2green (zendhetmij) on 2012-03-22
tags: added: unity
affects: dash (Ubuntu) → unity (Ubuntu)

apport information

tags: added: apport-collected precise
description: updated

apport information

Omer Akram (om26er) on 2012-03-25
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
John Lea (johnlea) on 2012-04-24
description: updated
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
Changed in unity:
milestone: none → backlog
tags: added: keybinding
summary: - dash home does not minimize with ctrl-alt-D
+ Keyboard shortcuts - dash home does not minimize with ctrl-alt-D
2green (zendhetmij) on 2012-05-27
description: updated
Tim Penhey (thumper) on 2012-06-11
Changed in ayatana-design:
status: Triaged → Fix Committed
Omer Akram (om26er) on 2012-07-24
summary: - Keyboard shortcuts - dash home does not minimize with ctrl-alt-D
+ Keyboard shortcuts - dash home does not minimize with ctrl-super-D
description: updated
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
John Lea (johnlea) on 2012-10-12
Changed in ayatana-design:
importance: High → Medium
Changed in unity:
importance: Low → Medium
Changed in unity (Ubuntu):
importance: Low → Medium
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
2green (zendhetmij) wrote :

Retested on 13.04 with latest updates. Problem stil exists.

2green (zendhetmij) wrote :

Retested on 13.10, problem stil exists... although it is slightly improved. Everything seems to minimize except the dash screen. Looks better this way, but still blocks and efficient workprocess.

Stephen M. Webb (bregma) on 2013-10-10
Changed in unity:
milestone: none → 7.2.0
Christopher Townsend (townsend) wrote :

I think the design needs to be adjusted some for this. There is no concept of a "minimized" Dash. The Dash is either opened or closed.

The following needs Design input:

- If the Dash is open, what happens to the Dash the first time Ctrl-Super-D is hit? Does is stay open or should it close?

- If the answer to above is to close the Dash, what happens when Ctrl-Super-D is hit again? Does it stay closed or shall it open again?

Changed in ayatana-design:
status: Fix Committed → Incomplete
Changed in unity:
assignee: nobody → Christopher Townsend (townsend)
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Christopher Townsend (townsend)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision 3618, scheduled for release in unity, milestone 7.2.0

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (18.5 KiB)

This bug was fixed in the package unity - 7.1.2+14.04.20140214.1-0ubuntu1

---------------
unity (7.1.2+14.04.20140214.1-0ubuntu1) trusty; urgency=low

  [ Sebastien Bacher ]
  * use unity-control-center by default.
  * lists keybinding in unity-control-center. (LP: #1271710)

  [ Brandon Schaefer ]
  * Bump to new libnux from this branch:
    https://code.launchpad.net/~brandontschaefer/nux/xim-preedit-
    support.
  * Adds Super+L to lock the screen, while keeping the older shortcut
    around in g-s-d (Ctrl+Alt+L). (LP: #830709)
  * Do not open the dash/hud on a monitor with a top most window that is
    fullscreen. (LP: #1267210)
  * Implement an EMConveter. This way with default settings such that
    DPI = 96.0f, and font_size = system font size. We can get the
    correct EM value for any pixel size. Once we have the correct EM
    value for any pixel size, the DPI value can be adjusted to the
    current logical one. From here, you can now get the correct pixel
    size based from of the EM value for the logical DPI of the screen.
  * Refactor EMConverter API. Now all thats needed is int
    ConvertPixels(int pixel); This will calculate the correct pixel size
    based on the DPI and font size.
  * Testing that the ibus anthy tests could possibly be causing strange
    issues on the nvidia machine. So skipping them to test if tihs is
    the source of the error.
  * Add Pt to Px function to em converter.
  * Move EMConverter over to unity settings.
  * Add multi monitor support for EMConverter in unity settings. Now you
    can grab a specific converter per monitor.
  * Simple RawPixel class. It adds 2 define literals, ex: 10_em,
    10.0_em. From there it turns them into raw pixels. RawPixels have CP
    (CovertPixel) function which takes in an EMConverter that allows you
    to use a converter specific to a monitor to convert the raw pixel to
    the correct value.

  [ Marco Trevisan (Treviño) ]
  * Don't re-present all of our windows on every frame. Only do that if
    damage intersects it. Use the new APIs exposed by compiz and nux to
    intelligently determine which windows need to be presented per-frame
    and only register damage for those windows. This fixes two things:
    1. BaseWindows being redrawn from scratch every time damage was
    registered over them. That was incorrect and should only be done in
    the case of background blurs. 2. BaseWindows being drawn to the
    screen on every frame, regardless of whether or not they needed to
    be. Now they will only be drawn if some damage intersects beneath
    them. Note that unity will expand the damage region to accomadate
    the base window since nux does not support geometry clipping. So if
    there is a partial intersection of the launcher for example, the
    area of the screen which contains the launcher will be re-painted
    (but the launcher itself won't be redrawn, just its texture) (LP:
    #1080947). (LP: #1080947)
  * Convert compiz regions / rects to nux::Geometry's and back easily.
  * UnityScreen: remove the useless and expensive gl{Push,Pop}Attrib
    calls For some reasons this code was copied by the opengl plugin as
    a workaround to fix the s...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.2.0.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers