Switcher remains open after super+tab has been used.

Bug #960652 reported by Thomi Richards on 2012-03-20
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Andrea Azzarone
Unity
Invalid
Medium
Andrea Azzarone
5.0
Invalid
Medium
Unassigned
Unity Distro Priority
Medium
Unassigned
compiz (Ubuntu)
Medium
Andrea Azzarone

Bug Description

To reproduce:

Hit super+tab to activate the BFB, opening the dash home lens.
Hit escape to close the dash.
Hit Alt+Tab as if you wanted to switch to the next application.

The Switcher should close and activate the next application, but instead it remains open. It can be closed by hitting the escape key.

Thomi Richards (thomir) wrote :

Related branch has a failing autopilot test that reproduces the problem. To run it, grab the branch, and then run:

./tools/autopilot run autopilot.tests.test_switcher.SwitcherLauncherInteractionTests.test_switcher_dissapears_after_supertab

Bilal Akhtar (bilalakhtar) wrote :

Reproducible only on trunk, not on Precise versions.

Changed in unity:
status: New → Confirmed
importance: Undecided → Low
milestone: none → 5.8.0
Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Didier Roche (didrocks) wrote :

put as high as it's a regression.

Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → High
Changed in unity:
importance: Low → High
Changed in unity (Ubuntu):
importance: Low → High

I can't reproduce this on trunk... Or using your branch.

Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Didier Roche (didrocks) on 2012-03-23
Changed in unity-distro-priority:
importance: High → Medium
Changed in unity:
importance: High → Medium
Changed in unity (Ubuntu):
importance: High → Medium
David Barth (dbarth) wrote :

It still fails here on 5.8.0+bzr2186ubuntu0+677

I have used the automated test from Thomi's branch

Tim Penhey (thumper) wrote :

The test passes fine for me too. We should find someone this fails for to fix.

Didier Roche (didrocks) wrote :

@Tim: I think you told on an email that Thomi (the bug reporter :p) and Jason got the issue. Maybe Jason can have a look at fixing it then?

Daniel van Vugt (vanvugt) wrote :

This bug is very likely fixed in the fix for bug 963470.

Nekhelesh Ramananthan (nik90) wrote :

Daniel, this bug present still present despite bug 963470 being fixed. You can reproduce this bug by following the steps described in the description.

Andreas Raster (rakete) wrote :

I've reported a similar issue under bug 975677 which is probably related to this one.

Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: 5.10.0 → 5.12.0
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: 5.12.0 → 5.14.0
Changed in unity:
milestone: 5.14.0 → 6.2
Omer Akram (om26er) wrote :

In Ubuntu 12.10 I am not able to reproduce the issue. Is that still an issue for you?

Andrea Azzarone (azzar1) on 2012-07-26
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2012-07-27
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3305

Changed in unity:
status: In Progress → Invalid
Changed in compiz:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Andrea Azzarone (andyrock)
milestone: none → 0.9.8.0
Changed in compiz-core:
status: New → Triaged
importance: Undecided → Medium
milestone: none → 0.9.7.10
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in unity:
milestone: 6.2 → none
Launchpad Janitor (janitor) wrote :
Download full text (7.9 KiB)

This bug was fixed in the package compiz - 1:0.9.8+bzr3319-0ubuntu1

---------------
compiz (1:0.9.8+bzr3319-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/patches/ubuntu-config.patch:
    - refresh with latest trunk
  * debian/*docs:
    - remove the TODO copy now removed upstream
  * debian/compiz-plugins.install:
    - install stackswitch, trip plugins
  * debian/rules, debian/control:
    - remove the compiz gnome-control-center key sedding through metacity.
      Compiz now directly ships them.
    - we do not need metacity-common anymore as a build-dep then
  * debian/compiz-gnome.migrations, debian/control:
    - build-dep on dh-migrations and ship gconf -> gsettings migration file

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Timo Jyrinki ]
  * New upstream snapshot.
    - Fix Compiz crash in movementWindowOnScreen (LP: #1015151)
    - Start window decorator when decor plugin starts (LP: #1014461)
    - Fixed: Crash in compiz::wall::movementWindowOnScreen (LP: #1015151)
    - Don't waste memory leaving /bin/sh running (LP: #1015422)
    - Add reliable detection of the compiz bin directory (LP: #1015898)
    - Check if the window would actually paint before painting the shadow,
      since it is possible that another plugin could be inhibiting paint of
      the dock window. (LP: #1012956)
    - Don't insert the window into the server list above the window it was
      created above. (LP: #1008020) (LP: #886605)
    - makes compiz enhanced zoom and show mouse plugins considerably
      smoother to use (LP: #930783)
    - Don't set decoration contexts on undecorated windows, since that
      might be read later and code will assume the window is decorated when
      it isn't. (LP: #1015593)
    - Fix potentially unterminated string leading to an uninitialized memory
      read (LP: #1018302)
    - Lift the 31/32 character restriction on key names that was causing so
      many warnings. It's now 1024 characters according to glib. (LP: #1018730)
    - Don't print the result of BUILD_DEB. It prevents ccsm et al from
      installing. (LP: #1018916)
    - Use the XDamage extension more efficiently (the way it was designed to be
      used). This dramatically reduces CPU usage, reduces wakeups, and
      increases frame rates. It also solves at least one observed performance
      bug (LP: #1007299) and probably several more.
    - Do the initial work to get libcompizconfig under test. (LP: #990690)
    - Add support for initiating window picker in other than nomal mode. For
      now added only the additional 'All windows' picker (LP: #933776)
      (LP: #955035)
    - Fixes (LP: #1018602) : An invalid read when using g_variant_iter_loop.
    - Don't allow unbinds of textures kept around for animations in any case,
      not just resizing. (LP: #1016366)
    - Wait for the server to finish processing requests before doing a bind
      (LP: #1016367)
    - Using the next/previous bindings the wall plugin didn't calculate
      correctly the next workspace when it reaches the begin or the end of a
      row of workspaces, so it didn't jump to the n...

Read more...

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
Changed in compiz-core:
milestone: 0.9.7.10 → 0.9.7.12
Didier Roche (didrocks) on 2012-12-11
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
no longer affects: compiz-core
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers