Launcher, Alt-Tab - clicking on launcher item or selecting a app in Alt-Tab raises all app windows, not just most recently focused

Reported by William Heslam on 2012-03-19
130
This bug affects 39 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Critical
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Precise
High
Marco Trevisan (Treviño)

Bug Description

What happens:

If an application has multiple windows, clicking once on the launcher icon, or selecting a app icon in Alt-Tab raises all windows.

This bug is only present in Unity3d, Unity2d currently has the correct behaviour. This bug must be fixed as early as possible in Precise because it is not acceptable for clicking on a Launcher icon to do different things in Unity2d and Unity3d.

------------------------

What should happen:

If an application has multiple windows, clicking once on the launcher icon should raise only the most recently focussed window (that is not currently minimised).

If an application has multiple windows, selecting a Alt-Tab icon should raise only the most recently focussed window (that is not currently minimised).

Excluding windows "that are not currently minimised" means that if a application (say 'Terminal') has two windows open (A and B), and the user minimises one window (window A) and then focuses a different application, if the user clicks on the 'Terminal' launcher icon (or selects the 'Terminal' icon in Alt-Tab), window B should be brought to the front of the Z stack and window A should remain minimised.

This behaviour occurs on the latest build of 12.04 beta and unity 5.6.0.

See this comment for a description of what should happen vs. what is actually happening:
http://design.canonical.com/2012/03/task-switching-in-ubuntu-and-a-introduction-to-the-spread/#comment-27356

*IMPORTANT NOTE* - This bug must be fixed for both Alt-Tab and the Launcher at the same time

------------------------

Design references:

- See section "2.8 Launcher" in the "Multiple Monitors UX Specification Phase 1" spec
( http://tinyurl.com/c2nwn7n )

- See heading "Switching Applications" in section "1. The Launcher" which is part of the "Unity Task Switching" spec ( http://tinyurl.com/7qpc2c6 )

Related branches

lp:~unity-team/unity/3v1n0-quick-alt+tab-fixes
Merged into lp:unity at revision 2282
Thomi Richards: Approve (quality) on 2012-04-16
Tim Penhey (community): Approve on 2012-04-16
Sam Spilsbury: Pending requested 2012-04-15
Alex Launi: Pending (quality) requested 2012-04-15
Omer Akram (om26er) wrote :

that sounds like a regression to me. I confirm the behavior that you reported as well.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Omer Akram (om26er) on 2012-03-19
Changed in unity:
milestone: none → 5.8.0
tags: added: regression
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Aibara Iduas (aibaraiduas) wrote :

This is not a regression as it's been happening since Natty. Clicking the launcher when there are multiple windows of an application open actually does different things (see: https://bugs.launchpad.net/unity/+bug/940686). Regardless, it is indeed a bug and only one window should be brought forward.

Omer Akram (om26er) wrote :

now in 11.10 and a few days ago in Precise the behavior was that:

on first click the last minimized window would raise on the second click there will be a spread for all the windows.

Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
William Heslam (willheslam) wrote :

I've tracked down roughly where I think the code has changed to introduce this bug, but without an in-depth knowledge of the codebase (which I don't have!), I'm pretty lost as to where to go from here.

oneiric
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/oneiric/unity/oneiric/view/head:/plugins/unityshell/src/BamfLauncherIcon.cpp#L73

precise:
http://bazaar.launchpad.net/~unity-team/unity/trunk/view/head:/plugins/unityshell/src/BamfLauncherIcon.cpp#L232

and the Focus function itself:

oneiric:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/oneiric/unity/oneiric/view/head:/plugins/unityshell/src/BamfLauncherIcon.cpp#L539

precise:
http://bazaar.launchpad.net/~unity-team/unity/trunk/view/head:/plugins/unityshell/src/BamfLauncherIcon.cpp#L554

Any ideas? I'm not a compiz dev or all that familiar with C++.

William Heslam (willheslam) wrote :

I've attached what I hope is a reasonable portrayal of the wrong behaviour in Unity 3D and the scenario where it is most irritating.

Note that in Unity 2D, the window raising behaviour is correct: only the wikipedia article is raised and the kitten pictures stay behind the gedit essay window.

Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity (Ubuntu Precise):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu Precise):
status: Confirmed → In Progress
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: 5.10.0 → 5.12.0

Can't this be fixed in Unity 5.10 so it is released in 12.04 final? It is a very odd behaviour that really cuts the workflow...

John Lea (johnlea) on 2012-04-13
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
status: New → Fix Committed
tags: added: udp
John Lea (johnlea) on 2012-04-13
Changed in ayatana-design:
assignee: John Lea (johnlea) → nobody
importance: Critical → Undecided
status: Fix Committed → New
tags: removed: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
status: New → Fix Committed
John Lea (johnlea) on 2012-04-13
summary: - clicking on launcher item raises all app windows, not just most recently
- focussed
+ clicking on launcher item or selecting a app in Alt-Tab raises all app
+ windows, not just most recently focussed
description: updated
tags: added: udp
John Lea (johnlea) on 2012-04-13
description: updated
summary: - clicking on launcher item or selecting a app in Alt-Tab raises all app
- windows, not just most recently focussed
+ Launcher, Alt-Tab - clicking on launcher item or selecting a app in Alt-
+ Tab raises all app windows, not just most recently focussed
John Lea (johnlea) on 2012-04-13
Changed in unity:
importance: Medium → Critical
description: updated
John Lea (johnlea) on 2012-04-13
description: updated

@stephane-guillou; this bug seems to have just missed the 5.10 deadline, but it is a critical issue so should be fixed in Unity 5.12

Omer Akram (om26er) on 2012-04-13
summary: - Launcher, Alt-Tab - clicking on launcher item or selecting a app in Alt-
- Tab raises all app windows, not just most recently focussed
+ [regression] Launcher, Alt-Tab - clicking on launcher item or selecting
+ a app in Alt-Tab raises all app windows, not just most recently focussed

This bug is really making things quite hard for me. It makes working with multiple windows quite a pain for me and possible alot others. Consider you have 4 windows with the same launcher you minimize all and then click on the launcher icon and Bamm all windows appear.

John Lea (johnlea) on 2012-04-13
description: updated
John Lea (johnlea) on 2012-04-13
summary: [regression] Launcher, Alt-Tab - clicking on launcher item or selecting
- a app in Alt-Tab raises all app windows, not just most recently focussed
+ a app in Alt-Tab raises all app windows, not just most recently focused
Didier Roche (didrocks) wrote :

removing the regression tag in the title, as it was a change that was done willingly at the time, and not something that people can think of having slept by not looking at it.
In addition, that was the behavior in alt-tab we had last cycle, and the discussion to change that 2 monthes before the release ended up by design vetoing it. So changing the behavior is another discussion with the release team, but it's not a regression as an unwanted change at the time it happened.

summary: - [regression] Launcher, Alt-Tab - clicking on launcher item or selecting
- a app in Alt-Tab raises all app windows, not just most recently focused
+ Launcher, Alt-Tab - clicking on launcher item or selecting a app in Alt-
+ Tab raises all app windows, not just most recently focused
Didier Roche (didrocks) wrote :

Also, I asked design to get in touch with the release team. For now, the patch is not fully backed and I'm not found of changing the behavior in a SRU (especially something we discussed 8 monthes ago and that design decided that it was the right behavior for alt-tab).

I agree I don't like the current behavior or raising all windows though on launcher and on alt-tab (as I was not in agreement on alt-tab 6 months ago).

tags: added: rls-mgr-p-tracking
Kate Stewart (kate.stewart) wrote :

This fix is not appropriate for an SRU since it is changing documented behaviour. It needs to be included in 12.04 release or else planned into a later release. Any fix for this we can pick up, must be a cherry pick, and targetted only to changing this issue, so we can revert if further issues are caused. Need this in place by monday at the latest.

Changed in unity (Ubuntu Precise):
importance: Medium → High
milestone: none → ubuntu-12.04
William Heslam (willheslam) wrote :

I'd really like to see this make it in time for 12.04. I'm unfamiliar with the politics and processes that surround getting code checked out, tested and included in a final release - my only interest is being able to put the 12.04 CD into my dad's/girlfriend's/friend's PCs, install and fully update it and then see correct and easy to use window management when using Ubuntu.

Consider that Unity is designed to improve window management compared to a traditional window-specific task bar or list. In my opinion it achieves this in every way - except when bringing a specific window to the fore without raising any others.

In Gnome 2 it takes one click.
In the 12.04 design spec, it takes one click.
In the current 12.04 prospective release, it takes one click + however many windows that belong to that application.
If you have 4 Firefox windows, it'll take 4 clicks (one to raise all windows, then 3 more to minimise each other window in turn.

I hate to break out a cliché, but this is one aspect of Unity that, for me, makes it nigh on unusable - or at least very aggravating. Everything else is genuinely stellar.

I've tried kicking up a fuss about this for a while and from the discussions I've had with developers and the design team, it seems that this is something that has slipped under the radar and been forgotten about, rather than deliberately decided as unnecessary or unimportant for release.

I hope it makes it in for 12.04!

Changed in unity (Ubuntu Precise):
assignee: Brandon Schaefer (brandontschaefer) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: Brandon Schaefer (brandontschaefer) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.10.0-0ubuntu4

---------------
unity (5.10.0-0ubuntu4) precise-proposed; urgency=low

  * Cherry-pick an additional fix from trunk fixing multiple bugs:
    - alt-tab - quick alt + tab (before the switcher shows) not consistent
      (LP: #861250)
    - Launcher, Alt-Tab - clicking on launcher item or selecting a app in
      Alt-Tab raises all app windows, not just most recently focused
      (LP: #959339)
    - Alt-Tab, multimonitor - The Alt-Tab overlay should appear on the display
      which has focus. (LP: #981795)
 -- Didier Roche <email address hidden> Mon, 16 Apr 2012 08:35:28 +0200

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Nick Tait (jnick-tait) on 2012-04-17
tags: added: reviewedbydesignp
removed: udp
Changed in ayatana-design:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2012-04-26
Changed in unity:
status: Fix Released → Fix Committed
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
status: Fix Committed → Fix Released
Elijah Lynn (elijah-lynn) wrote :

Okay, so how does a person who really enjoyed this bug do what it undid? I want to alt+tab to an application and have all windows focus/appear from that group, like Mac OS X.

Here is a another person asking for it --> http://askubuntu.com/questions/127143/how-do-i-revert-the-alt-tab-behavior-so-that-switching-to-an-app-brings-to-the-f

I think both are valid and useful cases but sometimes I just want to get all the windows focused. How do I do that now?

Just replied to that, we probably could add a new option to support the old behavior too but please fill a new bug (or propose a merge, it's trivial).

Peng (pengwg) wrote :

I second that we have the old behavior also available. It had been one of my favorite features of Unity. It is very useful when there's multiple gedit or terminal windows open, in which case the windows are not very distinguishable in a spread.

Also in spread I can't quickly go back to the window I want based on their original location on the screen.

Peng (pengwg) wrote :

Another idea is to list the window titles in the quick list menu.

I also would like to have the old behavior back. It just annoying when U have 2 or 3 terminals open. Many times I'm copying and pasteing from window to another, or reading a manual page on the other window.

Simon Strandman (nejsimon) wrote :

Sorry for the spam but this really should be configurable. This new behaviour is really annoying IMO.

Tom Wieczorek (twz123) wrote :

As suggested, I filed a feature request for a configuration option: https://bugs.launchpad.net/unity/+bug/1055478

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers