padding between last quicklist item and bottom edge is non-deterministic (changes randomly)

Bug #955158 reported by Mirco Müller on 2012-03-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Andrea Azzarone
5.0
Fix Released
Low
Andrea Azzarone
unity (Ubuntu)
Low
Andrea Azzarone
Precise
Low
Unassigned

Bug Description

[TestCase]
1. Start with a fresh session; Log out and in again.
2. Right click on the Unity trash icon. Look at the placement of the text.
3. Close the quicklist.
4. Right click on the icon again. Look at the placement of the text.
Expected: The text is vertically aligned in the same place each time the quicklist is opened.
Observed: The text is vertically aligned in a different position when the quicklist is opened the second time.

[Regression Potential]
Broken quicklist display.

ORIGINAL DESCRIPTION:
With the addition of the new launcher-icon tooltips, a regression for the quicklist-rendering has been introduced.

The bottom padding in multi-item and single-item quicklists is not equal to 3px anymore. See the provided screenshot for the glitches being demonstrated:

http://ubuntuone.com/3i3ee0LHYPM7CB84dlBoAt

Related branches

Mirco Müller (macslow) on 2012-03-14
Changed in unity:
milestone: none → 5.8.0
assignee: nobody → Mirco Müller (macslow)
importance: Undecided → Low
status: New → Triaged
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Mirco Müller (macslow) wrote :

Here's a better demonstration of what's actually going wrong (with commentary voice-over):

http://people.canonical.com/~mmueller/955158-showcase.ogv

The refresh-artifacts you can see in the video are from the screencasting-application and not really visible live on screen.

Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: 5.10.0 → 5.12.0
Mirco Müller (macslow) on 2012-04-20
Changed in unity:
assignee: Mirco Müller (macslow) → nobody
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: 5.12.0 → 5.14.0
Omer Akram (om26er) on 2012-06-13
Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Andrea Azzarone (azzar1) on 2012-06-19
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Daniel van Vugt (vanvugt) wrote :

I noticed this with the trash icon in precise. Maybe in oneiric too?

Its quicklist alignment changes randomly. Sometimes the gap at the bottom is small, sometimes large. Though now I've found this bug it's stopped happening so I can't do screenshots.

summary: - padding between last quicklist item and bottom edge is not correct
+ padding between last quicklist item and bottom edge is non-deterministic
+ (changes randomly)
description: updated
Changed in unity:
milestone: 5.14.0 → 6.0
Didier Roche (didrocks) on 2012-07-10
Changed in unity:
milestone: 6.0 → 6.2
Andrea Azzarone (azzar1) on 2012-07-11
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity (Ubuntu Precise):
importance: Undecided → Low
status: New → In Progress
description: updated

Hello Mirco, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity - 5.14.0-0ubuntu1

---------------
unity (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Unity launcher shows internal partitions after they have been unmounted
      (LP: #994163)
    - can't click to dismiss hud in the area where dynamic hud results are
      meant to appear (LP: #962651)
    - Spread/Scale should exit if Dash is invoked (LP: #944033)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dash - The search bar gets the focus when pressing invalid keys
      (LP: #931393)
    - unity crashed with NameError in reset_unity_compiz_profile(): global name
      'GError' is not defined (LP: #778470)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      from unity::UnityWindow::glPaint() (LP: #851982)
    - "Keyboard Shortcuts" overlay can cause annoyance (LP: #934062)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - HUD Draws improperly while searching for results (LP: #932531)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold (LP: #839717)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - dash should open when pressing "super" in scale mode (LP: #1023811)
    - Multimonitor, Launcher - When the Launcher is set to autohide and
      'Sticky edges' are turned off, 'Launcher Edge Stop Overcome Pressure'
      seems to be broken when revealing the Launcher (LP: #987955)
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - Regression: shift+click on a launcher icon to open a new application
      instance gone (LP: #754565)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Duplicated applications icons on quick application restart (LP: #1003574)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - alt-backtick flickers between windows (LP: #987156)
    - [Hud] The result grid is not drawn in proximity of the search entry
      (LP: #1008603)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - [hud] The last button is not rounded (LP: #1008656)
    - Hud flickers when show up (LP: #1011507)
    - Dash maximise button changed location (LP: #987674)
    - launcher reordering "line" doesn't go to the bottom slot (LP: #971421)
    - Dash/HUD should close on "Spread" (LP: #870284)
    - Nothing should be written into the dash/hud searchbar whe...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package unity - 6.2.0-0ubuntu1

---------------
unity (6.2.0-0ubuntu1) quantal-proposed; urgency=low

  [ Adam Conrad ]
  * Removed debian/patches/libgeis-rename.patch

  [ Łukasz 'sil2100' Zemczak ]
  * debian/rules:
    - added override for dh_shlibdeps to point it to the private directory of
      libunity-protocol-private.so
  * debian/unity.lintian-overrides,
    debian/libunity-core-6.0-5.lintian-overrides:
    - added override to silence the binary-or-shlib-defines-rpath error, since
      we are forced to use RPATH in our case

  [ Didier Roche ]
  * New upstream release.
    - [nvidia] compiz crashed with SIGSEGV in
      nux::GraphicsEngine::QRP_GLSL_Color() from
      nux::GraphicsEngine::QRP_Color() from nux::BasePainter::PaintBackground
      (LP: #982626)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold. (LP: #839717)
    - running applications without an icon use a blank icon (LP: #886778)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - still some accent issues with unity/nux (LP: #950740)
    - Launcher doesn't autoscroll when holding an icon (can't reach trash)
      (LP: #987223)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - [GLES] framebuffer output scaled incorrect in both blur and items above
      shell with multimonitor (LP: #1016789)
    - [regression] [unity 6.0] Fullscreen windows flicker and/or never redraw
      properly if panel_opacity<1.0 or dash is opened. (LP: #1024911)
    - panel and launcher blinks when using libreoffice presenter/spreadsheet
      (LP: #1024459)
    - compiz crashed with SIGSEGV in
      unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
      (LP: #1020075)
    - Update to 1.6.4 (LP: #1014850)
    - [nvidia] unity crashed in nux::GraphicsEngine::QRP_GLSL_1Tex
      (glDrawArrays) (LP: #1031554)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - Launcher, Dash - Showing dash, via super key, with a quicklist shown
      doesn't work (LP: #913994)
    - REGRESSION: can't type characters with accent (dead keys) (LP: #961741)
    - Launcher wrongly shows top tooltip when peforming the accordion effect
      (LP: #980942)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - logging out/in with mounted drives causes unity launcher icons to be
      duplicated (LP: #1010714)
    - Mounted volume icons doubled up in launcher (LP: #1010858)
    - Launcher - when a user starts dragging a item, the launcher icons that
      are *not* valid drop receptacles should be tinted (LP: #1020891)
    - Alt+F4 does not close the hud when Numlock or Capslock are on.
      (LP: #1022801)
    - Unity shortcut overlay needs to include shortcut for video lens
      (LP: #937334)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - give a way to remove 'Show Desktop' from the Alt-Tab items
      (LP: #1014346)
    - Multi...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers