compiz crashed with SIGSEGV in nux::WindowThread::GetWindowCompositor() from nux::BaseWindow::BaseWindow() from unity::dash::Controller::SetupWindow()

Bug #953515 reported by David Hope on 2012-03-12
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Unassigned
5.0
Incomplete
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Gconf-cleaner crashed as soon as I tried to save the original config

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: libnux-2.0-0 2.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic-pae 3.2.9
Uname: Linux 3.2.0-18-generic-pae i686
ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
Date: Mon Mar 12 18:45:29 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120301)
ProcCmdline: compiz
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xb45940c4 <_ZNK3nux12WindowThread19GetWindowCompositorEv+4>: mov 0xdc(%eax),%eax
 PC (0xb45940c4) ok
 source "0xdc(%eax)" (0x000000dc) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 nux::WindowThread::GetWindowCompositor() const () from /usr/lib/libnux-2.0.so.0
 nux::BaseWindow::BaseWindow(char const*, char const*, int) () from /usr/lib/libnux-2.0.so.0
 unity::dash::Controller::SetupWindow() () from /usr/lib/compiz/libunityshell.so
 unity::dash::Controller::EnsureDash() () from /usr/lib/compiz/libunityshell.so
 ?? () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in nux::WindowThread::GetWindowCompositor()
UpgradeStatus: Upgraded to precise on 2012-03-12 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

David Hope (dhhope) wrote :

StacktraceTop:
 nux::WindowThread::GetWindowCompositor (this=0x0) at ./WindowThread.cpp:1541
 nux::BaseWindow::BaseWindow (this=0x8fbdc88, WindowName=0xb481a74a "Dash", __Nux_FileName__=0xb481a614 "/usr/include/Nux-2.0/Nux/BaseWindow.h", __Nux_LineNumber__=70) at ./BaseWindow.cpp:75
 unity::dash::Controller::SetupWindow (this=0x8c5e928) at /build/buildd/unity-5.6.0/plugins/unityshell/src/DashController.cpp:77
 unity::dash::Controller::EnsureDash (this=0x8c5e928) at /build/buildd/unity-5.6.0/plugins/unityshell/src/DashController.cpp:142
 unity::dash::Controller::Controller()::{lambda(void*)#1}::_FUN(void*) () at /build/buildd/unity-5.6.0/plugins/unityshell/src/DashController.cpp:53

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-04-05
visibility: private → public
summary: compiz crashed with SIGSEGV in nux::WindowThread::GetWindowCompositor()
+ from nux::BaseWindow::BaseWindow() from
+ unity::dash::Controller::SetupWindow()
Changed in nux:
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in nux:
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in unity:
milestone: none → 5.10.0
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: 5.10.0 → 5.12.0
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: 5.12.0 → 5.14.0
Changed in unity:
milestone: 5.14.0 → 5.16.0
Changed in unity:
milestone: 5.16.0 → 5.18.0
Changed in unity:
milestone: 5.18.0 → 7.0.0
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Changed in unity:
milestone: 7.0.1 → 7.3.1
no longer affects: nux (Ubuntu)
no longer affects: nux
no longer affects: unity/6.0
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers