compiz crashed with SIGSEGV in nux::NTextureData::ClearData() from nux::NTextureData::~NTextureData() from nux::Texture2D::~Texture2D()

Bug #952378 reported by scorp123 on 2012-03-11
64
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Brandon Schaefer
unity (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

SRU testcase

1. install unity from precise-proposed
2. enable/disable some plugins in CCSM
3. notice Unity does not crash.

Playing around with CCSM when all of a sudden eveything froze ... after 10-20 seconds I got kicked out to the login screen.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: libnux-2.0-0 2.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Sun Mar 11 18:03:47 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
ProcCmdline: compiz
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f348bf7fb40: cmp 0x18(%rdx),%rbx
 PC (0x7f348bf7fb40) ok
 source "0x18(%rdx)" (0x200000a0002f71c) not located in a known VMA region (needed readable region)!
 destination "%rbx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 nux::NTextureData::ClearData() () from /usr/lib/libnux-image-2.0.so.0
 nux::NTextureData::~NTextureData() () from /usr/lib/libnux-image-2.0.so.0
 nux::Texture2D::~Texture2D() () from /usr/lib/libnux-graphics-2.0.so.0
Title: compiz crashed with SIGSEGV in nux::NTextureData::ClearData()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

scorp123 (scorp123) wrote :

StacktraceTop:
 malloc_consolidate (av=0x7f348c2b7720) at malloc.c:4246
 malloc_consolidate (av=0x7f348c2b7720) at malloc.c:4215
 _int_free (av=0x7f348c2b7720, p=<optimized out>, have_lock=0) at malloc.c:4146
 nux::NTextureData::ClearData (this=0x155f808) at ./ImageSurface.cpp:903
 nux::NTextureData::~NTextureData (this=0x155f808, __in_chrg=<optimized out>) at ./ImageSurface.cpp:897

affects: ubuntu → nux (Ubuntu)
Changed in nux (Ubuntu):
importance: Undecided → Medium
summary: - compiz crashed with SIGSEGV in nux::NTextureData::ClearData()
+ compiz crashed with SIGSEGV in malloc_consolidate()
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
summary: - compiz crashed with SIGSEGV in malloc_consolidate()
+ compiz crashed with SIGSEGV in nux::NTextureData::ClearData() from
+ nux::NTextureData::~NTextureData() from nux::Texture2D::~Texture2D()
Changed in nux:
status: New → Confirmed
importance: Undecided → High
Changed in unity:
status: New → Confirmed
milestone: none → 5.12.0
importance: Undecided → High
visibility: private → public
Changed in nux (Ubuntu):
importance: Medium → High
Changed in unity:
importance: High → Medium
importance: Medium → High
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in nux:
status: Confirmed → Invalid
Changed in nux (Ubuntu):
status: Confirmed → Invalid
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: New → Fix Committed
Omer Akram (om26er) on 2012-04-26
no longer affects: nux (Ubuntu)
no longer affects: nux
Changed in unity (Ubuntu):
importance: Undecided → Medium
description: updated
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
status: Fix Committed → Fix Released

Hello scorp123, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.12-0ubuntu1

---------------
unity (5.12-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Launcher, Alt-Tab - clicking on launcher item or selecting a app in Alt-
      Tab raises all app windows, not just most recently focused (LP: #959339)
    - [heap corruption?] compiz crashed with SIGSEGV in _int_malloc() from
      g_realloc() from ... from g_dbus_connection_send_message_with_reply()
      from g_object_unref() from unity::dash::HomeLens::Impl::~Impl() from
      unity::dash::HomeLens::~HomeLens() (LP: #931201)
    - compiz crashed with SIGSEGV in _int_malloc() from __libc_calloc() from
      XOpenDisplay() from nux::WindowThread::ThreadCtor() (LP: #947844)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Window management - unity doesn't realise when applications bring their
      windows to the front (LP: #802816)
    - Dash - Clicking on the desktop dash border should do nothing, *NOT*
      close the dash (LP: #839472)
    - [FFe, UIFe] HUD - The HUD does not respect launcher icon size settings
      in autohide mode (LP: #921506)
    - compiz crashed with SIGSEGV in g_volume_get_mount() (LP: #918548)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - Panel is transparent when Dash is open; no blur no average BG color
      (LP: #965323)
    - Unity crashes with SIGSEGV when hitting debug DBus interface hard
      (LP: #979429)
    - compiz crashed with SIGSEGV in _int_malloc() from g_object_unref() from
      unity::dash::Model<unity::dash::FilterAdaptor>::~Model() (LP: #941750)
    - indicators menu are sometimes cut off at screen edge (LP: #883317)
    - the shortcut keys in workspace section of the shortcut overlay aren't
      translated (LP: #980828)
    - [regression] Dash keeps repainting unnecessarily (LP: #980924)
    - compiz crashed with SIGSEGV in nux::NTextureData::ClearData() from
      nux::NTextureData::~NTextureData() from nux::Texture2D::~Texture2D()
      (LP: #952378)
    - compiz crashed with SIGSEGV in g_object_unref() from
      unity::dash::Settings::~Settings() from
      unity::UnityScreen::~UnityScreen() (LP: #981764)
    - compiz crashed with SIGSEGV in unity::dash::ResultView::~ResultView()
      from unity::dash::ResultViewGrid::~ResultViewGrid() from
      nux::Object::Destroy() from nux::Object::UnReference() (LP: #942286)
    - compiz crashed with SIGSEGV in
      ends_with_iter_select<__gnu_cxx::__normal_iterator<char const*,
      std::basic_string<char> >, char const*, boost::algorithm::is_iequal>()
      from unity::ui::PointerBarrierWrapper::EmitCurrentData() (LP: #983268)
    - Chinese can't be shown completely in dash filter (LP: #984583)
    - [Unity 5.10] compiz crashed with SIGSEGV in
      unity::hud::HudIconTextureSource::ColorForIcon() from
      unity::hud::Icon::Icon() from emit from unity::IconTexture::IconLoaded
      (LP: #983646)
    - [regression] Close button does not close the dash/HUD (LP: #986264)
    - compiz crashed with SIGSEGV in g_volume_eject_with_operation_finish()
      fro...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers