Intermittent painting issue on top panel menus

Bug #950411 reported by Bruno Girin on 2012-03-08
This bug report is a duplicate of:  Bug #931473: Menus don't fully appear. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
New
Undecided
Unassigned

Bug Description

The menus in the top panel occasionally fail to paint properly, resulting in an outline with no or partial menu items inside. Moving the mouse pointer over the missing items forces a repaint of those items at which point they appear. When the menu is partially painted, the painted part is always a vertical slice on the right of the menu so for instance the menu may show a normal right half with an outline left half. It also looks like once a menu has been displayed properly once, the problem no longer occurs with that particular menu.

Steps to reproduce
1. Log in
2. Click on any menu item in the top panel

Actual behaviour:
The menu opens but intermittently only part of it is painted, the rest being just an outline.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.4.0+bzr2057ubuntu0+654 [origin: LP-PPA-unity-team]
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.94.1-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,move,vpswitch,snap,imgpng,gnomecompat,mousepoll,place,resize,grid,regex,session,wall,animation,workarounds,expo,fade,ezoom,scale,unityshell]
CompositorRunning: compiz
CrashDB: unity
Date: Thu Mar 8 23:41:41 2012
DistUpgraded: Log time: 2012-02-11 15:47:04.675012
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.8, 3.2.0-17-generic, x86_64: installed
 virtualbox, 4.1.8, 3.2.0-18-generic, x86_64: installed
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21e8]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
MachineType: LENOVO 12942NG
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic root=UUID=99ef2b0f-91ae-4bb4-99ca-09aa36f75bb9 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-02-11 (26 days ago)
dmi.bios.date: 06/20/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8MET22WW (1.22 )
dmi.board.asset.tag: Not Available
dmi.board.name: 12942NG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8MET22WW(1.22):bd06/20/2011:svnLENOVO:pn12942NG:pvrThinkPadX1:rvnLENOVO:rn12942NG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 12942NG
dmi.product.version: ThinkPad X1
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.0+bzr3035-0ubuntu1~ppa2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu5
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Bruno Girin (brunogirin) wrote :
Bilal Akhtar (bilalakhtar) wrote :

I used to have this issue earlier, but I haven't experienced it lately since I moved to trunk. Anyone else?

Omer Akram (om26er) wrote :

duplicate bug 931473

To post a comment you must log in.