Spread/Scale should exit if Dash is invoked

Bug #944033 reported by Mirco Müller on 2012-03-01
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Fix Released
Medium
Brandon Schaefer
5.0
Fix Released
Medium
Brandon Schaefer
unity (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

[Test Case]
1. Exit dash and/or spread (compiz' scale-plugin) by hitting: Escape
2. Trigger spread by keyboard-shortcut: Super+w
3. Trigger dash by keyboard-shortcut: Super
   -> Verify that the spread is closing and the dash opening

[Regression Potential]
No obvious regression potential, just new safe code.

Original description:

You can enter the Dash with an activated window-spread.

Steps to reproduce the bug
- exit dash and/or spread (compiz' scale-plugin) by hitting: Escape
- trigger spread by keyboard-shortcut: Super+w
- trigger dash by keyboard-shortcut: Super

What happens
- nothing

What should happen
- spread should be closing
- dash should be opening

Related branches

Mirco Müller (macslow) on 2012-03-01
Changed in unity:
assignee: nobody → Mirco Müller (macslow)
milestone: none → 5.8.0
Omer Akram (om26er) on 2012-03-01
Changed in unity:
importance: Undecided → Medium
status: New → Triaged
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: 5.10.0 → 5.12.0
Mirco Müller (macslow) on 2012-04-20
Changed in unity:
assignee: Mirco Müller (macslow) → nobody
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: 5.12.0 → 5.14.0
Omer Akram (om26er) on 2012-06-21
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
status: Triaged → In Progress

I added the design team to look at this. The reason is the only way to actually add this would be considered a hack. As we would have to rely on stealing keypresses from the Scale plugin or something else...that wouldn't be pretty.

John Lea (johnlea) wrote :

Yes this is something we should definitely do, and is related to bug #870284

Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Fix Committed
tags: added: udp
Daniel van Vugt (vanvugt) wrote :

This is historically by design. The scale plugin grabs the keyboard while active, so no other windows get keystrokes till it's unscaled/unspread.

However, we don't necessarily need to break the existing compiz logic. The unityshell plugin does some event interception, so it can steal key events etc from compiz and bypass normal compiz logic. Maybe we can make use of unityshell's handleEvent for this.

no longer affects: unity/6.0
Changed in unity:
status: In Progress → Fix Committed
milestone: 5.14.0 → 6.0
Omer Akram (om26er) on 2012-07-03
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2012-07-10
Changed in unity:
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

The steps described there work, it doesn't work perfectly with the launcher spread though:

- left click on the nautilus launcher icon
- middle click on the same icon to open a second instance
- left click to trigger the spread view of nautilus instances
- hit the super key

-> nothing happens

- hit super again

-> the spread closes and the dash open

Ideally you would need to only press super once in those cases (it's not a regression and probably not worth blocking the SRU but would be nice to fix for the next round)

Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package unity - 6.0.0-0ubuntu1

---------------
unity (6.0.0-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/rules, debian/control, debian/unity-autopilot.install:
    - install new unity-autopilot package, containing autopilot bindings and
      test for Unity
    - add some python build-dep for executing setup.py
    - use dh_python2 and add some python:Depends dep for automatic python
      version detection
  * debian/control:
    - remove gnome-desktop dependency: not needed upstream anymore
    - unity Breaks older lenses due to path change
    - remove libgdu in build-dep
  * debian/libunity-core-6.0-5.install, debian/libunity-core-6.0-dev.install,
    debian/control:
    - version bump in libunity-core, change soname

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - compiz crashed with SIGSEGV in get_current_slide() from
      unity::BGHash::OnSlideshowTransition() (LP: #889625)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - App icon on the Unity Launcher lost track of running instance
      (LP: #772063)
    - unity crashed with NameError in reset_unity_compiz_profile(): global
      name 'GError' is not defined (LP: #778470)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      [compizminimizedwindowhandler.h] from unity::UnityWindow::glPaint()
      (LP: #851982)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - [regression] Launcher is silent to screen reader users (LP: #949448)
    - still some accent issues with unity/nux (LP: #950740)
    - [regression] [precise] 3D apps run much slower under Unity (LP: #987304)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Port to libudisks2 (LP: #1012000)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dragged icons rendered under dash (LP: #1021541)
    - Regression in Launcher keyboard navigation (with Alt+F1) (LP: #1021549)
    - Unity dash is is much slower/laggy after revision 2469. (LP: #1021665)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - when a file is dragged from the Dash (Dash home, file lens, or
      music lens) and dropped on a Launcher icon, the Dash should
      automatically close (LP: #865168)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - Open dash, press Alt+f1 - dash remains open (LP: #919209)
    - application reopens itself when last instance is closed from
      windows/application switcher (LP: #926406)
    - HUD D...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

I opened bug #1023811 about the remaining issue

description: updated
Changed in unity (Ubuntu Precise):
importance: Undecided → Medium
status: New → In Progress

Hello Mirco, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity - 5.14.0-0ubuntu1

---------------
unity (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Unity launcher shows internal partitions after they have been unmounted
      (LP: #994163)
    - can't click to dismiss hud in the area where dynamic hud results are
      meant to appear (LP: #962651)
    - Spread/Scale should exit if Dash is invoked (LP: #944033)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dash - The search bar gets the focus when pressing invalid keys
      (LP: #931393)
    - unity crashed with NameError in reset_unity_compiz_profile(): global name
      'GError' is not defined (LP: #778470)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      from unity::UnityWindow::glPaint() (LP: #851982)
    - "Keyboard Shortcuts" overlay can cause annoyance (LP: #934062)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - HUD Draws improperly while searching for results (LP: #932531)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold (LP: #839717)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - dash should open when pressing "super" in scale mode (LP: #1023811)
    - Multimonitor, Launcher - When the Launcher is set to autohide and
      'Sticky edges' are turned off, 'Launcher Edge Stop Overcome Pressure'
      seems to be broken when revealing the Launcher (LP: #987955)
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - Regression: shift+click on a launcher icon to open a new application
      instance gone (LP: #754565)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Duplicated applications icons on quick application restart (LP: #1003574)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - alt-backtick flickers between windows (LP: #987156)
    - [Hud] The result grid is not drawn in proximity of the search entry
      (LP: #1008603)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - [hud] The last button is not rounded (LP: #1008656)
    - Hud flickers when show up (LP: #1011507)
    - Dash maximise button changed location (LP: #987674)
    - launcher reordering "line" doesn't go to the bottom slot (LP: #971421)
    - Dash/HUD should close on "Spread" (LP: #870284)
    - Nothing should be written into the dash/hud searchbar whe...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignq
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers