Press Alt+F1, panel’s shadow dissapear

Bug #942965 reported by Adolfo Jayme on 2012-02-28
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Marco Trevisan (Treviño)
5.0
Fix Released
Low
Marco Trevisan (Treviño)
unity (Ubuntu)
Low
Marco Trevisan (Treviño)
Precise
Undecided
Unassigned

Bug Description

[Impact]

Shadow panel disappears when in Launcher.

[Test Case]

1. make sure desktop have the focus
2. press alt-f1

[Regression Potential]

None.

---

bzr2041

1. make sure desktop have the focus
2. press alt-f1

what happens:
see the panel shadow is gone

Related branches

Bilal Akhtar (bilalakhtar) wrote :

Nice catch!

Changed in unity:
status: New → Triaged
importance: Undecided → Low
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Omer Akram (om26er) on 2012-03-01
description: updated
Changed in unity:
status: Triaged → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 7.0.0
Changed in unity (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision 3208, scheduled for release in unity, milestone backlog

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily13.03.13.1-0ubuntu1

---------------
unity (6.12.0daily13.03.13.1-0ubuntu1) raring; urgency=low

  [ Sebastien Bacher ]
  * Launcher - Update the icons used for the Software Centre, Nautilus,
    and Software Updater (LP: #1081691)

  [ Andrea Azzarone ]
  * Nautilus windows don't get the the focus when opened via the dash.
    (LP: #1152733)

  [ Marco Trevisan (Treviño) ]
  * New Shutdown view disables panel shadow (LP: #1152760)
  * Shutdown goodbye text is sometimes partly missing (LP: #1152978)
  * Shutdown view should be closable by escape-key (LP: #1152712)
  * Press Alt+F1, panel’s shadow dissapear (LP: #942965)
  * Long text in previews or dialogs is not properly aligned and/or
    missing (LP: #1152980)
  * Panel Shadow is not drawn properly during workspace switching (LP:
    #1153699)
  * QuicklistMenuItem's do not export the event timestamp on Activate
    (LP: #1154082)
  * [multimonitor] Dash - Opening dash or HUD on one screen removes
    panel shadow on the other (LP: #892718)

  [ Łukasz 'sil2100' Zemczak ]
  * Lenses shortcuts not working in singular cases (e.g. Super+A) (LP:
    #1152517)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3211
 -- Ubuntu daily release <email address hidden> Wed, 13 Mar 2013 09:23:11 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) wrote :

Thanks a bunch, Marco!

Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
Aritchie (aritchie) wrote :

So is this fix going to be available to 12.04?

It's not that important for being SRUed I think, but porting it should be easy... Patches welcome! ;)

Aritchie (aritchie) wrote :

Marco, I am not trying to offend anyone and having said that I do not understand the logic. You are saying it is important enough to fix for an upcoming release ofr Unity which will be in 13.04 but it is not important enough to fix for 12.04. This was a bug in 12.04 not 13.04. It should be fixed in 12.04 especially since 12.04 is a LTS.

Aritchie: I didn't considered this bug so much important for 12.04 since it is triggered on a more rarely used scenario, while it was more important in 13.04 since the new shutdown dialogues highly highlighted it.

However, I'll check the feasibility of backporting this patch to 12.04.

So, it seems that will arrive with next SRU in 12.04 as well... ;)

description: updated

Hello Adolfo, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.20.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Aritchie (aritchie) wrote :

Ubuntu 12.04.2 LTS
Unity 5.20.0 "SRU-4"

The label "Ubuntu Desktop" still disappears and the menu still does not appear when I hover the mouse over the panel a few seconds after login but the shadow no longer disappears. It no longer disappears after hitting "Alt-F1". I can click on the desktop to get the "Ubuntu Desktop" label and the desktop menu back on the panel.

Artichie, this bug is not much about the "Ubuntu Destkop" label, but the shadow underneath the panel.

Aritchie (aritchie) wrote :

The menu is part of this though and this all happened at the same time. I do agree the label is not a big deal. The menu though is. The bug with the menu appeared at the same time as the "shadow" bug. All this was working as it should from the start. These issues got introduced from updates to the system over the last year or so.

Shuduo Sang (sangshuduo) on 2013-07-03
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.20.0-0ubuntu2

---------------
unity (5.20.0-0ubuntu2) precise; urgency=low

  * Check to see if the window is supposed to have decorations instead
    of the window actually being decorated when Undecorate() is called.
    This fixes a regression from the previous SRU where windows opened
    maximized upon login could have extra decorations (LP: #1195730)

unity (5.20.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - ResultRendererTile: fix a crash if row.renderer<TextureContainer*>()
      is null (LP: #926658)
    - Fix unity launcher vanishes when switching to mirrored displays
      (LP: #991637)
    - Fix window decorations being drawn when they should not be.
      This fixes icaclient window "dancing" (LP: #1083186) and
      hides decoration in a test case with Steam (LP: #1122478)
    - [multimonitor] Dash - Opening dash or HUD on one screen removes panel
      shadow on the other (LP: #892718)
    - Press Alt+F1, panel’s shadow dissapear (LP: #942965)
  * Cherry-pick a manual test for decorations fix
 -- Christopher Townsend <email address hidden> Mon, 08 Jul 2013 09:37:30 -0600

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints