When "Bias alt-tab (...)" is switched on, alt+tab and ctrl+alt+tab are swapped

Bug #942677 reported by Łukasz Zemczak on 2012-02-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Tim Penhey
unity (Ubuntu)
Undecided
Unassigned

Bug Description

When the "Bias alt-tab to prefer windows on the current viewport" option is set in, for instance, ccsm, alt + tab and ctrl + alt + tab are swapped. With this option enabled, alt+tab navigates through all applications on all workspaces (as expected) - but ctrl+alt+tab navigates only through applications on the given workspace.
I'm not sure how the design spec defines the ctrl+alt+tab behavior in this case. Is this option even necessary now anyway?

Unity version: 5.4.0+bzr2035ubuntu0+654
Ubuntu version: precise

Bilal Akhtar (bilalakhtar) wrote :

In my case, alt+tab shows windows only on the current workspace, and ctrl+alt+tab shows the old switcher with all windows on all workspaces.

I'm not sure what's the intended behavior.

Omer Akram (om26er) on 2012-02-29
Changed in unity:
importance: Undecided → Low
Omer Akram (om26er) wrote :

ctrl + alt + tab is just out of scope for this bug since unity's switcher only invokes with alt-tab? enabling biased WS behavior is how design wanted it to be in Precise.

Changed in unity:
status: New → Incomplete
Łukasz Zemczak (sil2100) wrote :

Well, since the new Unity offers both alt + tab and ctrl + alt + tab, I just thought maybe the whole "bias alt-tab behavior (...)" option should be removed from unity? Since it doesn't make sense to have the option when the ctrl + alt + tab binding is at hand.

Tim Penhey (thumper) wrote :

This was fixed yesterday. I agree with Łukasz in that the bias should be removed. Right now it should default to on. It was used in more than one place, so I didn't fix this while fixing the bug.

Changed in unity:
status: Incomplete → Fix Committed
assignee: nobody → Tim Penhey (thumper)
milestone: none → 5.6.0
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers