Unity hangs when touching my touchpad/trackpad

Reported by Andrea Cimitan on 2012-02-28
64
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Unity
High
Daniel d'Andrada
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Happens quite few times a day

Andrea Cimitan (cimi) wrote :
Changed in unity:
assignee: nobody → Daniel d'Andrada (dandrader)
no longer affects: utouch
Omer Akram (om26er) on 2012-02-29
no longer affects: compiz (Ubuntu)
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: Confirmed → In Progress
Daniel d'Andrada (dandrader) wrote :

I cannot reproduce this crash.

Versions used:
  compiz 1:0.9.7.0~bzr2995-0ubuntu5
  unity from lp:unity revision 2040
  nux from lp:nux revision 586

Changed in unity:
status: In Progress → Incomplete
Stephen M. Webb (bregma) wrote :

I get this every time I touch my trackpad. It is a hang, not a crash. The GDB backtrace attached to this bug also shows a hang, not a crash.

When this same hang was analyzed in January of 2011 the Unity developers said there was an XSync call missing from the query sequence, if that information is any help.

Chase Douglas (chasedouglas) wrote :

Andrea,

Can you confirm that this is a hang and not a crash?

Changed in unity:
status: Incomplete → In Progress
Andrea Cimitan (cimi) wrote :

Chase, it could be a hang, unity just freezes and I need to go to a tty and re-run it.

Daniel d'Andrada (dandrader) wrote :

Andrea,

Could you please try unity from lp:~dandrader/unity/lp942625 and tell us if the hang still occurs? And also whether you get the warnings "GestureEngine - XQueryTree failed!" and/or "GestureEngine: data->window == 0"?

Daniel d'Andrada (dandrader) wrote :

Awesome! I have been able to reproduce this very problem when running the trunk versions of compiz&friends. Now I can check if my patch works myself. :)

Daniel d'Andrada (dandrader) wrote :

Ok, the bug stopped appearing on my machine. I didn't have the change to try out my patch. Thus Andrea, I still need your help.

At least I can confirm it is a hang and not a crash.

summary: - Unity crashed touching my touchpad/trackpad
+ Unity hangs when touching my touchpad/trackpad
Daniel d'Andrada (dandrader) wrote :

Was able to reproduce it again and found the cause. Fix has been proposed.

Omer Akram (om26er) on 2012-03-01
Changed in unity:
milestone: none → 5.6.0
Changed in unity:
status: In Progress → Fix Committed
Tim Penhey (thumper) on 2012-03-04
Changed in unity:
importance: Undecided → High
Ruben (y-ruben) wrote :

I'm happy to help test this as well. I'm seeing this very often on my MacBook Pro.

Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments