Dash is totally broken when disabling the blur effect

Bug #941066 reported by Marco Trevisan (Treviño) on 2012-02-25
78
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
Low
Jay Taoko
unity (Ubuntu)
Low
Jay Taoko

Bug Description

When using a simple transparent dash, disabling the blur effect, the output is totally broken.

This needs to be fixed in precise or disabled.
Also, it would be nice to set the default transparency to a lower level when the blur is disabled, or would be impossible to use the dash.

--------------------------------
Desired resolution:

- For P the ability to switch off Dash bluring should be disabled.

Related branches

Changed in unity:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Andrea Azzarone (andyrock)
milestone: none → 5.6.0
John Lea (johnlea) on 2012-02-28
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
Changed in unity (Ubuntu):
status: New → Confirmed
tags: added: udp
Omer Akram (om26er) wrote :

Its a non standard feature in Unity, its not shown in any of the default config utility, so neither is there any design needed nor is it of such a high importance.

Changed in unity:
importance: High → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Max Bowsher (maxb) wrote :

Agree it's non standard, though the dash can be painfully slow even on reasonably modern graphics hardware, so any options to moderate the amount of attempted eye-candy would be nice.

Omer Akram (om26er) on 2012-04-01
Changed in unity:
milestone: 5.6.0 → 5.10.0
assignee: Andrea Azzarone (andyrock) → Jay Taoko (jaytaoko)
Changed in unity (Ubuntu):
assignee: nobody → Jay Taoko (jaytaoko)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Andrea Cimitan (cimi) on 2012-04-06
Changed in unity:
status: In Progress → Fix Committed
Doug McMahon (mc3man) wrote :

So now it's fixed & you're back to a basically transparent Dash, though at least now it's lightly tinted.
For a very short time in the sad history of "no blur" it actually produced something useful by having a dark colored Dash similar to unity-2d's in 11.10

Why anyone, other than a very few users, would want to use this current implementation is beyond me - it shows everything underneath

Owais Lone (loneowais) wrote :

It's a very useful feature for people with old hardware or low end intel graphics. It can be made quite usable if used along with the background color feature with is broken right now https://bugs.launchpad.net/ubuntu/+source/unity/+bug/926144.

On 04/08/2012 10:11 AM, Owais Lone wrote:
> It's a very useful feature for people with old hardware or low end intel
> graphics. It can be made quite usable if used along with the background
> color feature with is broken right now
> https://bugs.launchpad.net/ubuntu/+source/unity/+bug/926144.
>
Maybe I should reserve further comment till both the 'fixed' no blur & a
functioning background color are available.
But -
First, I thought the idea is that things should work well without too
much user modifying, is the idea that if a user can switch to no blur
they should be capable of making it usable if it's not depending on
chosen Background image?

2nd - the problem with using the 'background color feature' is that one
must choose a new color & set opacity. The opacity setting does have a
positive effect of making the Dash more usable, the picking of a new
color & raising opacity to the extent it improves the Dash is most
likely to produce an awful launcher

Further - what if the user wishes to make the no blur Dash usable & keep
their current launcher coloring? Good luck trying to do that

Is there some reason other than Design that the no blur Dash can't have
some opacity?

Owais Lone (loneowais) wrote :

I totally agree. There used to be a black background in 11.04 or 11.10 with no-blur and it was quite usable. Not sure why it was removed.

Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Doug McMahon (mc3man) wrote :

re-opened this bug in case anyone cares how it looks, ect.
Bug 837401

Adolfo Jayme (fitojb) wrote :

Doug, this bug was fixed, this was not related to the fact that the dash is not readable when blur is disabled.

Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Nick Tait (jnick-tait) on 2012-04-26
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers