HUD - The chevrons in the auto-complete that separate menu levels do not match the design

Reported by John Lea on 2012-02-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

The chevrons in the auto-complete that separate menu levels do not match the design. See attached design "Pangolin_matrix_v1-3e.png" If needed Rosie can export this chevron as a individual image asset.

John Lea (johnlea) on 2012-02-23
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
tags: added: udp
tags: added: hud
Changed in ayatana-design:
importance: Undecided → High
status: New → Triaged
Changed in unity:
status: New → Confirmed
milestone: none → backlog
Changed in unity (Ubuntu):
status: New → Confirmed
John Lea (johnlea) wrote :
Ted Gould (ted) on 2012-02-23
Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Olli Ries (ories) wrote :

as per discussion with Tim: we are rendering text and cannot intermix a graphic element in the rendered string.

the current chevron in the "greater than" from the official Ubuntu font.
please reassess

Changed in ayatana-design:
status: Triaged → Incomplete
Andrea Cimitan (cimi) wrote :

We could possibly add a new char in the ubuntu font to cover this case, but I'm not sure and it's just a possibility.
Even if it's not something that can be directly fixed in unity, now we still need to keep the bug opened to have it on track, otherwise it will get lost in the long list of 'Invalid' bugs.
The product which shows the bug is unity, in fact, so I don't know why we were closing the bug.

Changed in unity:
status: Invalid → Confirmed
Changed in unity (Ubuntu):
status: Invalid → Confirmed
Changed in ayatana-design:
status: Incomplete → Confirmed
Andrea Cimitan (cimi) wrote :

I changed the ayatana-bug status to Confirmed, will change to Fix committed once we will produce a required asset or an alternative solution

Changed in ayatana-design:
status: Confirmed → Fix Committed
Andrea Cimitan (cimi) wrote :

Sorry, I apologize for the mistake of changing the ayatana-design bug status to Confirmed. It should remain Fix Committed instead.

The design specifies a specific visual appearance for the chevrons that need to be respected irrespective of the technical solution.

If this bug involves different projects (font or indicator) feel free to add them, but this is the visuals approved and the bug should remain open until exactly this visual will be in production.

Ted Gould (ted) wrote :

Assigning to font as Cimi suggested.

affects: unity (Ubuntu) → ubuntu-font-family-sources (Ubuntu)
affects: unity → ubuntu-font-family
Changed in ubuntu-font-family:
milestone: backlog → none
Adolfo Jayme (fitoschido) wrote :

I don't think adding an additional glyph to the font is worth. Why not simply substitute this > with this › (rsaquo) ?

Adolfo Jayme (fitoschido) wrote :

Please don't mess up with Ubuntu fonts. What if I change my UI font? Will you add the extra glyph to every other font I'd loke to use in my system? What about Ubuntu users that use another font because Ubuntu font still does not cover their script?

I think, with due respect, that it's better to update your designs and mockups to use an existing character like ›.

John Lea (johnlea) on 2012-10-12
Changed in ayatana-design:
importance: High → Medium
Changed in ubuntu-font-family-sources (Ubuntu):
importance: Undecided → Medium
Adolfo Jayme (fitoschido) wrote :

Moving the bug to Unity -- the chevron is already used as an individual asset for the Previews feature. The font is not related to this: adding a non-standard character will only create problems while customizing the deskop font or if the language is not covered by the font.

affects: ubuntu-font-family → unity
affects: ubuntu-font-family-sources (Ubuntu) → unity (Ubuntu)
John Lea (johnlea) on 2012-10-15
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers