Staging: Unity 3D uninstallable

Bug #938590 reported by Paul Sladen on 2012-02-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Enabling ppa:unity-team/staging causes 'unity' to be removed:

  unity : Depends: unity-common (= 5.4.0+bzr2005ubuntu0+652) but 5.4.0+bzr2006ubuntu0+652

Omer Akram (om26er) wrote :

I am upgrading to 5.4.0+bzr2006ubuntu0+652 right now without a problem. you might have another ppa something.

Changed in unity:
status: New → Incomplete
Paul Sladen (sladen) wrote :

Broken today (for a different reason):

  sudo apt-get install unity=5.4.0+bzr2009ubuntu0+652
  The following packages have unmet dependencies.
     unity : Depends: libnux-abiversion-20120221.01 but it is not installable

AFAICT, no PPAs other than Unity staging at enabled at this precise moment.

Omer Akram (om26er) wrote :

that would just need unity to build again for the latest ABI break and it will be installable.

Omer Akram (om26er) wrote :

the staging ppa quite often break and I believe what you initially reported have passed.

Changed in unity:
status: Incomplete → Invalid
Paul Sladen (sladen) wrote :

Fixed as of
  unity amd64 5.4.0+bzr2014ubuntu0+652
  libnux-2.0-0 amd64 2.4.0+bzr584ubuntu0+319

Changed in unity:
status: Invalid → Fix Released
MBuBuntu (mbubuntu) wrote :

hello, I just had this bug now.
I made apt-get install dist-upgrade
and Unity was uninstalled (with ubuntu-desktop)
and when I would like to reinstall it I had this message :

ubuntu-tn@ubuntu-tn:~$ sudo apt-get install unity
[sudo] password for ubuntu-tn:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
unity : Dépend: libnux-abiversion-20120301.01 mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

thx

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers