Window management - Dragging down a maximized window from the panel has not predictable results

Bug #934680 reported by Marco Trevisan (Treviño) on 2012-02-18
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Unassigned

Bug Description

Dragging a window down from the top panel has a lot of issues, first of all:

 - The window should be restored as soon as the mouse pointer drags content outside the panel area
 - Once a window is restored it should not be placed outside the desktop area,
   unless it fits into it, also it should be never below the launcher (when always visible).
   In the case that the window is bigger than the available space, the window should be resized to fit on the monitor if possible. If this is not possible (e.g. it is a fixed size window that is larger than the monitor resolution) the top and left
   borders should be always visible anyway.
 - The just restored window, should be grabbed on a point of the top decoration
   that is proportional to the x-offset grabbed on the panel, so if you start
   dragging at the left of the panel, the window should be handled by the top-left
   corner, if you start dragging on the right of the panel, the window shuold be
   proportionally handled on the right.

Related branches

Changed in unity:
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Medium
Changed in compiz-grid-plugin:
status: New → Invalid
no longer affects: compiz-grid-plugin
John Lea (johnlea) on 2012-02-20
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
summary: - Dragging down a maximized window from the panel has not predictable
- results
+ Window management - Dragging down a maximized window from the panel has
+ not predictable results
Changed in ayatana-design:
importance: Undecided → High
status: New → Fix Committed
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in unity (Ubuntu):
status: New → In Progress
Changed in unity:
milestone: backlog → 5.6.0
Omer Akram (om26er) on 2012-02-21
Changed in unity (Ubuntu):
importance: Undecided → Medium
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-04-16
tags: added: delta-with-3d
Changed in unity-2d:
status: New → Confirmed
John Lea (johnlea) on 2012-10-12
tags: added: reviewedbydesignp
removed: udp
Changed in ayatana-design:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
no longer affects: unity-2d
Changed in unity-2d (Ubuntu):
status: Confirmed → Invalid
Adolfo Jayme (fitojb) on 2014-07-01
no longer affects: unity-2d (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers