"Keyboard Shortcuts" overlay can cause annoyance

Bug #934062 reported by Vincent Ladeuil on 2012-02-17
324
This bug affects 68 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Fix Released
High
Andrea Azzarone
6.0
Fix Released
High
Andrea Azzarone
unity (Ubuntu)
High
Andrea Azzarone
Precise
High
Andrea Azzarone

Bug Description

[Test Case]
1. Press and hold Super
   -> Verify that the Help and Shortcuts overlay is visible
2. Press shift
   -> Verify that the Help and Shortcuts overlay hides

[Regression Potential]
Invalidly working unity keyboard shortcuts.

Original description:

Having the help screen displayed when the <super> key is pressed long enough is a good idea.

Having workspace switching shorcuts added is even better (I won't have to add them myself anymore).

Both combined have a very annoying side-effect: while I switch between workspaces searching for the right one, I leave the super key pressed... which triggers the help display.. which obscures the workspaces I'm searching...

This is on an up-to-date precise system and has started a few days ago. I think I have a good idea about which shortcuts exist now, can I have a way to disable the help screen or make it less intrusive ?

-----------------------------------------
Desired Solution:

When any other key is pressed while Super is held, the shortcuts hint should be disabled. The shortcuts hint should continue to be disabled for the duration the SUPER key is held (even if the modifier key is subsequently released.)

Related branches

Omer Akram (om26er) wrote :

I added the designers of Unity to the bug so that they could review and decide on it. Thanks for your bug report.
(don't mind the incomplete status that is how unity bugs are handled)

summary: - help screen too intrusive
+ "Keyboard Shortcuts" overlay can cause annoyance
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
tags: added: needs-design
sarton85 (sarton85) wrote :

I can also confirm this.

Whenever the Super key has to be long pressed, for example; when switching workspaces, moving windows to other workspaces or to check which shortcut is attached to an icon in the launcher, the keyboard shortcuts pop up. This gets annoying very quickly.

It also has graphical glitches. The shortcut overlay blurs the application/wallpaper in the background. While switching to another workspace the overlay still has the blur of the previous workspace in the background.

I would advice to include an option to switch the overlay off, or to present the shortcut keys in another manner. The shortcut overlay is an informative and needed tool, but it shouldn't disturb the daily workflow.

@Vincent Ladeuil; the shortcuts overlay can be switched off with gconf-editor or ccsm; http://askubuntu.com/questions/103352/how-do-i-disable-the-unity-keyboard-shortcut-overlay

Michael Weimann (m982) wrote :

The shortcuts overlay is a pretty good thing. But it shouldn't trigger if any other shortcut is used, e.g. super + shirt for workspace switching. Perhaps the behavior could be added to the shortcuts overlay.

Vincent Ladeuil (vila) wrote :

@sarton85: Thanks for the hint !

stianst (stianst) wrote :

This also affects the maximize (super+up) and minimize (super+down) shortcuts

Vincent Ladeuil (vila) wrote :

I guess the overlay display triggers after a delay starting with the first KeyDown event for the <super> key. May be this delay should cancelled if *any* other key is pressed ?

I.e. the overlay will be then be displayed only if the super key and *nothing* else is pressed during the delay.

stianst (stianst) wrote :

I have the same problem with the launcher being shown - whenever I use any shortcut with super+<something> both the launcher and the keyboard shortcuts are left open afterwards.

Also if I press and hold super to display the keyboard shortcuts the overlay goes away when I release super, but if I try to use a shortcut with super it doesn't go away until I press super again.

I confirm that the "Keyboard Shortcuts" overview pops up during operation, e.g., when maximizing a window via Super+Up. It happens no matter how quickly the keys are released again. I am using 12.04 Beta 2.

Daniel van Vugt (vanvugt) wrote :

Confirmed. This seems to happen a lot. It's very intrusive.

I haven't looked yet, but if Unity still handles key events directly while Super is held then it should be easy to fix in Unity. Otherwise, the relevant functionality is already implemented in compiz (to detect secondary keystrokes while a modifier is held) and we possibly just need to expose that info to plugins like unityshell in a new way, _before_ the Terminate callback is triggered.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Łukasz Halman (lukasz-halman) wrote :

+1 for this issue

Super+Up/Down shortcuts are currently unusable for me.

Additionally is it really that good idea to do everything through some <Super>+something combo? We are some old/known GNOME shortcuts like Alt+F10, Alt+F5 dropped?

Daniel van Vugt (vanvugt) wrote :

Interesting. UnityScreen::handleEvent() already contains code that's meant to cancel the shortcut hints when any other key is pressed while Super is held. But it's obviously not working.

Shahar Or (mightyiam) wrote :

Dear Daniel,

Thank you for the attention. I hope this gets solves in precise before release.

Blessings,
Shahar

Having even more trouble then described above;
When I maximize or minimize a screen the overlay pops up and does not go away, even when releasing all the keys, I have to press the super key again to make it go away, but then the dash opens...

Should I make a new bug or will this be handled in the same issue?

Nekhelesh Ramananthan (nik90) wrote :

@Nicky De Maeyer, if you read the comments above in this bug report, you will see that other users (including me) need to do the same to hide the shortcut overlay again. I am guessing a bug report would not be necessary. Hope some one can confirm my statement or disagree quickly since we should try to get this fixed by Unity 5.10.

David Baucum (maxolasersquad) wrote :

@Nicky: It's the same for me. <super>+up to maximize a window, <super> again to make the Keyboard Shortcuts screen go away, and then <super> a third time to make the dash go away. For annoying, and practically makes keyboard shortcuts unusable. This is hands down the worst bug in 12.04 presently for me.

The shortcuts should never appear if you've used a Super-shortcut. So
yes, this is a bug, patches welcome.

tags: removed: needs-design
Mal (mal-gamble) wrote :

I'm glad to see that the problem with the shortcuts hint display seems to have been fixed with the latest update, however I have to say that I'm really disappointed with the current state of the keyboard shortcuts in Precise.

We now have an inconsistent and non-intuitive set of shortcuts: The keypad shortcuts, <ctrl><alt>kp1, kp2, kp3, kp5, kp7, kp8, kp9, provide useful window positioning to corresponding parts of the screen and allow cycling through 1/2, 1/3, 1/4... window sizing - this is good. However, <ctrl><alt>kp4, kp6 no longer do anything! Instead, we have the key combinations <ctrl><super>left and <ctrl><super>right (what happened to <super>left and <super>right?) to provide the left and right half screen window positioning without the ability to cycle through the other size options. I know it's possible to reassign the shortcuts using CCSM, but this would make them inconsistent with the shortcuts hint display and there is no way to reinstate the cycling behaviour.

Why can't we have the original functionality of keypad keys 4 and 6, complete with the cycling behaviour, as well as the <super>left and <super>right functionality for those with simpler requirements and for machines with no numpad? Would it really matter if there were two ways of achieving similar results?

We all want 12.04 to be a polished, reliable and professional operating system. The current state of these shortcuts is at odds with this objective.

Daniel van Vugt (vanvugt) wrote :

Mal, that design decision is detailed in bug 969235. If you would like to revert to the traditional compiz shortcuts using the number pad then please run "ccsm" and look in the "Grid" section to change the shortcuts.

Daniel van Vugt (vanvugt) wrote :

The "ccsm" command is in the ubuntu package named "compizconfig-settings-manager".

Mal (mal-gamble) wrote :

Daniel, yes it is possible to reassign the keys, but the fact remains that the default shortcuts are inconsistent, the reassigned shortcuts won't match the shortcuts hint display and it's not possible to reinstate the cycling behaviour.

Thanks for pointing out bug 969235 - perhaps this would be a better place for discussion on this issue.

stianst (stianst) wrote :

After installing recent updates it works better, but still not perfect. If ctrl is pressed and held first, then super, then up/down, it works as expected without showing the overlay or the dash. However, if super is pressed first both the dash and overlay is shown, but at least now they disappear when super is released.

This results in (at least for me) the dash+overlay still being displayed about half the time I use any of the "new" ctrl+super shortcuts, as I tend to press all keys simultaneously.

uzi3k (uzi3k) wrote :

I have the problem with the maximise and minimise function with the super + cursor up/down commands. Keyboard shortcut is my preferred way of maximising and minimising so is a frequent problem.

John Lea (johnlea) on 2012-04-12
description: updated
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: New → Fix Committed
importance: High → Critical

After a fresh install from 11.04 to 12.10 I can no longer use Super+U, Super+J, Super+M, for audio controls (volume up, volume down, mute).

I assume this is caused by the shortcuts overlay. Disabling it in CCSM does not help, the keybinds remain useless (unless I replace 'Super' with 'Ctrl' or something similar).

Andreas (andreasbutti) wrote :

I can also not use 'Super' for other Keyboard shurtcuts anymore.

Is there a workaround / solution?

For your information, pressing Escape hides the Shortcut Overlay until a new "Super" keypress.

Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2012-06-29
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
milestone: backlog → 5.14.0
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) wrote :

«When any other key is pressed while Super is held, the shortcuts hint should be disabled.»

So "any other key" includes TAB too right?

John Lea (johnlea) wrote :

@andyrock; yes

"when TAB is pressed while Super is held, the shortcuts hint should be disabled. The shortcuts hint should continue to be disabled for the duration the SUPER key is held (even if the modifier key is subsequently released)."

Andrea Azzarone (azzar1) on 2012-07-03
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
status: Fix Committed → In Progress
Andrea Azzarone (azzar1) on 2012-07-03
Changed in unity:
status: In Progress → Fix Committed
description: updated
Changed in unity (Ubuntu Precise):
importance: Undecided → High
status: New → In Progress

Hello Vincent, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
pablomme (pablomme) wrote :

Unity 5.14.0-0ubuntu1 has fixed the problem.

tags: added: verification-done
removed: verification-needed
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity - 5.14.0-0ubuntu1

---------------
unity (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Unity launcher shows internal partitions after they have been unmounted
      (LP: #994163)
    - can't click to dismiss hud in the area where dynamic hud results are
      meant to appear (LP: #962651)
    - Spread/Scale should exit if Dash is invoked (LP: #944033)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dash - The search bar gets the focus when pressing invalid keys
      (LP: #931393)
    - unity crashed with NameError in reset_unity_compiz_profile(): global name
      'GError' is not defined (LP: #778470)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      from unity::UnityWindow::glPaint() (LP: #851982)
    - "Keyboard Shortcuts" overlay can cause annoyance (LP: #934062)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - HUD Draws improperly while searching for results (LP: #932531)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold (LP: #839717)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - dash should open when pressing "super" in scale mode (LP: #1023811)
    - Multimonitor, Launcher - When the Launcher is set to autohide and
      'Sticky edges' are turned off, 'Launcher Edge Stop Overcome Pressure'
      seems to be broken when revealing the Launcher (LP: #987955)
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - Regression: shift+click on a launcher icon to open a new application
      instance gone (LP: #754565)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Duplicated applications icons on quick application restart (LP: #1003574)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - alt-backtick flickers between windows (LP: #987156)
    - [Hud] The result grid is not drawn in proximity of the search entry
      (LP: #1008603)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - [hud] The last button is not rounded (LP: #1008656)
    - Hud flickers when show up (LP: #1011507)
    - Dash maximise button changed location (LP: #987674)
    - launcher reordering "line" doesn't go to the bottom slot (LP: #971421)
    - Dash/HUD should close on "Spread" (LP: #870284)
    - Nothing should be written into the dash/hud searchbar whe...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Andrea Azzarone (azzar1) on 2012-08-21
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Precise):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignq
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers