HUD doesn't give the focus back to the active application after dash/hud use

Reported by Sebastien Bacher on 2012-02-17
86
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Gord Allott
Unity Distro Priority
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

On current precise with unity staging:

- run nautilus
- tap <alt> to open the hud
- type "ico" (should select view>icons), "enter"

-> the hud close but nautilus doesn't get focussed back

Related branches

lp:~gordallott/unity/fix-hud-lose-last-application-focus
Merged into lp:unity at revision 2063
Gord Allott (community): Approve on 2012-03-09
Mirco Müller: Approve on 2012-03-05
lp:~gordallott/unity/hud.restore-focus-on-return
Merged into lp:unity at revision 2065
Unity Team: Pending requested 2012-03-09
Omer Akram (om26er) on 2012-02-17
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
importance: Medium → High
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
milestone: none → 5.6.0
tags: added: hud
Didier Roche (didrocks) on 2012-02-20
summary: - doesn't give the focus back to the active application after hud use
+ doesn't give the focus back to the active application after dash/hud use
Changed in unity-distro-priority:
status: New → Triaged
importance: Undecided → High
status: Triaged → Fix Committed
Gord Allott (gordallott) on 2012-02-23
Changed in unity:
assignee: nobody → Gord Allott (gordallott)
status: Triaged → In Progress
John Lea (johnlea) on 2012-02-23
summary: - doesn't give the focus back to the active application after dash/hud use
+ HUD doesn't give the focus back to the active application after dash/hud
+ use
John Lea (johnlea) on 2012-02-23
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
Omer Akram (om26er) on 2012-02-23
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-03-09
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-03-14
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Tim Penhey (thumper) on 2012-04-22
Changed in ayatana-design:
status: Triaged → Fix Committed
Nick Tait (jnick-tait) on 2012-04-26
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udp
Edward Donovan (edward.donovan) wrote :

I still lose focus from the active window, after closing the Dash or HUD, in Quantal. Not every time, but many times a day. Is anyone else seeing this in Quantal? Maybe I'll need to open a new report. Thanks.

Branimir Kolar (branimir101) wrote :

I also lose focus in 12.04 after using hud and it usually happens after switching between apps using alt+tab. 'HUD focus' kinda stays on previus app. For example if I switch from chrome to sublime using Alt+Tab and then use the HUD on sublime after I enter somethin in the HUD focus will be on chrome instead on sublime.

Brian Coleman (brianfcoleman-0) wrote :

This is still happening to me on Ubuntu 12.04 64 bit with Sublime Text 3 and Google Chrome. When I use the HUD to activate a menu option in Sublime Text by pressing Alt, typing to filter and pressing up or down to select an entry, when I press Enter the menu option succeeds but after the HUD UI closes focus changes to Google Chrome.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers