HUD loses keypresses for the first second after opening

Bug #932906 reported by Roman Yepishev on 2012-02-15
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Installed: 5.2.0+bzr1974ubuntu0+644
Looks like this is 5.4-rc1

STR:

1. Click Alt calling hud
2. Right when it opens, start entering the text, e.g. "power"

Expected results:
HUD is opened, the "I-beam" prompt is ready so the whole word can be entered

Actual results:
You can type in the whole word w/o HUD noticing that or parts of the text go missing. If you type fast this is really noticeable.

Bilal Akhtar (bilalakhtar) wrote :

I can reproduce this bug on the same version.

Changed in unity:
status: New → Triaged
importance: Undecided → High
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → High
Omer Akram (om26er) on 2012-02-17
tags: added: hud
John Lea (johnlea) on 2012-02-23
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
Changed in unity:
milestone: none → backlog
tags: added: udp
Bence Lukács (lukacs-bence1) wrote :

The same with unity 5.4.0

Paul Sladen (sladen) wrote :

It's not a simple "as the first second", sometimes the first keystroke is captured, but then several missed.

Here's a screenshot of type "<alt> abcefghijklmnopq" at normal typing speed. The results, with dropped characters in between [square brackets] are:

  [abcd]efgh… (+ keyboard icon)
  a[bcde]fgh… (+ wifi icon)
  a[bcde]fgh… (+ Firefox icon)
  a[bcde]fgh… (+ wifi icon)

the unpredictability nullifies usefulness as it prevents the user "working ahead".

Paul Sladen (sladen) wrote :

Correction:

  [abcd]efgh… (+ keyboard icon)
  a[bcde]fgh… (+ wifi icon)
  a[bcd]efgh… (+ Firefox icon)
  a[bcd]efgh… (+ wifi icon)

The highest loss I think I've seen is up to 'g'. The alphabet isn't with muscle memory. If I type something made up of real words (such as "ubuntu linux" or "paul sladen" I get things like '[ubuntu l]inux' or 'p[aul sla]den'.

I had one instance where the first *two* characters were caught before the gap, but that could have been a typo as I haven' t been able to reproduce that one.

Didier Roche (didrocks) on 2012-03-07
Changed in unity:
status: Triaged → Fix Committed
milestone: backlog → 5.6.0
Omer Akram (om26er) on 2012-03-09
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Tim Penhey (thumper) on 2012-04-22
Changed in ayatana-design:
status: Triaged → Fix Committed
Nick Tait (jnick-tait) on 2012-04-26
tags: added: reviewedbydesignp
removed: udp
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers