showing quicklist from launcher keynav mode focuses last application

Bug #932486 reported by Thomi Richards on 2012-02-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Andrea Azzarone
7.2
Fix Committed
Medium
Unassigned
unity (Ubuntu)
Medium
Andrea Azzarone
Nominated for Trusty by Christopher Townsend
Trusty
Medium
Andrea Azzarone

Bug Description

[ Impact ]

Poor user experience due to the app window not being focused as expected.

[ Test Case ]

0. Have at least one application window open
1. Enter launcher keynav mode with Alt+F1
2. Select a launcher icon with the Up or Down keys.
3. Show the quicklist by pressing Right.
4. Collapse the quicklist by pressing Left.
5. Observe that the app window never has focus during the above steps.

[ Regression Potential ]

None observed.

Debdiff of the SRU is found here: https://bugs.launchpad.net/unity/+bug/886478/+attachment/4401967/+files/unity.7.2.5.debdiff

----------------------------------------------------------------------------

Original Description:

To reproduce:

0) Have at least one application window open
1) Enter launcher keynav mode with Alt+F1

 * Note that when entering keynav mode, the application loses focus. THe triangle to the right of it's launcher icon is no longer drawn, and the window title is not displayed in the panel.

2) Select a launcher icon with the Up or Down keys.
3) Show the quicklist by pressing Right.

 * Note that the application becomes active again - it's window title is drawn to the panel, and the triangle to the right of the launcher icon is drawn again.

4) Collapse the quicklist by pressing Left.

 * The app loses focus again.

This seems like inconsistent behavior to me... either the app should never lose focus when we enter keynav mode, or should not be activated when we show a quicklist.

Related branches

tags: added: precise
Changed in unity:
status: New → Confirmed
importance: Undecided → Medium
Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in unity:
milestone: none → 7.2.0
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Stephen M. Webb (bregma) on 2014-04-15
Changed in unity:
milestone: 7.2.0 → 7.2.1
Stephen M. Webb (bregma) on 2014-06-04
Changed in unity:
milestone: 7.2.1 → 7.2.2
Changed in unity:
milestone: 7.2.2 → 7.2.3
Changed in unity:
milestone: 7.2.3 → 7.3.1
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.1 → 7.3.2
Stephen M. Webb (bregma) on 2015-03-19
Changed in unity:
milestone: 7.3.2 → 7.3.3
Andrea Azzarone (azzar1) on 2015-03-20
Changed in unity:
assignee: Marco Trevisan (Treviño) (3v1n0) → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.2+15.04.20150330-0ubuntu1

---------------
unity (7.3.2+15.04.20150330-0ubuntu1) vivid; urgency=medium

  [ Andrea Azzarone ]
  * Do not restore focus if a quicklist is opened during launcher key
    navigation. (LP: #932486)
  * Forward first key event that happens on top of the blank window to
    the lockscreen. (LP: #1308265)
  * Hide launcher to avoid damaging window when not needed. Also make
    sure that pressure effect works fine (previous fix has been reverted
    because of this!). (LP: #1301394)
  * Make sure scope_views_[filter.id] exists before using operator[] on
    it. (LP: #926979)
  * Make sure that signals are auto-desconnected when
    XdndStartStopNotifierImp is destroyed. (LP: #1432231)
  * Release pointer barrier if launcher is in lock_hide state. (LP:
    #1029114)

  [ Sebastien Bacher ]
  * use the new nautilus .desktop name (LP: #1436297)

  [ Stephen M. Webb ]
  * AP tests: accounted for arbitrarily-raised exceptions in checking
    scaled windows (LP: #1436095)
 -- CI Train Bot <email address hidden> Mon, 30 Mar 2015 15:48:47 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Andrea Azzarone (azzar1)
description: updated
description: updated
description: updated

Hello Thomi, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.2.5+14.04.20150521.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Christopher Townsend (townsend) wrote :

The application window no longer is focused until exiting Launcher keynav mode. Marking verification-done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.5+14.04.20150521.1-0ubuntu1

---------------
unity (7.2.5+14.04.20150521.1-0ubuntu1) trusty; urgency=medium

  [ Chris Townsend ]
  * Releasing 7.2.5.
  * Bump version to 7.2.5.
  * Use a 2 second delay before showing the first run shortcut hints to
    workaround a race condition on input handling. (LP: #1313597)

  [ Andrea Azzarone ]
  * Add the possibility to specify the font size and the font weight
    without chaning the default font name. (LP: #886478)
  * Do not restore focus if a quicklist is opened during launcher key
    navigation. (LP: #932486)
  * Draw osk above unity shell. (LP: #1413165)
  * Forward first key event that happens on top of the blank window to
    the lockscreen. (LP: #1308265)
  * Make sure scope_views_[filter.id] exists before using operator[] on
    it. (LP: #926979)
  * Release pointer barrier if launcher is in lock_hide state. (LP:
    #1029114)

  [ Brandon Schaefer ]
  * When we quit the quicklist it would check if the mouse was over the
    launcher, if it wasn't it would fold the launcher. We don't need to
    check this if we are in keynav as we want all the icons to be
    unfolded. (LP: #1246891)

  [ CI Train Bot ]
  * New rebuild forced.

  [ Stephen M. Webb ]
  * AP tests: accounted for arbitrarily-raised exceptions in checking
    scaled windows (LP: #1436095)

 -- CI Train Bot <email address hidden> Thu, 21 May 2015 15:07:15 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers