Dash - The search bar gets the focus when pressing invalid keys

Bug #931393 reported by Andrea Azzarone on 2012-02-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
6.0
Fix Released
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)
Precise
Medium
Marco Trevisan (Treviño)

Bug Description

[Test Case]
1. Open the dash
2. Use the keyboard navigation to focus a dash icon
3. Press SHIFT (just it) (or CTRL, ALT, F1...)
   -> Verify that nothing happens

[Regression Potential]
Broken dash input or not working IBus input.

Original description:

To reproduce:

[*] Open the dash
[*] Use the keyboard navigation to focus a dash icon
[*] Press SHIFT (just it) (or CTRL, ALT, F1...)

Outcome:
The search bar gets the focus.

What should happens:
Nothing.

Related branches

Andrea Azzarone (azzar1) on 2012-02-13
description: updated
John Lea (johnlea) on 2012-02-13
summary: - The search bar gets the focus when pressing shift
+ Dash - The search bar gets the focus when pressing shift
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Confirmed
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
milestone: none → backlog
status: New → Confirmed
Changed in ayatana-design:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-02-13
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
John Lea (johnlea) on 2012-03-07
Changed in unity:
importance: Low → Medium
Omer Akram (om26er) on 2012-03-09
Changed in unity (Ubuntu):
importance: Low → Medium
Changed in unity:
assignee: Andrea Azzarone (andyrock) → Marco Trevisan (Treviño) (3v1n0)
milestone: backlog → 5.14.0
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
summary: - Dash - The search bar gets the focus when pressing shift
+ Dash - The search bar gets the focus when pressing invalid keys
description: updated
no longer affects: unity/5.0
Changed in unity:
status: In Progress → Triaged
Changed in unity:
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
description: updated
description: updated
Changed in unity (Ubuntu Precise):
importance: Undecided → Low
status: New → In Progress
importance: Low → Medium

Hello Andrea, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Andrea Azzarone (azzar1) on 2012-07-23
tags: added: verification-done
removed: verification-needed
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity - 5.14.0-0ubuntu1

---------------
unity (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Unity launcher shows internal partitions after they have been unmounted
      (LP: #994163)
    - can't click to dismiss hud in the area where dynamic hud results are
      meant to appear (LP: #962651)
    - Spread/Scale should exit if Dash is invoked (LP: #944033)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dash - The search bar gets the focus when pressing invalid keys
      (LP: #931393)
    - unity crashed with NameError in reset_unity_compiz_profile(): global name
      'GError' is not defined (LP: #778470)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      from unity::UnityWindow::glPaint() (LP: #851982)
    - "Keyboard Shortcuts" overlay can cause annoyance (LP: #934062)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - HUD Draws improperly while searching for results (LP: #932531)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold (LP: #839717)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - dash should open when pressing "super" in scale mode (LP: #1023811)
    - Multimonitor, Launcher - When the Launcher is set to autohide and
      'Sticky edges' are turned off, 'Launcher Edge Stop Overcome Pressure'
      seems to be broken when revealing the Launcher (LP: #987955)
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - Regression: shift+click on a launcher icon to open a new application
      instance gone (LP: #754565)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Duplicated applications icons on quick application restart (LP: #1003574)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - alt-backtick flickers between windows (LP: #987156)
    - [Hud] The result grid is not drawn in proximity of the search entry
      (LP: #1008603)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - [hud] The last button is not rounded (LP: #1008656)
    - Hud flickers when show up (LP: #1011507)
    - Dash maximise button changed location (LP: #987674)
    - launcher reordering "line" doesn't go to the bottom slot (LP: #971421)
    - Dash/HUD should close on "Spread" (LP: #870284)
    - Nothing should be written into the dash/hud searchbar whe...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Christian Giordano (nuthinking) wrote :

Pressing the Alt key, the Dash is correctly dismissed and the HUD launched. Maybe the description should be modified.

tags: added: reviewedbydesignq
removed: udp
Changed in ayatana-design:
status: Fix Committed → Fix Released

The problem was about keeping pressed Alt, not only tapping it.

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Precise):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers