Window management, Launcher, multi-monitor - Windows can't be maximized on the lower display in vertically-stacked configuration

Reported by Roman Yepishev on 2012-02-13
42
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Andrea Azzarone
unity (Ubuntu)
High
Andrea Azzarone

Bug Description

STR:

0. Make sure you have two displays connected
1. Configure the displays to be vertically-stacked
2. Move a maximizable window on the lower display to the top edge.

Actual results:
- The window travels to the display above.

Expected results:
- Maximize animation appears and when mouse button is released, the window becomes maximized
- There should be edge-stop (sticky edge) effect on top and bottom edges. Currently the edge stop is only active on the left and right edges of the screen.

-------------------------------------
Desired resolution:

- Add edge-stop (sticky edge) behaviour to the top and bottom edges of the monitor.

Related branches

lp:~andyrock/unity/fix-lp-931384
Merged into lp:unity at revision 3459
PS Jenkins bot: Approve (continuous-integration) on 2013-08-11
Brandon Schaefer: Approve on 2013-08-09
Roman Yepishev (rye) wrote :
John Lea (johnlea) on 2012-02-13
summary: - Windows can't be maximized on the lower display in vertically-stacked
- configuration
+ Window management, Launcher - Windows can't be maximized on the lower
+ display in vertically-stacked configuration
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Triaged
Changed in unity:
milestone: none → backlog
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
John Lea (johnlea) on 2012-02-16
summary: - Window management, Launcher - Windows can't be maximized on the lower
- display in vertically-stacked configuration
+ Window management, Launcher, multi-monitor - Windows can't be maximized
+ on the lower display in vertically-stacked configuration
tags: added: multimonitor
Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: Medium → Critical
John Lea (johnlea) on 2012-02-20
Changed in unity:
importance: Undecided → High
Tim Penhey (thumper) on 2012-04-20
Changed in ayatana-design:
status: Triaged → Fix Committed
John Lea (johnlea) on 2012-06-18
description: updated
description: updated
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 760240, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

John Lea (johnlea) wrote :

@vanvugt; I'm not sure that this bug is a duplicate of bug 760240 so I have removed the duplicate link. The reason I am not sure about it being a duplicate is because this bug covers the vertical monitor stacking case and specifically the lack of edge-stop (sticky edge) behaviour on the top and bottom edges of the monitor. I have updated the description to make this clearer

Changed in compiz:
status: New → Confirmed
Changed in compiz-core:
status: New → Confirmed
Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
John Lea (johnlea) on 2012-06-19
description: updated
Omer Akram (om26er) on 2012-07-09
no longer affects: compiz-core
no longer affects: unity (Ubuntu)
John Lea (johnlea) on 2012-07-10
Changed in unity:
status: Confirmed → Triaged
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
John Lea (johnlea) on 2012-09-03
Changed in compiz:
status: Confirmed → Triaged
Changed in compiz (Ubuntu):
status: Triaged → Invalid
Changed in compiz:
status: Triaged → Invalid
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) on 2012-09-14
no longer affects: compiz
no longer affects: compiz (Ubuntu)
Changed in unity:
milestone: none → backlog
John Lea (johnlea) on 2012-10-10
Changed in ayatana-design:
importance: Critical → High
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
milestone: backlog → 7.1.1
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.1

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.1.0+13.10.20130812.1-0ubuntu1

---------------
unity (7.1.0+13.10.20130812.1-0ubuntu1) saucy; urgency=low

  [ Brandon Schaefer ]
  * Add ibus.py to the tests/autopilot/unity/emulators from
    lp:autopilot. (LP: #1210661)
  * Don't make the ScopeView/DashView/ScrollView Visible on start up
    (bool wise, causing things to think its ok to render). (LP:
    #1201631)
  * Adds the ability to use the mouse in the switcher. (LP: #824965)

  [ Andrea Azzarone ]
  * Add edge barriers to unity::panel::PanelView. (LP: #931384)

  [ Marco Trevisan (Treviño) ]
  * ApplicationLauncherIcon: Create a local desktop file when sticking
    an app that has not Also make icon sticky only if both the icon
    itself and the inner app is sticky as well. (LP: #1209320, #753305,
    #765466, #754334, #704046)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3462
 -- Ubuntu daily release <email address hidden> Mon, 12 Aug 2013 06:49:01 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers