Launcher - Icons are not colorized properly

Bug #930949 reported by brncsk on 2012-02-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
Andrea Cimitan
Unity
Fix Released
Medium
Jason Smith
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Launcher icons should be tinted with the average color of the background when the dash is open (since revision 1879), however mine are still white-ish gray. The same happens to the BFB even when the dash is not open.

brncsk (adam-barancsuk) wrote :
brncsk (adam-barancsuk) wrote :
Hernando Torque (htorque) wrote :

I cannot reproduce this with revision 1953.

Omer Akram (om26er) wrote :

Jason knows about the issue he said ARB GPUs yet inherit the color. I saw it on one of my system.

Changed in unity:
milestone: none → 5.6.0
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Medium
status: New → Triaged
Omer Akram (om26er) wrote :

*don't yet

brncsk (adam-barancsuk) wrote :

Thanks for the info, I'm on an Intel 945GM so this must be the case.

Andrea Cimitan (cimi) wrote :

Still a bug, even if drastically improved with the latest changes to launcher icons.
What is wrong in the current implementation is that launcher icons gets desaturated and becomes more transparent. They should be colorized instead (for example, desaturating the icon and blend it with OVERLAY blending operator) and not lose in transparency.

The animation from state A (fully normal colored) to be (wallpaper-colorization for icons) could be applied by calculating the wallpaper-colorized version of the icon and paint with alpha from 0.0 to 1.0 above the state A icon.

tags: added: unity3p
Changed in ayatana-design:
assignee: nobody → Andrea Cimitan (cimi)
status: New → Fix Committed
Andrea Cimitan (cimi) on 2012-02-15
summary: - Launcher icons are not colorized properly
+ Launcher - Icons are not colorized properly
Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: Undecided → Critical
tags: added: udp
Jason Smith (jassmith) wrote :

ARB shaders are now fixed. Any remaining complaints should be opened in a new bug.

Changed in unity:
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-03-01
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Nick Tait (jnick-tait) on 2012-03-07
tags: added: furtherdesignreviewrequiredp
removed: top5p udp unity3p
Nick Tait (jnick-tait) on 2012-03-07
tags: added: udp
Tim Penhey (thumper) on 2012-04-16
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-04-16
Changed in ayatana-design:
status: Fix Released → Fix Committed
Nick Tait (jnick-tait) on 2012-04-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: furtherdesignreviewrequiredp
Nick Tait (jnick-tait) on 2012-04-20
tags: removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers