Dash - Different states of rating stars, and dimensions

Bug #924884 reported by Xi Zhu on 2012-02-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
Medium
Mirco Müller
unity (Ubuntu)
Medium
Unassigned

Bug Description

In order to keep the consistency, rating stars in dash filter results have been tweaked in new shape and pattern. Also, dimensions should be bigger.

left to right:

2nd: selected
3rd: selected&focus (50% opacity #ffffff on top of selected state)
4th: deselected&focus (50% opacity #ffffff on top of deselected state)
5th: deselected

Related branches

Xi Zhu (xi.zhu) wrote :
Xi Zhu (xi.zhu) wrote :
Xi Zhu (xi.zhu) wrote :
Xi Zhu (xi.zhu) wrote :
Xi Zhu (xi.zhu) wrote :
Omer Akram (om26er) on 2012-02-01
Changed in unity:
importance: Undecided → Medium
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
status: Incomplete → Confirmed
Omer Akram (om26er) on 2012-02-01
Changed in unity:
milestone: none → backlog
Mirco Müller (macslow) on 2012-02-03
Changed in unity:
assignee: nobody → Mirco Müller (macslow)
John Lea (johnlea) on 2012-02-03
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
tags: added: udp
Omer Akram (om26er) on 2012-02-03
Changed in unity:
milestone: backlog → 5.4.0
Mirco Müller (macslow) wrote :

It is correct that the spacing/gap between the bottom edge of the All-button and the upper edge of the rating stars has been reduced to just 2 pixels? It used to be 12 pixels like in all other filter-categories too. See the attached screenshot from my detail-hunting in gimp... comparing old vs new.

Xi Zhu (xi.zhu) wrote :

No, it is not changed.

Andrea Cimitan (cimi) on 2012-02-15
description: updated
summary: - Different states of rating stars
+ Different states of rating stars, and dimensions
Andrea Cimitan (cimi) on 2012-02-15
summary: - Different states of rating stars, and dimensions
+ Dash - Different states of rating stars, and dimensions
Mirco Müller (macslow) on 2012-02-17
Changed in unity:
status: Confirmed → In Progress
Didier Roche (didrocks) on 2012-02-17
Changed in unity:
milestone: 5.4.0 → 5.6.0
Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
Tim Penhey (thumper) on 2012-02-20
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Nick Tait (jnick-tait) on 2012-04-26
tags: added: reviewedbydesignp
removed: udp
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers