custom background color breaks display of launcher icons if #000000 is used

Reported by Doug McMahon on 2012-01-31
94
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Unity
Low
Marco Biscaro
5.0
Low
Unassigned
unity (Ubuntu)
Low
Marco Biscaro
Nominated for Precise by Daniel van Vugt

Bug Description

They just come up 'there', but uncolored so basically invisible, (can be seen on an lightened screen area to some extent

Related branches

lp:~marcobiscaro2112/unity/custom-bg
Merged into lp:unity at revision 2653
MC Return (community): Approve on 2012-09-03
Andrea Azzarone: Approve on 2012-09-01
Nick Dedekind: Approve on 2012-08-22
Daniel van Vugt: Pending requested 2012-09-03
Thomi Richards: Pending requested 2012-07-12
Omer Akram: Pending requested 2012-07-12
Doug McMahon (mc3man) wrote :
Bowmore (bowmore) wrote :

This seems to be the case only when using black (#000000) as the background color for dash/laucher. Changing it to e.g. #000001 reveals the laucher icons again.

Bowmore (bowmore) on 2012-02-01
Changed in unity:
status: New → Confirmed

On 01/31/2012 07:46 PM, Bowmore wrote:
> This seems to be the case only when using black (#000000) as the
> background color for dash/laucher. Changing it to e.g. #000001 reveals
> the laucher icons again.
>
Correct, it was set to black in 5.0, (set thru gconf where the numbering
is a bit different

Was able to achieve basically the same by setting to a very dark blue &
raising the opacity

Didier Roche (didrocks) on 2012-02-01
Changed in unity (Ubuntu):
status: New → Confirmed

This bug still exists. Im using 5.8.0-0ubuntu2.
If i set rgb(1,1,1) the Dash icon looks lightgrey. But it would be awesome if rgb(0,0,0) would be possible too!
Just like the Launcher was before Unity 5.0.

The opacity itself is not important, if opacity>0 the chosen color will be used, if it opacity=0 the background image "main color" will be used.
Just look at my screenshot for further details(it is split into the two situations grey and black).

Doug McMahon (mc3man) on 2012-04-07
summary: - custom background color breaks display of launcher icons in 5.2-rc1
+ custom background color breaks display of launcher icons if #000000 is
+ used
thom (tsk) wrote :

Bug has become worse:

unity:
  Geïnstalleerd: 5.10.0-0ubuntu1
  Kandidaat: 5.10.0-0ubuntu1
  Versietabel:
 *** 5.10.0-0ubuntu1 0
        500 http://nl.archive.ubuntu.com/ubuntu/ precise-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     5.8.0-0ubuntu2 0
        500 http://nl.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

when saving color, launcher changes it to another color without my permission.
Launcher always follows the color of the background instead of my command.

Did not found any manual override (which, in itself, is a bug)

Doug McMahon (mc3man) wrote :

Thon - this is the bug you're referring to & more likely to be fixed than this one which is solely about using #000000
Bug 975350

thom (tsk) wrote :

Doug...thanks, that is it indeed, I didn't know that the chamelion-bug was a feature gone wrong.

At the moment I also experience when I enter #000000 it is saved as #000001
I don't know wether this must pass for a bugfix or just unintended behaviour (another bug).

Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
assignee: nobody → Marco Biscaro (marcobiscaro2112)
Changed in unity (Ubuntu):
assignee: nobody → Marco Biscaro (marcobiscaro2112)
Doug McMahon (mc3man) wrote :

Gave the proposed diff a try here - works well so far, hopefully will pass review

Doug McMahon (mc3man) on 2012-06-08
tags: added: precise quantal unity
removed: 5.2-rc1
Changed in unity:
milestone: none → 6.2
Doug McMahon (mc3man) wrote :

Just to mention -
the previously proposed fix for #000000 (launcher.cpp commit), still works quite fine in 6.0
Obviously the other part of that commit wasn't acceptable & is no longer usable anyway
Just hoping the that #000000 doesn't fall by the wayside when you fix the loss of color setting on login

Didier Roche (didrocks) on 2012-08-10
Changed in unity:
milestone: 6.2 → 6.4
Changed in unity:
milestone: 6.4 → 6.6
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-09-14
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
milestone: 6.6 → 7.0
importance: Undecided → Low
Newfie (mn-newfie) wrote :

Good to see that this seems to have been fixed. Is there any chance that this is going to get backported to 12.04? I'd really love to set my launcher to look like it did in Oneiric :)

Dawid M. (dejw18) wrote :

Me too. I'd also love to see it backported to 12.04. It's one of the first things that catches your attention - that you cannot control the color of your working environment. This makes using Unity unpleasant.

Omer Akram (om26er) on 2012-09-20
no longer affects: unity/6.0
Changed in unity:
milestone: 7.0 → 6.6
Changed in unity:
status: Fix Committed → Fix Released
Doug McMahon (mc3man) wrote :

So i gather there is no interest/intention of backporting this fix to 12.04??
(that's where it broke & there was plenty of time before 12.04 release to fix so it would be a shame to let it go.

Daniel van Vugt (vanvugt) wrote :

Fix released in Ubuntu 12.10 as far as I can tell.

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
importance: Undecided → Low
Doug McMahon (mc3man) wrote :

Put up a ppa for those wishing to test to fix applied to 12.04
https://launchpad.net/~mc3man/+archive/color-fix

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers