HUD - closing a window with <Alt>+<F4> opens the hud

Reported by Martin-haesler on 2012-01-29
244
This bug affects 66 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Compiz Core
High
Daniel van Vugt
Unity
High
Tim Penhey
Unity Distro Priority
High
Unassigned
unity-2d
High
Unassigned
compiz (Ubuntu)
Undecided
Daniel van Vugt
Nominated for Precise by Alan Pope ㋛
unity-2d (Ubuntu)
High
Unassigned
Nominated for Precise by Alan Pope ㋛
unity (Ubuntu)
High
Tim Penhey
Nominated for Precise by Alan Pope ㋛

Bug Description

Closing a window with the <Alt>+<F4> shortcut closes the window, but also opens the hud.

This doesn't always happen, but nearly all of the time.

-------------------
Desired solution:

The HUD should only show on Alt RELEASE. In other words,
tap-and-release-alt should show the HUD, together with
three-finger-tap-on-window in touch environments.

Ted Gould (ted) on 2012-01-30
affects: indicator-appmenu → unity
Omer Akram (om26er) on 2012-01-30
tags: added: hud
Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in unity:
status: New → Incomplete
Martin-haesler (martin-haesler) wrote :

Yes, it was reproducible. It happened (I write happened, because since todays updates HUD stopped working completely :(
nearly every time. To recreate it, open Firefox, press <Alt>, wait for a tiny little bit then press <F4>. This will close the window,
as it should, but will also open the HUD.

Bilal Akhtar (bilalakhtar) wrote :

Thinking more about it, we need design discussion on whether the HUD should open only on Alt RELEASE, or whether it should close upon detecting another key being pressed as part of an Alt+whatever combination.

Changed in unity:
status: Incomplete → Confirmed
importance: Undecided → High
Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → High
tags: added: needs-design
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Changed in unity:
status: Confirmed → Incomplete

The HUD should only show on Alt RELEASE, yes. In other words,
tap-and-release-alt should show the HUD, together with
three-finger-tap-on-window in touch environments.

Mark

John Lea (johnlea) on 2012-02-08
tags: added: udp
removed: needs-design
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Changed in unity:
milestone: none → backlog
John Lea (johnlea) on 2012-02-08
summary: - closing a window with <Alt>+<F4> opens the hud
+ HUD - closing a window with <Alt>+<F4> opens the hud
Didier Roche (didrocks) on 2012-02-10
Changed in unity-distro-priority:
status: New → Triaged
importance: Undecided → High
Tim Penhey (thumper) on 2012-02-13
Changed in ayatana-design:
status: Triaged → Fix Committed
Omer Akram (om26er) on 2012-02-13
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity:
milestone: backlog → 5.4.0
importance: High → Medium
Changed in unity (Ubuntu):
importance: High → Medium
Tim Penhey (thumper) on 2012-02-16
Changed in unity:
status: Fix Committed → In Progress
assignee: nobody → Tim Penhey (thumper)
importance: Medium → High
David Barth (dbarth) on 2012-02-17
Changed in unity (Ubuntu):
status: Fix Committed → In Progress
Changed in unity:
milestone: 5.4.0 → 5.6.0
Changed in unity (Ubuntu):
milestone: none → ubuntu-12.04-beta-1
assignee: nobody → Tim Penhey (thumper)
David Gómez (dabisu) wrote :

Another problem similar to this one. The standard key combination to switch the input method is Alt + Space, and HUD appears when it shouldn't. I had to disable it in CCSM because my system was unusable.

Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
Guilherme Salgado (salgado) wrote :

I see a similar issue when using Alt+1..9 to switch application tabs, but in my case it looks more like a race condition so I filed bug 938720

tags: added: rls-mgr-p-tracking
Omer Akram (om26er) on 2012-02-23
Changed in unity (Ubuntu):
importance: Medium → High
David Owen (dsowen) wrote :

Not just Alt, but any modifier key. I also get this type of behavior with chords involving Super.

Paul Sladen (sladen) wrote :

Bug #940413 has been marked a dup of this, but hasn't brought the method over; being:

  Alt down
  key down
  Alt release
  key release

which causes the action, /and/ triggers the HUD. Vs:

  Alt down
  key down
  key release
  Alt release

which merely causes the action, /without/ triggering the HUD.

bakytn (bakytn) wrote :

This also affected when you change the keyboard layout (which is usually Alt+Shift)

Corey Kearney (snkiz) wrote :

It would appear any shortcut involving alt can cause this. I just got with <alt>print screen while I was taking a screenshot of a window. The super key does it too. Pulls up the shortcut overview or unhides the launcher or opens the dash or brings up the launcher numbers. or any combination of that list.

Omer Akram (om26er) on 2012-02-29
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
bakytn (bakytn) wrote :

how can we test? Thank you!

Martin Pitt (pitti) on 2012-03-02
Changed in unity (Ubuntu):
milestone: ubuntu-12.04-beta-1 → ubuntu-12.04-beta-2
blinkblink (thomasthoma) wrote :

There are some duplicates of this bug,
concerning the fact that ALT+SHIFT is used for switching keyboard layout.

It's annoying (and confusing to new users) that sometimes the HUD comes up accidentaly.

A possible solution would be to use: ALT+SPACE to invoke the HUD.

Another possible solution: easily discoverable customization of the HUD shortcut.

Cheers!

kao_chen (kaochen2) wrote :

This bug affect also blender.
It's now impossible to merge two vertex with the Alt + M
It's very annoying.
Other shortcuts in the software began with alt. Super + h will be better

Paul Sladen (sladen) wrote :

First HUD key-binding change:

bzr log -r 1737.2.5..1737.2.6

  revno: 1737.2.6
  committer: Gord Allott <email address hidden>
  branch nick: hud-proto
  timestamp: Fri 2011-12-02 14:47:45 +0000
  message:
    change the key binding for hud to <Super>H

bzr diff -r 1737.2.5..1737.2.6
  === modified file 'plugins/unityshell/unityshell.xml.in'
  --- plugins/unityshell/unityshell.xml.in 2011-11-15 18:24:50 +0000
  +++ plugins/unityshell/unityshell.xml.in 2011-12-02 14:47:45 +0000
  @@ -43,5 +43,5 @@
                   <option name="show_hud" type="key">
                       <_short>Key to show the matrix</_short>
                       <_long>Make the matrix appear with that key</_long>
  - <default>&lt;Shift&gt;h</default>
  + <default>&lt;Super&gt;h</default>
                     </option>

Second key-binding change is:

  bzr diff -r 1737.8.2..1737.8.3

which introduces a bit of helper code too, including a 50 ms hard-coded timeout. However, the whole things seems to hinge upon:

  optionGetShowHud().key().toString() == action->key().toString()

which doesn't seem to be capable of expressing the requirement "Press and release of Alt with no other keys touched (pressed, or released) in the meantime.

Paul Sladen (sladen) wrote :

Update from Gord; there have been additional logic changes, and it's "mostly handled inside compiz now".

Avik Topchyan (topchyan) wrote :

Paul, does this mean I have to install compiz manager every time and fix this manually? Is it possible to customize HUD or any other shortcut invocation without really installing compiz manager (which seems too involved and dangerous for a normal user). Thanks!

Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
bakytn (bakytn) wrote :

Yeah working fine! I am happy that was..truly annoying :D

On Mar 12, 2012, at 07:27 PM, bakytn wrote:

>Yeah working fine! I am happy that was..truly annoying :D

What's the likelihood of getting a fix into Unity 2D? ;)

Or maybe I should just comment out the HUD in my own PPA.

Didier Roche (didrocks) on 2012-03-14
Changed in unity-distro-priority:
status: Triaged → Fix Released
bakytn (bakytn) wrote :

Barry, should work already

Shahar Or (mightyiam) wrote :

Thanks a bunch for the fix!

One of the more irritating and impossible bugs on our desktop ever :)

Barry Warsaw (barry) wrote :

On Mar 15, 2012, at 07:58 AM, bakytn wrote:

>Barry, should work already

Unless I've missed something, this is still a serious problem in Unity 2D.

Shahar Or (mightyiam) wrote :

Dear Barry,
I've just checked Unity 2D in precise and haven't experienced this.
Thanks,
Shahar

Gustavo Niemeyer (niemeyer) wrote :

The behavior is still not entirely correct. HUD isn't popping up anymore, but an ALT-<key> sequence that is used as a shortcut (e.g. ALT-<1-4> to change workspaces) is now being sent to the open application in addition to change the workspace. This means that every time I change from the browser (Chromium) workspace to another one, the tab in the browser changes too. The shortcut should be consumed in those cases, rather than being dispatched to the application.

tags: added: rls-p-tracking
Daniel van Vugt (vanvugt) wrote :

@Gustavo, your issue with Alt-<1-4> is bug 953834.

Changed in compiz-core:
status: New → Fix Committed
assignee: nobody → Daniel van Vugt (vanvugt)
importance: Undecided → High
milestone: none → 0.9.7.2
Changed in compiz (Ubuntu):
status: New → Fix Released
assignee: nobody → Daniel van Vugt (vanvugt)
Barry Warsaw (barry) wrote :

On Mar 19, 2012, at 01:09 AM, Gustavo Niemeyer wrote:

>The behavior is still not entirely correct. HUD isn't popping up
>anymore

Under Unity 3d, a quick tap of Alt will summon the HUD. Lingering longer on
Alt does not though, and this seems fairly natural from my quick
experimentation. The tap doesn't interfere with normal Emacs usage or
Alt-Tabbing for example (at least for me).

Note that Unity 2d still is not fixed.

Changed in compiz-core:
status: Fix Committed → Fix Released
Albert Astals Cid (aacid) wrote :

"Note that Unity 2d still is not fixed."

Did it ever have this bug? I can't reproduce it here

Barry Warsaw (barry) wrote :

On Mar 19, 2012, at 12:07 PM, Albert Astals Cid wrote:

>"Note that Unity 2d still is not fixed."
>
>Did it ever have this bug? I can't reproduce it here

These are probably better bugs that describe the problem with HUD and Unity
2d:

https://bugs.launchpad.net/ubuntu/+source/unity-2d/+bug/947468
https://bugs.launchpad.net/unity-2d/+bug/947613

I hope the problem with Unity 2d gets addressed before the final release of
Precise, because it makes the 2d desktop incredibly painful to use for
development.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Gerry Boland (gerboland) on 2012-03-28
Changed in unity-2d:
milestone: none → 5.10.0
importance: Undecided → High

Seems like this is causing quite a few problems for people. Could you please take a look to see how to mitigate the problem?

Changed in unity-2d (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Albert Astals Cid (aacid) wrote :

For the people having the problem with the HUD being triggered incorrectly (i.e. when doing Alt+F4 like the bug subject says) under unity-2d it would be great if you could install the unity-2d packages at my PPA
https://launchpad.net/~aacid/+archive/ppaprecise/
and do the following after upgrading
open a terminal
killall unity-2d-shell
killall unity-2d-shell (yes you need this twice)
unity-2d-shell
And then trigger the bug and write here which keypresses you did and attach the output of unity-2d-shell

The code at my PPA has extra debugging enabled that will monitors the state of the internal code that is responsible of triggering the HUD and will hopefully help us find what is wrong in the unity-2d code

David Barth (dbarth) on 2012-04-06
Changed in unity-2d:
status: New → In Progress
assignee: nobody → Albert Astals Cid (aacid)
Changed in unity-2d (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Albert Astals Cid (aacid)
milestone: none → ubuntu-12.04
Didier Roche (didrocks) on 2012-04-12
Changed in unity-2d:
milestone: 5.10.0 → 5.12
Barry Warsaw (barry) wrote :

Yes, the bug still occurs for me when I hit Alt. Note that I can hit and hold Alt for 10 seconds, then release it and it still brings up the HUD. This is true even though I have System Systems->Keyboard->Shortcuts->Key to show the HUD set to Super+Space.

Barry Warsaw (barry) wrote :

Oh, just to be clear, this is with the PPA installed as directed.

Albert Astals Cid (aacid) wrote :

Barry can you please attach the log produced by the ppa version of unity-2d-shell?

Asa Zernik (asaz989) wrote :

For the unity-2d version of this bug, note that, as Paul mentioned (https://bugs.launchpad.net/ubuntu/+source/unity-2d/+bug/923410/comments/8), you need to use the right (wrong?) sequence of presses and releases to reproduce the bug. Specifically, the following sequence works correctly:

Alt down
key down
key release
Alt release

While the following sequence unexpectedly brings up the HUD:

Alt down
key down
Alt release
key release

Didier Roche (didrocks) on 2012-04-27
Changed in unity-2d:
milestone: 5.12 → 5.14
Ryan Fugger (rfugger) wrote :

I'm running unity 5.10.0, and still experiencing this bug in Firefox with the alt-left arrow (back shortcut) and alt-right arrow (forward shortcut) combinations. Can you re-open this, or should I open a new bug? Thanks.

Changed in unity-2d:
assignee: Albert Astals Cid (aacid) → nobody
Changed in unity-2d (Ubuntu):
assignee: Albert Astals Cid (aacid) → nobody
Gerry Boland (gerboland) wrote :

I believe this is fixed in Unity 2D 5.12, as released in Precise. Marking as fixed released. If anyone disagrees, please re-open.

Changed in unity-2d (Ubuntu):
status: In Progress → Fix Released
Changed in unity-2d:
status: In Progress → Fix Released
Asa Zernik (asaz989) wrote :

Launchpad doesn't seem to want to let me re-open for unity-2d, but this issue is definitely still present.

Doug McMahon (mc3man) wrote :

On 05/15/2012 07:58 AM, Asa Zernik wrote:
> Launchpad doesn't seem to want to let me re-open for unity-2d, but this
> issue is definitely still present.
>
Not an issue here unless one tries to cause the Hud to open by tapping
Alt+F4 quickly, try pressing Alt key down, then hit F4

Gerry Boland (gerboland) wrote :

#Asa Zernik
can you give me careful steps to reproduce this? Can you please check you're running unity-2d version 5.14 or greater? What hardware are you using?
-G

Gerry Boland (gerboland) wrote :

Sorry, I meant 5.12
-G

Barry Warsaw (barry) wrote :

On May 15, 2012, at 11:58 AM, Asa Zernik wrote:

>Launchpad doesn't seem to want to let me re-open for unity-2d, but this
>issue is definitely still present.

It still happens for me (IIRC, I showed didrocks at UDS). I suspect it's
caused by oddness in the VM layer's mapping of keys to the guest though.
Since I can now remap the HUD away from the really painful left-Alt, I'm happy
to allow this issue to be set to Won't Fix for my environment.

Steve Langasek (vorlon) wrote :

My bug #977683 was marked as a duplicate of this one, and definitely is still an issue. The tap detection seems to not take into account other non-alt chordic keypresses, and the timeout is designed for slow typers. Whenever I alt+tab quickly between windows, this is still an issue for me.

Changed in unity-2d (Ubuntu):
milestone: ubuntu-12.04 → none
status: Fix Released → Triaged
Gerry Boland (gerboland) wrote :

Case of Ubuntu inside a VM is not something we can easily fix, as we need to globally listen for any Alt key presses. There's no easy way around this.

The tap detection code does indeed take into account all other keypresses. The HUD should only show if you press & release the Alt key quickly, and having pressed no other key in the mean time. Perhaps some keys are not reported correctly. xev output would help us.

Any steps to reproduce and information about your system would be useful. External/internal keyboard, computer model, etc.
-G

Steve Langasek (vorlon) wrote :

On Tue, May 15, 2012 at 04:15:31PM -0000, Gerry Boland wrote:
> The tap detection code does indeed take into account all other
> keypresses. The HUD should only show if you press & release the Alt key
> quickly, and having pressed no other key in the mean time. Perhaps some
> keys are not reported correctly. xev output would help us.

Here's some xev output. But doesn't this suffer from the fundamental
problem that xev only shows the keypresses that are seen by the xev window?
(Whereas Alt+Tab is handled by the WM)

> Any steps to reproduce and information about your system would be useful.
> External/internal keyboard, computer model, etc.

External keyboard, ThinkPad X201, user who is very fast at Alt+Tab'ing ;)

FocusIn event, serial 33, synthetic NO, window 0x4c00001,
    mode NotifyWhileGrabbed, detail NotifyNonlinear

KeymapNotify event, serial 33, synthetic NO, window 0x0,
    keys: 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

FocusIn event, serial 33, synthetic NO, window 0x4c00001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 33, synthetic NO, window 0x0,
    keys: 3 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

KeyPress event, serial 33, synthetic NO, window 0x4c00001,
    root 0xbf, subw 0x0, time 922669940, (891,788), root:(893,868),
    state 0x0, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

FocusOut event, serial 33, synthetic NO, window 0x4c00001,
    mode NotifyGrab, detail NotifyAncestor

FocusOut event, serial 33, synthetic NO, window 0x4c00001,
    mode NotifyWhileGrabbed, detail NotifyNonlinear

FocusIn event, serial 33, synthetic NO, window 0x4c00001,
    mode NotifyWhileGrabbed, detail NotifyNonlinear

KeymapNotify event, serial 33, synthetic NO, window 0x0,
    keys: 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

FocusIn event, serial 33, synthetic NO, window 0x4c00001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 33, synthetic NO, window 0x0,
    keys: 3 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

FocusOut event, serial 33, synthetic NO, window 0x4c00001,
    mode NotifyNormal, detail NotifyNonlinear

Daniel van Vugt (vanvugt) wrote :

Ryan: The problem with Alt+Arrow is bug 969039. Not this one.

Barry: If you're running Unity 3D on your VM host then that is bug 806255. Not this one.

Barry Warsaw (barry) wrote :

On May 16, 2012, at 01:48 AM, Daniel van Vugt wrote:

>Barry: If you're running Unity 3D on your VM host then that is bug
>806255. Not this one.

I was running Unity 2D. Just today I upgraded my VM guest to Quantal and
since I heard that 2D is going away in Quantal, I've switched to 3D for now.
It seems like a more future-proof path to bang on 3D and report bugs on it
than to fight with 2D, especially if it is going away.

John Lea (johnlea) on 2012-10-12
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udp
Changed in unity-2d (Ubuntu):
status: Triaged → Fix Released
JKL (jkl102001) wrote :

The Alt + PrintScreen case isn't fixed yet. That was bug 937036, and somebody marked it as a duplicate of this one, which I guess now is a catchall bug for all problems with Alt and the HUD.

What I observe is that pressing and holding Alt does nothing yet. While holding Alt, pressing and releasing Print Screen does nothing yet. Only when you finally release Alt does the screen capture happen, but before that the HUD comes up, and you end up capturing the HUD instead of the active window.

In other words, Alt + Printscreen doesn't work at all for what it is supposed to do.

I'm running 12.10, and I have tried both my laptop keyboard and an external USB keyboard.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers