when HUD is installed, can not take screenshot of window with Alt+PrtSrc

Reported by Robert Roth on 2012-01-29
90
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Unity
Low
Gord Allott
unity-2d
Undecided
Unassigned
unity (Ubuntu)
Low
Gord Allott

Bug Description

With ubuntu HUD installed, I can not take a screenshot of the focused window with the Alt+PrtSrc, as probably HUD gets the alt, so the screenshot tool takes Alt+PrtSrc as if only PrtSrc would have been pressed

Tags: hud Edit Tag help
Ted Gould (ted) on 2012-01-30
affects: indicator-appmenu → unity
Omer Akram (om26er) on 2012-01-30
tags: added: hud
Omer Akram (om26er) on 2012-01-31
Changed in unity:
importance: Undecided → Low
status: New → Confirmed
Didier Roche (didrocks) on 2012-02-01
Changed in unity (Ubuntu):
status: New → Confirmed
Robert Roth (evfool) on 2012-02-05
Changed in unity (Ubuntu):
importance: Undecided → Low
Omer Akram (om26er) on 2012-02-10
Changed in unity:
assignee: nobody → Gord Allott (gordallott)
Changed in unity (Ubuntu):
assignee: nobody → Gord Allott (gordallott)
Changed in unity:
status: Confirmed → Triaged
milestone: none → 5.4.0
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Didier Roche (didrocks) on 2012-02-17
Changed in unity:
milestone: 5.4.0 → 5.6.0
Sam_ (and-sam) wrote :

Pressing alt+print twice opens screenshot ui and leaves HUD. Other selected shortcuts are ignored by HUD.
As workaround to view screenshot ui using interactive mode via ccsm. (bug 927952)
I wouldn't consider interference with essential shortcuts as low. Introduction of more and more new shortcuts which in case interfere with system or custom shortcuts upsets users which is the last what a LTS needs.

Doug McMahon (mc3man) wrote :

Well I got duped to this with a slightly differing bug & at least here this isn't true. Alt+print works fine, it just opens Hud after completing
As soon as the print key is released the screenshot is taken, then Hud open
This behavior was seen on a 5 day old install & currently is on a new install with today's image

Also can be seen from a live session with today's image, may be worth someone else checking
(if you change or disable Hud's "Alt" keybinding then Alt+print will no longer work, but that's not this bug.

Roman Yepishev (rye) wrote :

In my case the screenshot is taken only when the Alt is released. At that point hud opens, focusing on itself, screenshot is taken of the whole screen.

Omer Akram (om26er) wrote :

the remaining issue is bug 937036

Changed in unity:
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in unity:
milestone: 5.6.0 → none
Jani Uusitalo (uusijani) wrote :

I linked Unity 2D where this problem still remains. As a workaround, Shift+PrtScrn can be used to approximately select the desired window area to grab.

Gerry Boland (gerboland) on 2012-03-20
Changed in unity-2d:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments