clicking on folders in the file lens does not open nautilus

Reported by Nekhelesh Ramananthan on 2012-01-25
66
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Unity
High
Michal Hruby
Unity Distro Priority
High
Unassigned
unity-lens-files
High
Michal Hruby
unity (Ubuntu)
High
Unassigned
unity-lens-files (Ubuntu)
Undecided
Unassigned

Bug Description

I am running Ubuntu 12.04 Precise LTS daily build with Unity 5.0. When I click on any of the folders in the files lens in the dash, it does open the folder in nautilus. It simply hides the dash and nothing else happens. I have attached a video to show what is happening.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.0.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-10.18-generic-pae 3.2.1
Uname: Linux 3.2.0-10-generic-pae i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,vpswitch,regex,imgpng,place,gnomecompat,grid,mousepoll,snap,move,resize,wall,session,animation,expo,workarounds,fade,ezoom,scale,unityshell]
Date: Wed Jan 25 17:28:23 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120116.2)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-01-25 (0 days ago)

Nekhelesh Ramananthan (nik90) wrote :
Nekhelesh Ramananthan (nik90) wrote :

Video showing the bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2012-02-02
Changed in unity:
status: New → Confirmed
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → High
Michal Hruby (mhr3) on 2012-02-02
Changed in unity-lens-files:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Michal Hruby (mhr3)
milestone: none → 5.4
Changed in unity-lens-files (Ubuntu):
status: New → Confirmed
Nekhelesh Ramananthan (nik90) wrote :

This bug is still present in Unity 5.2 Precise.

Paul White (paulw2u) wrote :

I'm seeing something slightly different here.

If a folder contains other folders but no files then nothing happens.

Nautilus only opens for me when a folder contains just files or a mixture of files and folders.

Sam_ (and-sam) wrote :

Can't confirm #6
Instead:
Dash doesn't open the first positioned folder when it incl. folders and files.
Dash displays on search two of the same, it doesn't open the first positioned, it opens the second.
Dash opens a created folder 'test' on first position which incl. only folders test-1 and test-2.
Dash doesn't find a folder (which was opened before in nautilus) when it isn't bookmarked in nautilus.
The folder is named 'Sicherungen', when searching 'sich' it finds 'testbackup' instead.
Dash displays same folders twice or certain ones never when filter is 'all'.

ii unity 5.2.0-0ubuntu2

Sam_ (and-sam) wrote :

Obviously depends on time of installation. #7 was installed four days ago on desktop-pc.
This one here on laptop was an alpha-1 installation and none of tested folders open. Also created 'test' folder incl. empty test-1 and test-2 folders, in contrary of #7 dash doesn't localize them.

Michal Hruby (mhr3) on 2012-02-17
Changed in unity-lens-files:
milestone: 5.4.0 → 5.6.0
Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
Michal Hruby (mhr3) on 2012-02-20
Changed in unity:
assignee: nobody → Michal Hruby (mhr3)
Michal Hruby (mhr3) on 2012-03-05
Changed in unity:
milestone: none → 5.8.0
Changed in unity-lens-files:
milestone: 5.6.0 → 5.8.0
Michal Hruby (mhr3) on 2012-03-05
Changed in unity-lens-files:
status: Triaged → In Progress
Changed in unity:
status: Confirmed → In Progress
Loris Zinsou (the-lz-himself) wrote :

I experience the same bug, except I can see two "Téléchargement" ("Downloads") folders.

The first one in the list is working as expected (it opens Nautilus), but the second one does nothing but close the dash.

I haven't re-installed Unity or reset Zeitgeist since I upgraded from Ubuntu 11.10, with alpha 1.

Omer Akram (om26er) on 2012-03-09
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity-lens-files (Ubuntu):
status: Confirmed → In Progress
Changed in unity-lens-files:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-13
Changed in unity:
milestone: 5.8.0 → none
milestone: none → 5.8.0
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-files:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.8.0-0ubuntu1

---------------
unity (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - New "push mouse offscreen" feature really difficult to get (LP: #923749)
    - unity-2d-panel crashed with SIGSEGV in
      unity::indicator::DBusIndicators::Impl::RequestSyncAll() (LP: #864737)
    - Pressing "Alt+Enter" causes compiz to crash in CompOption::value() from
      unity::UnityScreen::showLauncherKeyTerminate (LP: #960957)
    - SEGSIGV after unplugging external monitor (LP: #962693)
    - Background colorization should use a different heuristic (LP: #865239)
    - compiz+unity3d generates > 50 wakeups a second on idle system
      (LP: #917210)
    - [FFe, UIFe] HUD - The HUD does not respect launcher autohide or icon
      size settings (LP: #921506)
    - clicking on folders in the file lens does not open nautilus
      (LP: #921665)
    - No text inside multirange filters (LP: #927710)
    - can't alt-tab restore minimized uis which have an instance on another
      workspace (LP: #933397)
    - Ubuntu Software Center Unity launcher integration is not working
      (LP: #932280)
    - The line separator between the launcher and the dash is cleared when
      selecting a category (LP: #941082)
    - unity-panel-service crashed with SIGSEGV in g_hash_table_foreach()
      (LP: #937119)
    - Alt-F10 locks up Unity (LP: #948522)
    - multimonitor, launcher: Provide an option to display either a single
      launcher or a launcher on each display in a multi-monitor environment
      (LP: #950136)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - Unity 5.6: key bindings (such as Super) don't work on empty workspace or
      on slow/loaded systems (LP: #953089)
    - Alt+arrows keyboard shortcuts don't invoke Back and Forward navigation
      (LP: #953783)
    - HUD is sending 2 menu signals instead of 1 (LP: #956878)
    - 6th item of HUD not fully visible (LP: #957229)
    - HUD: seems to trigger operations more than once (LP: #960503)
    - Launcher gets always desaturated when using HUD on secondary monitor
      (LP: #961169)
    - [5.8 pre staging] launcher is displayed on the left screen, not the
      primary one (LP: #961281)
    - launcher icons do not re-saturate after dash is closed (LP: #961844)
    - Launcher shows arrows for applications on all workspaces (LP: #961977)
    - Dash - Implement overlay scrollbars in Dash (LP: #608124)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - Dash - Missing category separator line in dash (LP: #850984)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - When multiple results have equal string match relevancy ranking,
      those with equal ranking should be then sorted by frequency of use.
      (LP: #871900)
    - Keyboard shortcut - F10 shortcut is used to show m...

Read more...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-files - 5.8.0-0ubuntu1

---------------
unity-lens-files (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - clicking on folders in the file lens does not open nautilus
      (LP: #921665)
    - Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Privacy Delete history is not deleting download history (LP: #947856)
    - Locate scope doesn't respect privacy settings (LP: #955229)
    - \\192.168.1.x opens http:\\192.168.1.x in firefox as opposed to
      smb://192.168.1.x in nautilus (LP: #773841)
    - Web url regexp matches non url (LP: #948086)
  * debian/control:
    - build-dep on newer zeitgeist
 -- Didier Roche <email address hidden> Fri, 23 Mar 2012 15:05:24 +0100

Changed in unity-lens-files (Ubuntu):
status: In Progress → Fix Released
Didier Roche (didrocks) on 2012-04-17
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers