HUD - Using HUD often results in window losing focus

Reported by Seth Forshee on 2012-01-24
58
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Gord Allott
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Often after doing some action with HUD I'm finding that my window has lost focus. Examples:

Example #1 (any application)
 * Press Alt to reveal HUD
 * Press Alt again to dismuss HUD
 * Window no longer has focus

Example #2 (nautilus)
 * Pres Alt to reveal HUD
 * Type "new" and use keyboard to select "File > Create New Folder"
 * Nautilus window no longer has focus

Related branches

lp:~gordallott/unity/hud
Merged into lp:unity at revision 1900
Gord Allott (community): Approve on 2012-02-06
John Lea: Approve (design review) on 2012-02-03
Andrea Azzarone: Needs Fixing on 2012-01-27
Mirco Müller: Needs Fixing on 2012-01-27
Thomi Richards: Needs Fixing on 2012-01-25
Marco Biscaro (community): Needs Fixing on 2012-01-25
Seth Forshee (sforshee) on 2012-01-24
tags: added: hud
Changed in unity:
status: New → Confirmed
Gord Allott (gordallott) on 2012-01-26
Changed in unity:
assignee: nobody → Gord Allott (gordallott)
Omer Akram (om26er) on 2012-01-27
Changed in unity:
importance: Undecided → High
status: Confirmed → In Progress
milestone: none → 5.2.0
Didier Roche (didrocks) on 2012-02-01
Changed in unity (Ubuntu):
status: New → In Progress
Didier Roche (didrocks) on 2012-02-03
Changed in unity:
milestone: 5.2.0 → 5.4.0
Gord Allott (gordallott) on 2012-02-07
Changed in unity:
status: In Progress → Fix Committed
Gord Allott (gordallott) on 2012-02-07
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-02-17
Changed in unity:
status: Fix Committed → Fix Released
Oren_B (oren.barnea) wrote :

The fix in Unity 5.4.0 seems to fix only the first problem Seth showed. Creating a new directory using HUD still makes Nautilus lose focus. Same happens to me when I change profiles in gnome-terminal.

Didier Roche (didrocks) on 2012-02-20
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Seth Forshee (sforshee) wrote :

I agree, this isn't fully fixed. I have 5.4.0-0ubuntu1 installed, and I can still trigger the problem in a number of different ways. As noted, example #2 in the description still results in a loss of focus. When using gvim if I use HUD to select the Edit->Paste menu option, my window no longer has focus afterwards. In fact using HUD at all with gvim results in a loss of focus. Things have improved, but problems remain, so I'm reopening the bug.

Changed in unity:
status: Fix Released → Confirmed
John Lea (johnlea) on 2012-02-23
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
tags: added: udp
summary: - HUD: Using HUD often results in window losing focus
+ HUD - Using HUD often results in window losing focus
Oren_B (oren.barnea) wrote :

Seems to be fully fixed in Unity 5.6.0 (tested on Unity-2D).
Thanks, devs!

Omer Akram (om26er) on 2012-03-11
Changed in unity:
status: Confirmed → Fix Released
Tim Penhey (thumper) on 2012-04-22
Changed in ayatana-design:
status: Triaged → Fix Committed
Nick Tait (jnick-tait) on 2012-04-26
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udp

A similar issue pops up in GIMP when I use the HUD to apply any filters; this results in the main GIMP window losing focus and the window listing layers gaining focus instead, leading to the HUD/global menu remaining empty until the main GIMP window is clicked on again. Would that be this bug, or is there a separate bug filed for it?

Sebastien Bacher (seb128) wrote :

@Christopher: the gimp issue you describe is a different one, it happens without the hud, see bug #980159

Branimir Kolar (branimir101) wrote :

I'm on 12.04 and this issue happens randomly with unity 5.14.0-0ubuntu1 installed. Is it possible to fix this and stay on 12.04 LTS ?

Edward Donovan (edward.donovan) wrote :

Branimir - I have been having this problem all along through Quantal. I'm not sure if we should open a new report, or not. But I think the situation looks the same on 12.04 and 12.10, at any rate. Thanks.

dimovnike (dimovnike) wrote :

i am on precise now and issue still randomly happens. but its hard to reproduce, because it happens really random. (Also not always all items show in the HUD but this is another story)

Vincent (vinnl) wrote :

Since I cannot re-open this issue, I've opened a new one: bug 1102395

If someone can re-open this one, the other one can be marked as duplicate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers