Launcher, Dash - Showing dash, via super key, with a quicklist shown doesn't work

Bug #913994 reported by Andrew Hayzen on 2012-01-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Fix Released
Medium
Brandon Schaefer
unity (Ubuntu)
Medium
Unassigned

Bug Description

Hi

Description: Ubuntu 11.10
Release: 11.10
unity:
  Installed: 4.24.0-0ubuntu2.1
  Candidate: 4.24.0-0ubuntu2.1
  Version table:
 *** 4.24.0-0ubuntu2.1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     4.22.0-0ubuntu3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages

What happened:
When a quicklist is open the dash cannot be displayed using the super key. Also the dash appears when the quicklist has lost its focus causing confusion to the user.

Steps to reproduce:
1) Right click on a launcher item to show the quicklist
2) Press the 'super' key to reveal the dash - Note that the dash is not shown
3) Click on the desktop (or anywhere to make the quicklist loose focus) - Note that the dash is now displayed

What should have happened:
- At step 2 the dash should have been displayed, and the quicklist closed

Hope this bug can be fixed.

Andy

--------------------------------------------
Note from design:

Thanks for the great bug description, this is a valid issue and has been approved for resolution.

Related branches

Bilal Akhtar (bilalakhtar) wrote :

This needs design discussion, on whether the dash should open at step 2 or not open at all after step 3 (I prefer the latter, but you prefer the former)

tags: added: needs-design
Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
John Lea (johnlea) on 2012-01-10
tags: added: udp
removed: needs-design
description: updated
Changed in unity:
milestone: none → backlog
status: Incomplete → Confirmed
Changed in ayatana-design:
status: New → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
summary: - Showing dash, via super key, with a quicklist shown doesn't work
+ Launcher, Dash - Showing dash, via super key, with a quicklist shown
+ doesn't work
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
Andrew Hayzen (ahayzen) wrote :

Hi

As a note. I thought that the dash should open at step 2 to keep unity consistent.

This is because of the following example:
1) Open dash
2) Open a quicklist of an item in the launcher (right-click on item in launcher) - note that the dash remains
3) Press the super key - note that the dash is hidden and the quicklist remains

So if the user is has the dash open and a quicklist open, they can hide the dash by pressing the super key.
However because of this bug they cannot 'undo' their change to show the dash by pressing the super key.

This makes the behaviour feel inconsistent and is the reason I think the dash should open at step 2.

Hope that helps

Andy

Logan Rosen (logan) wrote :

I don't think that this bug occurs anymore. The dash doesn't display at all after clicking off the quicklist. Can you confirm this, Andy?

Andrew Hayzen (ahayzen) wrote :

Hi Logan

On my 11.10 machine the bug is still present, but I haven't updated recently due to another bug.

Description: Ubuntu 11.10
Release: 11.10
unity:
  Installed: 4.28.0-0ubuntu2
  Candidate: 4.28.0-0ubuntu2
  Version table:
 *** 4.28.0-0ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     4.22.0-0ubuntu3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages

Also via a Virtual Machine on 12.04 the bug is still present, but again i haven't updated recently due to bandwidth limitations - but hopefully will be switching to beta 2 soon.

Description: Ubuntu precise (development branch)
Release: 12.04
unity:
  Installed: 5.6.0-0ubuntu3
  Candidate: 5.8.0-0ubuntu2
  Version table:
     5.8.0-0ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
 *** 5.6.0-0ubuntu3 0
        100 /var/lib/dpkg/status

Once I get 12.04 beta 2 I will test for this bug again. The steps i'm using to produce the bug is in the first comment.

Logan, what version of unity are you using as this may be my issue (run apt-cache policy unity)?

Many thanks,

Andy

Andrew Hayzen (ahayzen) wrote :

Hi

Just updated the VM to 12.04 beta 2

Description: Ubuntu precise (development branch)
Release: 12.04
unity:
  Installed: 5.8.0-0ubuntu2
  Candidate: 5.8.0-0ubuntu2
  Version table:
 *** 5.8.0-0ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

I have tested this bug in the virtual machine and it doesn't seem to occur any more. What now happens is that the dash doesn't open after step 3, so it is now acting as expected.

Could someone else please confirm outside of a virtual machine to make sure that the bug is fixed and feel free to mark this bug as fixed after doing so.

Many thanks for your work guys.

Andy

Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
John Lea (johnlea) on 2012-04-26
Changed in ayatana-design:
importance: Undecided → Low
importance: Low → Medium
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
status: Triaged → In Progress
Changed in unity:
milestone: backlog → 6.2
status: In Progress → Fix Committed
John Lea (johnlea) on 2012-08-09
Changed in unity:
importance: Low → Medium
Changed in unity (Ubuntu):
importance: Low → Medium
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package unity - 6.2.0-0ubuntu1

---------------
unity (6.2.0-0ubuntu1) quantal-proposed; urgency=low

  [ Adam Conrad ]
  * Removed debian/patches/libgeis-rename.patch

  [ Łukasz 'sil2100' Zemczak ]
  * debian/rules:
    - added override for dh_shlibdeps to point it to the private directory of
      libunity-protocol-private.so
  * debian/unity.lintian-overrides,
    debian/libunity-core-6.0-5.lintian-overrides:
    - added override to silence the binary-or-shlib-defines-rpath error, since
      we are forced to use RPATH in our case

  [ Didier Roche ]
  * New upstream release.
    - [nvidia] compiz crashed with SIGSEGV in
      nux::GraphicsEngine::QRP_GLSL_Color() from
      nux::GraphicsEngine::QRP_Color() from nux::BasePainter::PaintBackground
      (LP: #982626)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold. (LP: #839717)
    - running applications without an icon use a blank icon (LP: #886778)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - still some accent issues with unity/nux (LP: #950740)
    - Launcher doesn't autoscroll when holding an icon (can't reach trash)
      (LP: #987223)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - [GLES] framebuffer output scaled incorrect in both blur and items above
      shell with multimonitor (LP: #1016789)
    - [regression] [unity 6.0] Fullscreen windows flicker and/or never redraw
      properly if panel_opacity<1.0 or dash is opened. (LP: #1024911)
    - panel and launcher blinks when using libreoffice presenter/spreadsheet
      (LP: #1024459)
    - compiz crashed with SIGSEGV in
      unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
      (LP: #1020075)
    - Update to 1.6.4 (LP: #1014850)
    - [nvidia] unity crashed in nux::GraphicsEngine::QRP_GLSL_1Tex
      (glDrawArrays) (LP: #1031554)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - Launcher, Dash - Showing dash, via super key, with a quicklist shown
      doesn't work (LP: #913994)
    - REGRESSION: can't type characters with accent (dead keys) (LP: #961741)
    - Launcher wrongly shows top tooltip when peforming the accordion effect
      (LP: #980942)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - logging out/in with mounted drives causes unity launcher icons to be
      duplicated (LP: #1010714)
    - Mounted volume icons doubled up in launcher (LP: #1010858)
    - Launcher - when a user starts dragging a item, the launcher icons that
      are *not* valid drop receptacles should be tinted (LP: #1020891)
    - Alt+F4 does not close the hud when Numlock or Capslock are on.
      (LP: #1022801)
    - Unity shortcut overlay needs to include shortcut for video lens
      (LP: #937334)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - give a way to remove 'Show Desktop' from the Alt-Tab items
      (LP: #1014346)
    - Multi...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignq
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers