Launcher - launcher should have blurred background all the time

Reported by Omer Akram on 2011-11-17
106
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

When the dash is open the launcher and the panel also gain blurred backgrounds but when the dash is closed revealing the launcher from the left edge shows launcher with no blur it can be less attractive in some cases and also reduces the visibility on the BFB with certain desktop wallpapers.

in the attached screenshot the launcher is transparent+the desktop wallpaper gradient, blur would look nice.

-------------------------------
Desired solution:

- All computers which have good video acceleration should have an active blur behind the Launcher at all times.

- The active blur should not be applied when the computer has very poor video acceleration.

Omer Akram (om26er) wrote :
John Lea (johnlea) on 2011-11-17
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
Omer Akram (om26er) on 2011-11-17
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: Triaged → Confirmed
Tim Penhey (thumper) on 2011-11-22
Changed in ayatana-design:
status: Triaged → Fix Committed
Andrea Cimitan (cimi) on 2011-12-13
tags: added: unity3p
Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: High → Critical
Omer Akram (om26er) on 2012-03-23
Changed in unity:
milestone: none → backlog
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Changed in unity (Ubuntu):
assignee: nobody → Jason Smith (jassmith)
Andrea Cimitan (cimi) on 2012-05-02
tags: added: euv
aquahawk (shane71717) on 2012-05-15
Changed in ayatana-design:
status: Fix Committed → Fix Released
Amaeth (dfoxpro) wrote :

At this point is curious how another windows can gain blur like conky but the unity launcher is no way to add a blur effect.
In the attachment i show how conky show blur with Compiz and the "Blur window" feature enable.

shane (shane-animail) wrote :

It says fix released in ayatana-design. What does this mean exactly?
Does it mean this WILL be implemented in Unity and if so, when would such a fix trickle into an actual ubuntu release?

John Lea (johnlea) wrote :

@shane-animail; "fix released" in ayatana-design means that the change has been approved and it is now waiting for someone to pickup and fix. When it gets fixed really depends on how soon somebody volunteers to fix it, so if you are be interested in looking into this bug and submitting a patch it would be much appreciated. Contact jcastro on #ubuntu-desktop (Freenode IRC) if you need any pointers or advice on how to get started with contributing to Ubuntu.

Changed in ayatana-design:
status: Fix Released → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Warning:

Unity's active blur is _very_ slow. This change may impact desktop performance significantly.

John Lea (johnlea) wrote :

@vanvugt; can we then automatically detect systems with good video acceleration, and only apply the active blur on these systems? I have updated the bug description.

description: updated
description: updated
Omer Akram (om26er) wrote :

We should actually fix unity to do a faster less resource hungry blur. We can do better.

John Lea (johnlea) wrote :

@om26er; we definitely should, but "make the unity blur faster and less resource hungry" should be another bug, and shouldn't block this bug from being resolved.

Daniel van Vugt (vanvugt) wrote :

John,

Automatic detection is not relevant here. Unity's active blur is very slow even on fast graphics hardware. It's a software problem with Unity/Nux AFAIK.

We really don't have an excuse when you see Windows 7 do fast active blurs even on low-end systems. But yes, that's a different bug (which I can't find logged yet). It's worth mentioning here, though.

On the other hand, the active blur only consumes resources when something behind it changes. For regular desktop usage this should be zero. However if you have active blur on your panel and toggle the workspace switcher (Super+S) for example, then you see significant slow-down in the expo view.

John Lea (johnlea) wrote :

@vanvugt; so if the Launcher is locked out, having active blur behind the Launcher switched on only has a negligible performance impact? (because no window are behind the Launcher, only the background, and this does not change)?

What about the case when the Launcher is set to auto-hide? Is there a way to do static blur behind the Launcher in this case, because the launcher is shown only temporally, and the likelihood so items changing behind the Launcher while it is temporally revealed is low??

(I'm looking for a way to make this possible)

Daniel van Vugt (vanvugt) wrote :

I'm not sure if a blurred launcher will produce bugs with autohide. I haven't tried it.

I can tell you for sure that a blurred launcher will make expo painfully slow for many people. In theory, we could solve half of that problem by using more efficient damage logic in the expo plugin. However that would not solve the problem of a blurred launcher causing expo entry/exit to be very slow and stuttery. That would only be solved by addressing the active blur's performance in Unity/Nux.

John Lea (johnlea) on 2012-10-09
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
Changed in unity (Ubuntu):
assignee: Jason Smith (jassmith) → nobody
John Lea (johnlea) on 2012-10-10
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in ayatana-design:
importance: Critical → High
John Lea (johnlea) wrote :

Now that nic-doffay fast blur has landed, perhaps we can have another go at implementing this in 13.10?

Stephen M. Webb (bregma) on 2013-04-25
Changed in unity:
milestone: backlog → 7.1.0
Stephen M. Webb (bregma) on 2013-07-26
Changed in unity:
milestone: 7.1.0 → 7.1.1
Stephen M. Webb (bregma) on 2013-10-04
Changed in unity:
importance: High → Medium
milestone: 7.1.1 → 7.2.0
Changed in unity (Ubuntu):
importance: High → Medium
Stephen M. Webb (bregma) on 2014-04-15
Changed in unity:
milestone: 7.2.0 → 7.2.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints