Alt+Tab default delay of 150ms is too long

Reported by Chow Loong Jin on 2011-11-10
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Medium
Jason Smith
unity (Ubuntu)
Medium
Jason Smith

Bug Description

  affects unity
  affects hundredpapercuts
  affects ubuntu/unity

The Alt+Tab timeout is set to 150ms, which leads to a general impression of
slowness/lagginess, as the switcher does not appear immediately.

I'm assuming that this was done so that the user may switch between two
applications quickly without bringing the launcher up by tapping Alt+Tab and
releasing before the 150ms is up, so I'm attaching a patch that lowers this to
50ms, which appears to be a good compromise for me, from my testing.

Personally, I've found in my own daily use that when switching to the next
application, I prefer to know what I'm switching to before letting go of Alt,
which makes the current behaviour very annoying. So annoying that I've almost
exclusively switched to task-switching with the ring switcher and scale switcher.

Here's an external link regarding the issue:
http://askubuntu.com/questions/43875/how-do-i-adjust-the-alt-tab-speed

Some quick googling for "alt tab delay" also reveals that many Windows users are
complaining about the Alt+Tab delay/slowness in Windows.

--
Kind regards,
Loong Jin

Related branches

lp:~jassmith/unity/unity.alt-tab-timings
Merged into lp:unity at revision 2020
David Barth: Approve on 2012-02-22
Jason Smith (community): Needs Fixing on 2012-02-22
Chow Loong Jin (hyperair) wrote :

The attachment "0001-Lower-switcher-timeout-to-50ms.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Chris Wilson (notgary) on 2011-11-12
Changed in hundredpapercuts:
status: New → Opinion
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-11-22
Changed in unity:
status: New → Confirmed
Omer Akram (om26er) on 2011-12-02
affects: hundredpapercuts → ayatana-design
Changed in ayatana-design:
status: Opinion → New
Omer Akram (om26er) wrote :

this needs design input before being set as confirmed.

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Chow Loong Jin (hyperair) wrote :

I don't think that this is the same bug as bug #838232. If I'm reading that bug correctly, bug #838232 is about reducing the delay for which the Alt+Tab switcher turns into the Alt+Grave switcher. However, this bug is about reducing the delay for the Alt+Tab switcher appearing at all.

Chow Loong Jin (hyperair) wrote :

Here's a patch that makes the delay configurable instead of hardcoding it to 50ms.

John Lea (johnlea) on 2011-12-12
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
status: New → Triaged
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
tags: added: udp
Tim Penhey (thumper) on 2012-02-08
Changed in ayatana-design:
status: Triaged → In Progress
status: In Progress → Fix Committed
Changed in unity:
status: Confirmed → Triaged
importance: Undecided → Low
Tim Penhey (thumper) on 2012-02-08
Changed in unity:
milestone: none → backlog
Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: Low → Critical
Omer Akram (om26er) on 2012-02-22
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
importance: Low → Medium
status: Triaged → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Jason Smith (jassmith)
status: Confirmed → In Progress
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
milestone: backlog → 5.6.0
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Omer Akram (om26er) wrote :

its not merged yet why fix committed?

Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Nick Tait (jnick-tait) on 2012-03-13
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers