Window title bars are un-clickable

Bug #880449 reported by Harry on 2011-10-23
92
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Łukasz Zemczak
unity (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

TESTCASE:
1. Open a window and minimize it.
2. Show desktop; Ctrl+Alt+D in Ubuntu 11.10, Ctrl+Super+D in 12.04. Or Alt-Tab to the desktop.
3. Show desktop again.
4. Unminimize the window. Its title bar now can't be clicked.

ORIGINAL DESCRIPTION:
windows A and B are open (but not maximized), and windows C and D are minimized. If I hit ctrl+alt+D to show the desktop (which minimizes A and B), then when I open windows C and D, the title bars are unclickable. Note, in this case, the title bars of windows A and B are not affected. Hitting ctrl+alt+D only affects the title bars of windows that were minimized when ctrl+alt+D was hit.

If I then open all windows and hit ctrl+alt+D to close them, then the title bars of all windows go back to normal (i.e., they are all clickable again).

Please see the screencast (do note that I have menubars because of another bug; however, it does help demonstrate that only the titlebars are not receiving clicks.

https://bugs.launchpad.net/compiz-core/+bug/880449/+attachment/3087289/+files/bug.ogv

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,wall,vpswitch,resize,gnomecompat,place,regex,compiztoolbox,resizeinfo,imgpng,move,session,snap,grid,animation,workarounds,fade,expo,unitymtgrabhandles,scale,ezoom,unityshell]
CompositorRunning: compiz
Date: Sun Oct 23 12:50:12 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus: virtualbox, 4.1.2, 3.0.0-12-generic-pae, i686: installed
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0112] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASRock Incorporation Device [1849:0112]
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic-pae root=UUID=488f3a84-6094-4dad-a6ab-d85c65610aed ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/21/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.10
dmi.board.name: H67M-ITX
dmi.board.vendor: ASRock
dmi.chassis.type: 3
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.10:bd02/21/2011:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnH67M-ITX:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu5
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

Harry (harry81b) wrote :
Dmitry Shachnev (mitya57) wrote :

It's bug in compiz, not in xorg.

affects: xorg (Ubuntu) → compiz (Ubuntu)
description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. Compiz, in particular, is in heavy development and this bug may have been fixed in the development version of Ubuntu (12.04) if not on the current 11.10 release. If you are able, it would be of great help if you could confirm if the bug still exists by testing a livecd (available at http://cdimage.ubuntu.com/daily-live/current/). When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue. Please keep in mind that the development version (12.04) is not suitable for daily use - please only use it for testing purposes.

Thank you for your help and patience.

Changed in compiz (Ubuntu):
status: New → Incomplete
Anthony (abastardi) wrote :

I'm using Ubuntu 12.04 Beta 2 and observing nearly the same behavior. Let's say windows A and B are open (but not maximized), and windows C and D are minimized. If I hit ctrl+alt+D to show the desktop (which minimizes A and B), then when I open windows C and D, they will both display the problem mentioned above (i.e., the title bars are unclickable). Note, in this case, the title bars of windows A and B are not affected. Hitting ctrl+alt+D only affects the title bars of windows that were minimized when ctrl+alt+D was hit.

If I then open all windows and hit ctrl+alt+D to close them, then the title bars of all windows go back to normal (i.e., they are all clickable again).

I can confirm this behavior as well.

summary: - Problem with titlebar
+ Triggering Show Desktop with both minimized and restored windows will
+ prevent ability to drag titlebars upon restoring.
description: updated
Changed in compiz (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Low
Changed in compiz-core:
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

I'm working on a similar bug fix right now (bug 981703). Hopefully it will fix this too.

summary: - Triggering Show Desktop with both minimized and restored windows will
- prevent ability to drag titlebars upon restoring.
+ Window title bars are un-clickable
Changed in compiz-core:
importance: Undecided → High
Changed in compiz (Ubuntu):
importance: Low → High
Changed in compiz-core:
assignee: nobody → Daniel van Vugt (vanvugt)
description: updated
Daniel van Vugt (vanvugt) wrote :

Hmm no, this bug seems quite different to bug 981703. Also, this bug only seems to occur with Unity (4 & 5, 11.10 & 12.04). I can't reproduce this bug with upstream compiz-core or in Gnome Classic (with compiz). Only in Unity 3D.

Changed in compiz-core:
assignee: Daniel van Vugt (vanvugt) → nobody
status: Confirmed → Triaged
Changed in unity:
status: New → Triaged
importance: Undecided → High
milestone: none → 5.12.0
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in compiz-core:
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in unity:
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in compiz-core:
milestone: none → 0.9.8.0
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
Changed in compiz (Ubuntu):
status: Triaged → Invalid
Daniel van Vugt (vanvugt) wrote :

Fix committed where?

Changed in unity:
status: Fix Committed → Triaged
Changed in unity (Ubuntu):
status: Fix Committed → Triaged
Changed in unity:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Omer Akram (om26er) on 2012-04-26
Changed in unity (Ubuntu Precise):
status: Fix Committed → Confirmed
2green (zendhetmij) wrote :

Duplicate bug 986294 is not fixed with this solution.

just retested it with latest updates.

Changed in unity (Ubuntu Precise):
status: Confirmed → Incomplete
2green (zendhetmij) wrote :

* Pre condition
There are no running applications

* user story
Select 'system settings' from the sidebar
Minimize the window using the minimize button
Press ctrl+alt+D
Press ctrl+alt+D again
Select 'system settings' from the sidebar
Minimize the window using the minimize button

* Expected behavior
The 'system settings' window is minimized

* Current behavior
The 'system settings' window is NOT minimized (button are disabled)

* Extra information
This problem occurs with any windowed application.

robi1h (robi1h) wrote :

Installed the finale version of Ubuntu 12.04 and after I started using Show desktop (I'v enabled the icon crom compiz setting) this bug started to happen (the title bar is unclickabel). the only way that I get the functionality back is when I use show desktop again and again but then an other indows title bar is unclickable

Didier Roche (didrocks) on 2012-04-27
Changed in unity:
status: Fix Committed → Fix Released
2green (zendhetmij) wrote :

Retest: NOK

Still te same problem.

Select 'system settings' from the sidebar
Minimize the window using the minimize button
Press ctrl+alt+D
Press ctrl+alt+D again
Select 'system settings' from the sidebar
Minimize the window using the minimize button

* Expected behavior
The 'system settings' window is minimized

* Current behavior
The 'system settings' window is NOT minimized (button are disabled)

2green (zendhetmij) wrote :

Forgot to mention the test was with latest updates just before this report.

eden6000 (eden6000) wrote :

2green did you enable "proposed updates" in the software update tool? Because this bug is fixed in unity 5.12 and if you don't enable that you're stuck with 5.10 until 5.12 goes pushed to the regular updates... btw for me the bug is fixed...

2green (zendhetmij) wrote :

@eden6000

Thanks, but I had ¨proposed updates¨ enabled. But I just retested it, this time both my development machines are fine.

Bug solved.

2green (zendhetmij) on 2012-05-03
Changed in unity (Ubuntu):
status: Incomplete → Fix Released
Changed in unity (Ubuntu Precise):
status: Incomplete → Fix Released
N Oliver (n-n) wrote :

Confirmed fixed on my box using the proposed updates channel.

(For the less-tech savvy:)
Update Manager:
Settings (bottom left) -> Update -> Pre-released updates (precise-proposed)

Terminal:
apt-get update
apt-get install compiz-core
apt-get install compiz

(Steps could be changed a bit, but are my exact steps just in case a condensing changes the outcome)

Note: Installing the updates via Update Manager yielded an error of an untrusted source, despite whatever selection I made in the Settings window.

Amir Eldor (amireldor) wrote :

This is a funny one :) I didn't know what was going on or how to reproduce it... it's good that someone found how to do that.

no longer affects: compiz-core
no longer affects: compiz-core/0.9.7
no longer affects: compiz-core/0.9.8
no longer affects: compiz (Ubuntu)
no longer affects: compiz (Ubuntu Precise)
mmxbass (mmxbass) wrote :

This is broken again in Raring.

2green (zendhetmij) wrote :

Had the same problem, just retested this one using the above steps, is now fixed in 13.04.

Thanks!

stretch (stretch-) wrote :

Same problem happens to me also it raise the window below the front opened one
i have to highlight the front window first so i can change the size or click it's contents

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions