Keyboard shortcut - F10 shortcut is used to show menu and this is wrong

Reported by Alexander Kabakow on 2011-10-19
438
This bug affects 214 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Marco Trevisan (Treviño)
Unity Distro Priority
Low
Unassigned
unity-2d
High
Unassigned
gtk+2.0 (Ubuntu)
High
Unassigned
gtk+3.0 (Ubuntu)
High
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
High
Didier Roche

Bug Description

Unity 2d uses F10 shotcut to show menu,
but many applications use this key too

a lot of IDE's bind to F10 debug function "Step over"... FireFox Firebug and Google Chrome debugger does it
text editor Kate use F10 to toogle word wraping
I think there are more app uses it

May be unity2d should use different shotcut for mainmenu?

-------------------------------------------
Desired resolution:

- The "F10" shortcut should be changed to "Alt + F10". No "F" keys should ever be used for shell shortcuts without an additional modifier key. This change brings the shortcut into line with the "Alt +F1" Launcher keyboard navigation shortcut.

- The menu key should perform the same function as Alt + F10 (display menus). A nice to have gold plating feature would be to detect if a menu key is present on the keyboard, and if it is display the 'menu' key shortcut in the shortcuts overlay in place of "Alt + F10"

- The "Alt + F5" becomes a toggle, shifting the window between restored and maximised states (replacing the previous windox maximise Alt + F10 shortcut)

Alexander Kabakow (alexzak) wrote :
Colin Watson (cjwatson) wrote :

I was affected by this too. I've been using F10 for something like a decade as a custom keybinding to switch vim into paste mode; while no doubt I could change this, it's disorienting and breaks my finger macros.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Thomas Thurman (marnanel) wrote :

Definitely. At the least it shouldn't be hardcoded.

Changed in unity-2d (Ubuntu):
assignee: nobody → Thomas Thurman (marnanel)
Colin Watson (cjwatson) wrote :

Actually, I don't mind what the default is. What I do mind is that this is hardcoded in the unity-2d source and isn't configurable. If I could change this in gsettings then it would meet my needs.

tags: added: in-progress
summary: - Unity 2d uses F10 shotcut to show menu and this is wrong
+ Unity 2d uses F10 shortcut to show menu and this is wrong

Are there actually *any* hotkeys in unity-2d which *aren't* hard-coded? I could easily adapt it to use the same system as the other keys, but there doesn't seem to be one. And adding a whole new hotkey system in a patch without checking with the maintainers seems like overkill. I could also just use a plain DConf setting for the keystroke, but I can't find an accessor in Qt to turn a string representing a keystroke into the Qt::Key and modifier used for that keystroke.

Francesco Strappini (fstraps) wrote :

This is a very annoying bug...

Gerry Boland (gerboland) wrote :

Understood. We need to see how Unity is doing this. Hopefully they're using a better solution that we can emulate.

Changed in unity-2d:
status: New → Confirmed
importance: Undecided → High
Aritchie (aritchie) wrote :

I am running Unity on my Dell desktop system and it also uses F10.

mmxbass (mmxbass) wrote :

This is unbelievably inconvenient and IMO shows the dire lack of use testing put into unity2d. This is a showstopper IMO and unity2d should NEVER have been released in this state. The fact it STILL hasn't been fixed after over two weeks shows just how little importance the Ubuntu project places on unity2d and its users.

Lohith D Shivamurthy (dyams) wrote :

Unity is using the same key too.

Avol (avol) wrote :

This is really a very bad thing

mmxbass (mmxbass) wrote :

...and we're now at six weeks for what should have been resolved in under a day. As I've said, it's pretty clear at this point how much the Ubuntu project values unity 2d and those who use it.

John Lea (johnlea) wrote :

Note the history of why F10 was chosen is tracked in the following bug report https://bugs.launchpad.net/unity/+bug/701663 .

description: updated
summary: - Unity 2d uses F10 shortcut to show menu and this is wrong
+ Keyboard shotcut - F10 shortcut is used to show menu and this is wrong
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
milestone: none → backlog
tags: added: udp

@mmxbass; relax! We have many many bugs coming in and it takes time to review them all, currently we have a backlog we are trying to work through. We read every single bug that is posted to ayatana-design, sometimes it just takes a while for the bug to reach the top of the in box queue.

John Lea (johnlea) on 2011-12-12
tags: added: keybinding
John Lea (johnlea) on 2011-12-13
description: updated
John Lea (johnlea) on 2011-12-16
summary: - Keyboard shotcut - F10 shortcut is used to show menu and this is wrong
+ Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
John Lea (johnlea) on 2012-01-11
description: updated
mmxbass (mmxbass) wrote :

@johnlea; I waited a month and a half to respond to this just to make a point. We're at the what... 3.5 month mark? Absolutely zero progress has been made and I have to say this is hardly a stumper. This goes as much for criticism of Ubuntu as well. Unity2D isn't anywhere near ready for primetime. Releasing it when it clearly hasn't reached maturity only hurts reputations. The developers themselves clearly didn't do complete testing of this since it makes step-through debugging impossible in basically any IDE.

Remember folks. Don't use any software that software developers themselves (clearly) aren't using.

Omer Akram (om26er) on 2012-01-31
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity-2d:
status: Confirmed → Fix Committed
Changed in unity-2d (Ubuntu):
assignee: Thomas Thurman (marnanel) → Lohith D Shivamurthy (dyams)
Changed in unity-2d:
assignee: nobody → Lohith D Shivamurthy (dyams)
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity-2d (Ubuntu):
importance: Undecided → High
John Lea (johnlea) wrote :

@mmxbass; perhaps you would like to submit a patch to fix this issue? All help is appreciated, and the more contributors the quicker these bugs will be resolved.

Changed in ayatana-design:
status: Triaged → Fix Committed
mmxbass (mmxbass) wrote :

1: What? Because that would be productive given how the bug is now (finally) in fix comitted status. Oddly enough not until after another complaint and one day after at that.

2: Even if that weren't the case I don't have time because I lose too much time at work thanks to, ironically enough, the bug itself. Sort of a catch-22 when a bug is introduced that affects developer productivity, don't you think?

TEST MORE NEXT TIME

Yung-Chin Oei (yungchin) wrote :

With the latest packages for 12.04, the menu focus seems to have changed to Alt-F10 as proposed. It also seems though that there isn't a "maximise" shortcut at all anymore, is that right? (It would be fine I think to combine it into Alt-F5 as proposed above.)

Changed in unity-2d:
milestone: none → 5.4
Omer Akram (om26er) on 2012-02-13
Changed in unity:
importance: High → Medium
Changed in unity (Ubuntu):
importance: High → Medium
Clint Byrum (clint-fewbar) wrote :

Yung-Chin, thats my finding as well. Very frustrating to not be able to maximize by keyboard. Sounds like a case for a new bug though.

Didier Roche (didrocks) on 2012-02-17
Changed in unity:
status: Triaged → Fix Released
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.4.0-0ubuntu1

---------------
unity-2d (5.4.0-0ubuntu1) precise; urgency=low

  * New upstream release
    - unity-2d-launcher crashed with SIGABRT in qt_message_output()
      (LP: #854634)
    - Useless scroll arrows in Unity 2D global menus (LP: #913237)
    - [workspace switcher] Does not activate since bzr revision 900
      (LP: #928398)
    - On unity 2d when using Hebrew localization launcher won't load if you
      move cursor all the way to the right (LP: #877292)
    - panel 2D uses wrong width on multi monitor setup (LP: #880698)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - [dash] User can move dash around with ALT+LeftClick+Move (LP: #827838)
    - [launcher] UI does not distinguish between windows on this workspace and
      others (LP: #883172)
    - Panel and launcher are blank and non-functional when /usr is a symlink
      (LP: #757288)
    - Launcher - change to 'locked out' by default (LP: #928153)
  * debian/control:
    - Build-dep on latest nux (ABI break)
  * debian/*install, debian/control:
    - transition unity-2d-launcher and unity-2d-places to unity-2d-shell
    - breaks against older gnome-session (as components links changed)
 -- Didier Roche <email address hidden> Fri, 17 Feb 2012 14:21:45 +0100

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-02-20
Changed in unity:
status: Fix Released → Triaged
Didier Roche (didrocks) on 2012-02-20
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → Low
Roman Yepishev (rye) wrote :

Just to make sure this is not forgotten after Unity gets Alt+F10 shortcut too - currently gtk3 handles F10 in a weird way after xkb-data update, see https://bugzilla.gnome.org/show_bug.cgi?id=661973 for more information.

Roman Yepishev (rye) wrote :

I filed a bug in Ubuntu for gtk - LP 937822 for the issue i posted earlier.

Didier Roche (didrocks) on 2012-02-23
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
milestone: backlog → 5.6.0
Changed in unity (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Changed in unity:
status: Triaged → Fix Committed

The panel service part has been fixed on branch lp:~3v1n0/unity/lim (that doesn't hardcode this value anymore, but it looks the gconf key)

Changed in unity (Ubuntu):
status: Triaged → Fix Committed
nick rundy (nrundy) wrote :

The problem with making Alt+F5 a toggle is that the user does NOT know what he's getting.

User has a "almost maximized" window and taps Alt+F5 to "restore the window." But instead it maximizes. So then he's got to hit Alt+F5 again.

It is MUCH preferable to have keyboard shortcuts for OFTEN done activities (like minimizing, restoring, maximizing) a window do only one thing. Then when the user presses it he KNOWS what's going to happen.

On Tue, Feb 28, 2012 at 12:18:29AM -0000, Nick Rundy wrote:
> User has a "almost maximized" window and taps Alt+F5 to "restore the
> window." But instead it maximizes. So then he's got to hit Alt+F5 again.

Speaking as such a user, I'd say the cost of hitting Alt+F5 a second time,
when my fingers are over those keys already, is close to zero. Oh well, I
don't really care what the default shortcut will be, as long as there is a
default at all...

Oded Arbel (oded-geek) wrote :

I didn't know this bug was a discussion about the "toggle maximized" functionality, but if we are on the subject - I'd hate to see this very useful feature removed just because Unity has thrown discoverability out the window by hiding the window operation menu (the icon that represents it in a window was replaced by operation buttons and in a maximized window there is no way at all to get it using the mouse).

I would also like to have this feature using the default shortcut as it was in GNOME 2, GNOME 3 and KDE (which is ALT-F10) but anything configurable will work.

nick rundy (nrundy) wrote :

Guys, what I don't understand about this bug report is why using "F" keys is a problem for everything but Alt+F1 (Launcher Keyboard Navigation Mode) and the long-standing Alt+F4 (to close a window)?????

REGARDING Maximize/Restore keyboard shortcut:
Currently, "Keyboard Shortcuts" allows users to configure the following:
-"Toggle maximization state" = pressing toggles between the Maximize/Restore states
-"Maximize window" = pressing maximizes the window. If the window is already maximized it does nothing (yeah!)

So as long as these superb customization options stay, it doesn't matter what the defaults are because users can set what they want: a toggle or no-toggle for maximize/restore.

Alexander Kabakow (alexzak) wrote :

Unity-2d status above is "Fix released", but i still have this issue

I'am using unity-3d form ubuntu 11.10 with all updates installed
What is going on?
Is it ok?
When i will receive fixed version of unity-2d?

Alexander Kabakow (alexzak) wrote :

I'am using unity-2d form ubuntu 11.10 with all updates installed

PS:Sorry for typo

Jaromir Obr (jaromir-obr) wrote :

The fix is available in 12.04 beta

thom (tsk) wrote :

Hmm.... not for unity-3d it isn't....not yet.

for gnome-terminal I still have to add the cryptic incantation:

#---------------------------------------------------------
cat <<EOF > ~/.config/gtk-3.0/gtk.css
@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}
EOF
#----------------------------------------------------------

to make it work properly

The only "fix" that landed in 12.04 beta was a brand new bug:
when F10-menu is enabled, menu is only visible as long as F10 is pressed. Upon release of F10 the menu disappears.

not quite there yet I suppose ;-)

Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Alexander Kabakow (alexzak) wrote :

I'am still can't use unity :(
I am really dissapointed and will not use unity in future

My stopper bugs is #878492 and #877191

I wish you luck

Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
joopbraak (joopbraak) wrote :

My stopper bug is unity.

Do you mayor developers still feel that all the time that is spent developing unity and solving the (still quite basic) bugs would not better have been spent on making all the applications that people actually need to do their work (and the basic functions in Ubuntu, hibernation, to just mention a very important one) better ?

Gerry Boland (gerboland) wrote :

@Alexander Kabakow (alexzak)
The fix is available on Precise builds.

Didier Roche (didrocks) wrote :

Something made it regressed in 3d

Changed in unity:
assignee: Didier Roche (didrocks) → nobody
milestone: 5.6.0 → 5.8.0
status: Fix Released → Triaged
Changed in unity (Ubuntu):
status: Fix Released → Triaged
Tim Penhey (thumper) on 2012-03-15
Changed in unity:
status: Triaged → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: In Progress → Fix Committed
Robert Hutton (rwh-helms-deep) wrote :

The new default shortcut for maximise is Super+Up (and restore is Super+Down). These are now being shown in the keyboard shortcuts help that is displayed by holding super.

Didier Roche (didrocks) on 2012-03-23
Changed in unity:
status: Fix Committed → Fix Released
Michał Sawicz (saviq) wrote :

This is still an issue in unity-2d, though.

Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.8.0-0ubuntu1

---------------
unity (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - New "push mouse offscreen" feature really difficult to get (LP: #923749)
    - unity-2d-panel crashed with SIGSEGV in
      unity::indicator::DBusIndicators::Impl::RequestSyncAll() (LP: #864737)
    - Pressing "Alt+Enter" causes compiz to crash in CompOption::value() from
      unity::UnityScreen::showLauncherKeyTerminate (LP: #960957)
    - SEGSIGV after unplugging external monitor (LP: #962693)
    - Background colorization should use a different heuristic (LP: #865239)
    - compiz+unity3d generates > 50 wakeups a second on idle system
      (LP: #917210)
    - [FFe, UIFe] HUD - The HUD does not respect launcher autohide or icon
      size settings (LP: #921506)
    - clicking on folders in the file lens does not open nautilus
      (LP: #921665)
    - No text inside multirange filters (LP: #927710)
    - can't alt-tab restore minimized uis which have an instance on another
      workspace (LP: #933397)
    - Ubuntu Software Center Unity launcher integration is not working
      (LP: #932280)
    - The line separator between the launcher and the dash is cleared when
      selecting a category (LP: #941082)
    - unity-panel-service crashed with SIGSEGV in g_hash_table_foreach()
      (LP: #937119)
    - Alt-F10 locks up Unity (LP: #948522)
    - multimonitor, launcher: Provide an option to display either a single
      launcher or a launcher on each display in a multi-monitor environment
      (LP: #950136)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - Unity 5.6: key bindings (such as Super) don't work on empty workspace or
      on slow/loaded systems (LP: #953089)
    - Alt+arrows keyboard shortcuts don't invoke Back and Forward navigation
      (LP: #953783)
    - HUD is sending 2 menu signals instead of 1 (LP: #956878)
    - 6th item of HUD not fully visible (LP: #957229)
    - HUD: seems to trigger operations more than once (LP: #960503)
    - Launcher gets always desaturated when using HUD on secondary monitor
      (LP: #961169)
    - [5.8 pre staging] launcher is displayed on the left screen, not the
      primary one (LP: #961281)
    - launcher icons do not re-saturate after dash is closed (LP: #961844)
    - Launcher shows arrows for applications on all workspaces (LP: #961977)
    - Dash - Implement overlay scrollbars in Dash (LP: #608124)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - Dash - Missing category separator line in dash (LP: #850984)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - When multiple results have equal string match relevancy ranking,
      those with equal ranking should be then sorted by frequency of use.
      (LP: #871900)
    - Keyboard shortcut - F10 shortcut is used to show m...

Read more...

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Vlad (vcosvic) wrote :

Still have this bug in Unity 2D on Ubuntu 11.10. Is there any workaround besides switching to another distro? This is show-stopper for me.

Michał Sawicz (saviq) wrote :

I can confirm this is still an issue for GTK apps, pressing F10 invokes the menu, initially with a wrong placement.

Changed in unity-2d:
status: Fix Released → Confirmed
milestone: 5.4 → 5.10.0
Michał Sawicz (saviq) wrote :

I've tracked it down to org.gnome.desktop.interface menubar-accel dconf key. It defaults to F10, so gnome apps are affected.
/desktop/gnome/interface/menubar_accel is the legacy gconf key.

Additionally, for gnome-terminal to actually forward F10 key press to the shell, /apps/gnome-terminal/global/use_menu_accelelators needs to be disabled. That in itself looks like a bug in gnome-terminal (it should read the key above and only act on the shortcut set there).

A side-effect that I didn't yet identify is, after changing the accel key, F10 triggers the context menu in gnome apps.

Yury V. Zaytsev (zyv) wrote :

Michal, just want to thank you for your work on this bug, a solution would be highly appreciated.

Michał Sawicz (saviq) wrote :

Hey Yury, right now I can provide you with a workaround:

$ gsettings set org.gnome.desktop.interface menubar-accel "<Alt>F10"
$ gconftool-2 --set --type bool /desktop/gnome/interface/menubar_accel "<Alt>F10"
$ gconftool-2 --set --type bool /apps/gnome-terminal/global/use_menu_accelerators false

That will, unfortunately, leave you with the context menu on F10, bugreports:
https://bugzilla.gnome.org/show_bug.cgi?id=661973
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=658392

Oded Arbel (oded-geek) wrote :

When I run
$ gconftool-2 --set --type bool /desktop/gnome/interface/menubar_accel "<Alt>F10"

I get this:
Error: Parse error: Didn't understand `<Alt>F10' (expected true or false)

Using
$ gconftool-2 --set --type string /desktop/gnome/interface/menubar_accel "<Alt>F10"
Worked for me

Michał Sawicz (saviq) wrote :

Yes, of course, sorry.

Alex Vorona (alex-vorona) wrote :

>The new default shortcut for maximise is Super+Up (and restore is Super+Down).
Well, I have no right Win button neither on my Lenovo Thinkpad Edge 15 nor on my Dell Inspiron 1501. How many notebooks/netbooks did You see with right Win button? And You propose to use two hands simultaneously to press this shortcut ?

Daniel Nyström (speakman) wrote :

Pressing Super+Up/Left/Right does not work on my new MacBook Air. It just show the shortcut help window as I've been holding down the Super button only.

Daniel Nyström (speakman) wrote :

Forgot to mention I'm on 12.04 Beta, just updated aws.

Daniel Nyström (speakman) wrote :

Ctrl+Super+Left/Right/Up does work though...

Didier Roche (didrocks) on 2012-04-12
Changed in unity-2d:
milestone: 5.10.0 → 5.12
Albert Astals Cid (aacid) wrote :

Fix for unity-2d was released as part of Unity-2d 5.2.1

Changed in unity-2d:
assignee: Lohith D Shivamurthy (dyams) → nobody
Changed in unity-2d (Ubuntu):
assignee: Lohith D Shivamurthy (dyams) → nobody
Changed in unity-2d:
status: Confirmed → Fix Released
Didier Roche (didrocks) on 2012-04-17
Changed in unity-distro-priority:
status: Fix Committed → Fix Released

I have this bug but I do not think it has anything to do with Unity as I am running XFCE. I am using Ubuntu 12.04.

QUESTIONS

Is this bug report meant to cover Unity only?

Should I open a new bug, or should one of the duplicate bugs be unduped?
(I noticed there is some discussion in bug #726639 around whether or not it is actually a dupe of this bug).

Is anyone else seeing this issue and not using Unity?

WORKAROUNDS THAT WORK

$ cat .gtkrc-2.0
binding "NoKeyboardNavigation" {
        unbind "<shift>F10"
}

class "*" binding "NoKeyboardNavigation"

$ cat .config/gtk-3.0/gtk.css
@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}

WORKAROUNDS THAT DO NOT WORK

I have tried gconf-editor, changing the setting /desktop/gnome/interface/menubar_accel has no effect

There is another open bug report for the non-Unity issue:

Bug #937822 [precise] F10 always opens the menu, cannot be overriden (after xkeyboard-config update)

Michał Sawicz (saviq) wrote :

@Chris See my comment https://bugs.launchpad.net/ubuntu/+source/unity-2d/+bug/878492/comments/45 about the upstream bugs that seem to deal with the same.

Changed in unity-2d:
milestone: 5.12 → none
Valdisvi (valdis-vitolins) wrote :

On 12.04 64-bit it is fixed now, though, issue for gnome terminal still is not resolved: see Bug #987971 "Gnome-terminal shows pop-up menu after pressing F10"

John Lea (johnlea) wrote :

Reverting to 'Triaged' as this bug does not appear to be fixed in the release version of 12.04

Changed in unity:
status: Fix Released → Triaged
Changed in unity (Ubuntu):
status: Fix Released → Triaged
Changed in unity:
milestone: 5.8.0 → backlog

John, the bug has been fixed in unity (code), the problem is related to gtk apps only. We must fix them, not unity.

Changed in unity:
status: Triaged → Fix Released
milestone: backlog → none
Changed in gtk+2.0 (Ubuntu):
status: New → Confirmed
Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
unwrecker (unwrecker) wrote :

With workaround from Michał Sawicz, I have another bug.

1. Open some Terminals
2. Press «F10» (tilda typed, delete it)
3. Press Ctrl-D or type «exit»
4. All terminals will crash.

Didier Roche (didrocks) on 2012-06-20
Changed in unity:
status: Fix Released → Triaged
brewmanz (brewmanz) wrote :

I am running Ubuntu 11.10 AMD-64, applied all fixes, tried various work-arounds, rebooted a few times, and pressing F10 still displays first menu list. As something of a newbie with Ubuntu, I'll be honest and say that I can't understand quite a bit of the jargon that goes on - what's gtk? unity? 2D vs 3D?
At the end of the day, all I want is for Ubunut to allow me to press F10 and have it passed through to the app - in my case VirtualBox running Windows with Visual Studio debugging step being F10.
Please can someone tell me how to achieve that. Thanks.

Markelov Anton (doublic) wrote :

#32 Thanks for solution! It works fo me/

Beowulf (s-highlander) wrote :

I experience the bug with Ubuntu 12.04, it is so annoying!

John Lea (johnlea) on 2012-10-12
no longer affects: unity-2d (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
importance: Medium → High
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → High
Changed in gtk+2.0 (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in unity:
importance: Medium → High
Didier Roche (didrocks) wrote :

Please do not reopen the unity task. The issue remaining issue is on gtk only.

Changed in unity (Ubuntu):
status: Triaged → Fix Released
John Lea (johnlea) on 2012-10-12
Changed in unity (Ubuntu):
status: Fix Released → Triaged
Didier Roche (didrocks) wrote :

@John: please read the comment #63 before reopening it :/

Changed in unity-2d (Ubuntu):
status: New → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Timothy Arceri (t-fridey) wrote :

Marking GTK packages as invalid for this bug. As this bug is about changing the default shortcut in Unity.

See bug #937822 for the related GTK bug.

no longer affects: gtk
affects: gtk+2.0 (Ubuntu) → ubuntu
Changed in ubuntu:
status: Triaged → Invalid
Changed in gtk+3.0 (Ubuntu):
status: Triaged → Invalid
affects: ubuntu → gtk+2.0 (Ubuntu)

Unity code is fixed, probably we only need to change gtk-settings not to use F10 to open menus.

Changed in unity:
status: Triaged → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
Norbert (nrbrtx) wrote :

I recently installed 12.04.4 from latest CD-image. The bug is still here (tested in GNOME Fallback session). Please fix it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.