Activity log for bug #878052

Date Who What changed Old value New value Message
2011-10-19 10:00:10 Ivan Danov bug added bug
2011-10-19 21:03:04 Ivan Danov bug added subscriber Unity Bugs
2011-10-19 22:27:17 Ivan Danov bug task added unity-lens-files (Ubuntu)
2011-10-19 22:29:06 Ivan Danov bug task added unity-lens-files
2011-10-19 22:30:37 Ivan Danov bug added subscriber Unity Team
2011-10-19 22:32:33 Ivan Danov summary Content of hidden folders shown in unity-files-lens Content of hidden folders shown in unity-lens-files
2011-10-20 22:59:28 Ivan Danov bug added subscriber Ubuntu Bug Control
2011-10-20 23:01:08 Ivan Danov bug added subscriber Ubuntu Bugs
2011-10-22 18:38:42 C de-Avillez removed subscriber Ubuntu Bugs
2011-10-22 18:38:50 C de-Avillez removed subscriber Ubuntu Bug Control
2011-12-09 11:48:07 Omer Akram removed subscriber Unity Team
2011-12-09 11:48:11 Omer Akram removed subscriber Unity Bugs
2011-12-09 11:49:09 Omer Akram bug task added unity (Ubuntu)
2011-12-09 11:49:21 Omer Akram unity-lens-files: importance Undecided Low
2011-12-09 11:49:24 Omer Akram unity (Ubuntu): importance Undecided Low
2011-12-09 11:49:29 Omer Akram unity-lens-files (Ubuntu): importance Undecided Low
2011-12-09 11:49:36 Omer Akram unity-lens-files (Ubuntu): status New Confirmed
2011-12-09 11:49:38 Omer Akram unity: status New Confirmed
2011-12-09 11:49:40 Omer Akram unity-lens-files: status New Confirmed
2011-12-09 11:49:47 Omer Akram unity (Ubuntu): status New Confirmed
2011-12-09 11:49:49 Omer Akram unity: importance Undecided Low
2011-12-09 12:01:25 Mikkel Kamstrup Erlandsen unity-lens-files: importance Low High
2011-12-09 12:01:25 Mikkel Kamstrup Erlandsen unity-lens-files: status Confirmed Triaged
2011-12-09 12:01:25 Mikkel Kamstrup Erlandsen unity-lens-files: milestone 5.0.0
2011-12-09 12:01:40 Mikkel Kamstrup Erlandsen unity: importance Low High
2011-12-09 12:01:40 Mikkel Kamstrup Erlandsen unity: status Confirmed Triaged
2011-12-09 12:01:40 Mikkel Kamstrup Erlandsen unity: milestone 5.0.0
2011-12-09 12:01:43 Omer Akram unity (Ubuntu): importance Low High
2011-12-09 12:01:46 Omer Akram unity-lens-files (Ubuntu): importance Low High
2011-12-09 12:02:03 Omer Akram unity (Ubuntu): status Confirmed Triaged
2011-12-09 12:02:05 Omer Akram unity-lens-files (Ubuntu): status Confirmed Triaged
2011-12-10 15:56:17 Simon Hirscher bug added subscriber Simon Hirscher
2012-01-12 15:35:07 Mikkel Kamstrup Erlandsen unity-lens-files: milestone 5.0.0 5.0.2
2012-01-12 15:35:09 Mikkel Kamstrup Erlandsen unity: milestone 5.0.0 5.2.0
2012-01-12 17:41:55 Didier Roche unity: milestone 5.2.0 5.0.0
2012-01-12 17:51:38 Didier Roche unity: milestone 5.0.0 5.2.0
2012-02-03 10:32:22 Didier Roche unity: milestone 5.2.0 5.4.0
2012-02-13 08:13:49 Michal Hruby unity-lens-files: milestone 5.2.0 5.6.0
2012-02-13 08:13:52 Michal Hruby unity: milestone 5.4.0 5.6.0
2012-03-03 15:20:42 Robert Roth unity-lens-files: assignee Robert Roth (evfool)
2012-03-03 15:20:48 Robert Roth unity-lens-files: status Triaged In Progress
2012-03-03 15:21:26 Launchpad Janitor branch linked lp:~evfool/unity-lens-files/lp878052
2012-03-03 15:23:27 Robert Roth bug added subscriber Robert Roth
2012-03-05 13:15:28 Robert Roth unity: assignee Robert Roth (evfool)
2012-03-05 13:15:31 Robert Roth unity (Ubuntu): assignee Robert Roth (evfool)
2012-03-05 13:15:34 Robert Roth unity-lens-files (Ubuntu): assignee Robert Roth (evfool)
2012-03-05 13:15:37 Robert Roth unity (Ubuntu): assignee Robert Roth (evfool)
2012-03-05 13:15:40 Robert Roth unity-lens-files (Ubuntu): assignee Robert Roth (evfool)
2012-03-05 13:15:44 Robert Roth unity: assignee Robert Roth (evfool)
2012-03-12 10:44:29 Didier Roche unity: milestone 5.6.0 5.8.0
2012-03-12 10:59:23 Didier Roche unity: status Triaged Fix Released
2012-03-12 10:59:28 Didier Roche unity: milestone 5.8.0
2012-03-12 10:59:32 Didier Roche unity-lens-files: status In Progress Fix Committed
2012-03-12 10:59:37 Didier Roche bug task deleted unity (Ubuntu)
2012-03-12 10:59:46 Didier Roche unity-lens-files: status Fix Committed Fix Released
2012-03-12 11:05:20 Launchpad Janitor branch linked lp:~ubuntu-desktop/unity-lens-files/ubuntu
2012-03-12 11:10:14 Launchpad Janitor unity-lens-files (Ubuntu): status Triaged Fix Released
2012-03-12 14:39:02 Launchpad Janitor branch linked lp:ubuntu/unity-lens-files
2012-03-12 15:27:27 Michal Hruby unity-lens-files: status Fix Released In Progress
2012-03-12 15:27:31 Michal Hruby unity-lens-files (Ubuntu): status Fix Released Triaged
2012-03-12 15:27:37 Michal Hruby unity-lens-files: milestone 5.6.0 5.8.0
2012-03-12 15:27:39 Michal Hruby unity: milestone 5.8.0
2012-03-12 15:27:42 Michal Hruby unity: status Fix Released In Progress
2012-03-23 13:37:09 Didier Roche unity: milestone 5.8.0 5.10.0
2012-03-27 15:50:17 Omer Akram unity-lens-files (Ubuntu): status Triaged In Progress
2012-04-01 06:33:15 Omer Akram unity: status In Progress Confirmed
2012-04-01 06:33:19 Omer Akram unity-lens-files: status In Progress Confirmed
2012-04-01 06:33:21 Omer Akram unity-lens-files: assignee Robert Roth (evfool)
2012-04-01 06:33:23 Omer Akram unity-lens-files (Ubuntu): status In Progress Confirmed
2012-04-12 09:28:28 Didier Roche unity: milestone 5.10.0 5.12.0
2012-04-27 11:35:05 Didier Roche unity: milestone 5.12.0 5.14.0
2012-04-28 20:18:45 Lorenzo Mattei unity-lens-files: assignee Lorenzo Mattei (lore-mattei)
2012-04-28 20:18:53 Lorenzo Mattei unity-lens-files: status Confirmed In Progress
2012-04-28 20:42:30 Lorenzo Mattei branch linked lp:~lore-mattei/unity-lens-files/unity-lens-files-lp878052
2012-07-26 03:31:10 Daniel van Vugt unity: milestone 5.14.0 5.16.0
2012-08-31 20:57:27 Bernhard Kaindl bug added subscriber Bernhard Kaindl
2012-10-04 05:18:17 Daniel van Vugt unity: milestone 5.16.0 5.18.0
2012-10-08 08:24:55 Łukasz Zemczak nominated for series unity/5.0
2012-10-08 08:24:55 Łukasz Zemczak bug task added unity/5.0
2012-10-08 08:24:55 Łukasz Zemczak nominated for series unity/6.0
2012-10-08 08:24:55 Łukasz Zemczak bug task added unity/6.0
2012-10-08 08:25:12 Łukasz Zemczak unity: milestone 5.18.0 7.0.0
2012-10-08 08:25:16 Łukasz Zemczak unity/5.0: milestone 5.18.0
2012-10-08 08:25:33 Łukasz Zemczak unity/5.0: status New Confirmed
2012-10-08 08:25:40 Łukasz Zemczak unity/5.0: importance Undecided High
2012-10-08 08:25:46 Łukasz Zemczak unity/6.0: importance Undecided High
2012-10-08 08:26:01 Łukasz Zemczak unity/6.0: milestone 6.12.0
2012-11-05 11:38:27 Paweł Stołowski branch linked lp:~stolowski/unity-lens-files/hidden-files
2012-11-05 12:01:43 Michal Hruby description 1. Put a file in a hidden folder (name of the folder starting with ".", the name of the file without ".") - try with jpeg, it's easier to spot 2. Open the file and close it after that 3. Open the Dash and start typing the name of the previously closed file 4. You can see the file appearing in the Files & Folders Lens I don't think that it's a normal behavior, since after fixing the bug https://bugs.launchpad.net/unity/+bug/756280 the hidden files are not visible anymore in the Files & Folders Lens, so should be the content of hidden folders. I wrote couple of comments on the bug for the files, but nobody reopened the issue, so I had to make a new one. Using the latest up-to-date Ubuntu Oneiric Ocelot 11.10 Files contained in hidden directories often show up in files lens, which might and might not be desired - it can be useful in cases where you need to often search for and edit a configuration file for some application/service (which usually reside in hidden directories), yet many users think that by putting files into hidden directories these are no longer displayed anywhere. The problem is that by putting a file into hidden directories, you no longer see the file in file browsers etc, but accessing the file still logs its usage in eg Zeitgeist, and users need to use the dedicated Privacy settings panel to ensure access to such resources is not logged. We should have clear guidelines on when to use which to ensure consistent behaviour throughout the system. Original description: 1. Put a file in a hidden folder (name of the folder starting with ".", the name of the file without ".") - try with jpeg, it's easier to spot 2. Open the file and close it after that 3. Open the Dash and start typing the name of the previously closed file 4. You can see the file appearing in the Files & Folders Lens I don't think that it's a normal behavior, since after fixing the bug https://bugs.launchpad.net/unity/+bug/756280 the hidden files are not visible anymore in the Files & Folders Lens, so should be the content of hidden folders. I wrote couple of comments on the bug for the files, but nobody reopened the issue, so I had to make a new one. Using the latest up-to-date Ubuntu Oneiric Ocelot 11.10
2012-11-05 12:02:13 Michal Hruby bug task added ayatana-design
2012-11-05 12:08:35 John Lea description Files contained in hidden directories often show up in files lens, which might and might not be desired - it can be useful in cases where you need to often search for and edit a configuration file for some application/service (which usually reside in hidden directories), yet many users think that by putting files into hidden directories these are no longer displayed anywhere. The problem is that by putting a file into hidden directories, you no longer see the file in file browsers etc, but accessing the file still logs its usage in eg Zeitgeist, and users need to use the dedicated Privacy settings panel to ensure access to such resources is not logged. We should have clear guidelines on when to use which to ensure consistent behaviour throughout the system. Original description: 1. Put a file in a hidden folder (name of the folder starting with ".", the name of the file without ".") - try with jpeg, it's easier to spot 2. Open the file and close it after that 3. Open the Dash and start typing the name of the previously closed file 4. You can see the file appearing in the Files & Folders Lens I don't think that it's a normal behavior, since after fixing the bug https://bugs.launchpad.net/unity/+bug/756280 the hidden files are not visible anymore in the Files & Folders Lens, so should be the content of hidden folders. I wrote couple of comments on the bug for the files, but nobody reopened the issue, so I had to make a new one. Using the latest up-to-date Ubuntu Oneiric Ocelot 11.10 Files contained in hidden directories often show up in files lens, which might and might not be desired - it can be useful in cases where you need to often search for and edit a configuration file for some application/service (which usually reside in hidden directories), yet many users think that by putting files into hidden directories these are no longer displayed anywhere. The problem is that by putting a file into hidden directories, you no longer see the file in file browsers etc, but accessing the file still logs its usage in eg Zeitgeist, and users need to use the dedicated Privacy settings panel to ensure access to such resources is not logged. We should have clear guidelines on when to use which to ensure consistent behaviour throughout the system. Original description: 1. Put a file in a hidden folder (name of the folder starting with ".", the name of the file without ".") - try with jpeg, it's easier to spot 2. Open the file and close it after that 3. Open the Dash and start typing the name of the previously closed file 4. You can see the file appearing in the Files & Folders Lens I don't think that it's a normal behavior, since after fixing the bug https://bugs.launchpad.net/unity/+bug/756280 the hidden files are not visible anymore in the Files & Folders Lens, so should be the content of hidden folders. I wrote couple of comments on the bug for the files, but nobody reopened the issue, so I had to make a new one. Using the latest up-to-date Ubuntu Oneiric Ocelot 11.10 --------------------------------- Desired resolution: - The files contained in hidden directories should not be displayed in the Dash
2012-11-07 12:44:11 Timo Jyrinki unity/6.0: milestone 6.12.0 6.16.0
2012-11-08 11:34:16 PS Jenkins bot unity-lens-files: status In Progress Fix Committed
2012-11-08 11:45:16 Paweł Stołowski unity-lens-files: assignee Lorenzo Mattei (lore-mattei) Pawel Stolowski (stolowski)
2012-11-08 12:04:09 Paweł Stołowski branch linked lp:~stolowski/unity-lens-files/hidden-files-6.0
2012-11-08 12:11:23 Timo Jyrinki unity: status Confirmed Invalid
2012-11-08 12:11:32 Timo Jyrinki unity/6.0: status New Invalid
2012-11-08 12:11:35 Timo Jyrinki unity: milestone 7.0.0
2012-11-08 12:11:41 Timo Jyrinki unity/5.0: milestone 5.18.0
2012-11-08 12:11:46 Timo Jyrinki unity/5.0: status Confirmed Invalid
2012-11-08 12:11:48 Timo Jyrinki unity/6.0: milestone 6.16.0
2012-11-08 12:11:51 Timo Jyrinki unity: importance High Undecided
2012-11-08 12:11:53 Timo Jyrinki unity/5.0: importance High Undecided
2012-11-08 12:11:56 Timo Jyrinki unity/6.0: importance High Undecided
2012-11-08 12:12:18 Timo Jyrinki nominated for series unity-lens-files/5.0
2012-11-08 12:12:18 Timo Jyrinki bug task added unity-lens-files/5.0
2012-11-08 12:12:18 Timo Jyrinki nominated for series unity-lens-files/6.0
2012-11-08 12:12:18 Timo Jyrinki bug task added unity-lens-files/6.0
2012-11-08 12:56:19 Timo Jyrinki unity-lens-files/6.0: milestone 6.8.0
2012-11-08 12:56:24 Timo Jyrinki unity-lens-files/5.0: milestone 5.14.0
2012-11-08 12:56:53 Timo Jyrinki unity-lens-files: milestone 5.8.0 7.0.0
2012-11-08 13:41:52 Paweł Stołowski branch linked lp:~stolowski/unity-lens-files/hidden-files-5.0
2012-11-12 09:26:01 Paweł Stołowski unity-lens-files/5.0: assignee Pawel Stolowski (stolowski)
2012-11-12 09:26:04 Paweł Stołowski unity-lens-files/6.0: assignee Pawel Stolowski (stolowski)
2012-11-12 09:26:26 Paweł Stołowski unity-lens-files/6.0: status New Fix Committed
2012-11-14 06:17:30 Timo Jyrinki unity-lens-files/5.0: status New Fix Committed
2012-11-22 16:44:24 Stephen M. Webb unity-lens-files (Ubuntu): status Confirmed In Progress
2012-11-22 16:44:24 Stephen M. Webb unity-lens-files (Ubuntu): milestone ubuntu-13.04-alpha-1
2012-11-24 13:19:44 Andrea Azzarone unity-lens-files (Ubuntu): status In Progress Fix Committed
2012-12-05 15:00:25 Launchpad Janitor unity-lens-files (Ubuntu): status Fix Committed Fix Released
2013-01-11 16:35:24 Launchpad Janitor branch linked lp:~sil2100/unity-lens-files/quantal_6.6.1
2013-01-16 12:47:21 Łukasz Zemczak description Files contained in hidden directories often show up in files lens, which might and might not be desired - it can be useful in cases where you need to often search for and edit a configuration file for some application/service (which usually reside in hidden directories), yet many users think that by putting files into hidden directories these are no longer displayed anywhere. The problem is that by putting a file into hidden directories, you no longer see the file in file browsers etc, but accessing the file still logs its usage in eg Zeitgeist, and users need to use the dedicated Privacy settings panel to ensure access to such resources is not logged. We should have clear guidelines on when to use which to ensure consistent behaviour throughout the system. Original description: 1. Put a file in a hidden folder (name of the folder starting with ".", the name of the file without ".") - try with jpeg, it's easier to spot 2. Open the file and close it after that 3. Open the Dash and start typing the name of the previously closed file 4. You can see the file appearing in the Files & Folders Lens I don't think that it's a normal behavior, since after fixing the bug https://bugs.launchpad.net/unity/+bug/756280 the hidden files are not visible anymore in the Files & Folders Lens, so should be the content of hidden folders. I wrote couple of comments on the bug for the files, but nobody reopened the issue, so I had to make a new one. Using the latest up-to-date Ubuntu Oneiric Ocelot 11.10 --------------------------------- Desired resolution: - The files contained in hidden directories should not be displayed in the Dash [Impact] When a file is hidden, users expect it to be hidden. Same for files contained in hidden directories. This can be a privacy problem for many people. [Test Case] 1. Put a file in a hidden folder (name of the folder starting with ".", the name of the file without ".") - try with jpeg, it's easier to spot 2. Open the file and close it after that 3. Open the Dash and start typing the name of the previously closed file -> Make sure you can't see the file appearing in the Files & Folders Lens [Regression Potential] Missing files in the dash file lens search. --- Files contained in hidden directories often show up in files lens, which might and might not be desired - it can be useful in cases where you need to often search for and edit a configuration file for some application/service (which usually reside in hidden directories), yet many users think that by putting files into hidden directories these are no longer displayed anywhere. The problem is that by putting a file into hidden directories, you no longer see the file in file browsers etc, but accessing the file still logs its usage in eg Zeitgeist, and users need to use the dedicated Privacy settings panel to ensure access to such resources is not logged. We should have clear guidelines on when to use which to ensure consistent behaviour throughout the system. Original description: 1. Put a file in a hidden folder (name of the folder starting with ".", the name of the file without ".") - try with jpeg, it's easier to spot 2. Open the file and close it after that 3. Open the Dash and start typing the name of the previously closed file 4. You can see the file appearing in the Files & Folders Lens I don't think that it's a normal behavior, since after fixing the bug https://bugs.launchpad.net/unity/+bug/756280 the hidden files are not visible anymore in the Files & Folders Lens, so should be the content of hidden folders. I wrote couple of comments on the bug for the files, but nobody reopened the issue, so I had to make a new one. Using the latest up-to-date Ubuntu Oneiric Ocelot 11.10 --------------------------------- Desired resolution: - The files contained in hidden directories should not be displayed in the Dash
2013-01-16 12:47:29 Łukasz Zemczak bug added subscriber Ubuntu Stable Release Updates Team
2013-01-16 14:33:13 Timo Jyrinki nominated for series Ubuntu Precise
2013-01-16 14:33:13 Timo Jyrinki nominated for series Ubuntu Quantal
2013-01-25 09:20:34 Didier Roche bug task added unity-lens-files (Ubuntu Quantal)
2013-03-08 14:32:49 Launchpad Janitor branch linked lp:~timo-jyrinki/unity-lens-files/precise.sru.hiddenfiles
2013-03-20 00:45:06 Chris Halse Rogers unity-lens-files (Ubuntu Quantal): status New Fix Committed
2013-03-20 00:45:12 Chris Halse Rogers bug added subscriber SRU Verification
2013-03-20 00:45:16 Chris Halse Rogers tags 11.10 dash folders hidden lens ocelot oneiric privacy ubuntu unity unity-files-lens 11.10 dash folders hidden lens ocelot oneiric privacy ubuntu unity unity-files-lens verification-needed
2013-03-20 18:44:11 Ivan Danov tags 11.10 dash folders hidden lens ocelot oneiric privacy ubuntu unity unity-files-lens verification-needed 11.10 dash folders hidden lens ocelot oneiric privacy ubuntu unity unity-files-lens verification-done
2013-03-28 17:00:26 Brian Murray removed subscriber Ubuntu Stable Release Updates Team
2013-03-28 17:01:12 Launchpad Janitor unity-lens-files (Ubuntu Quantal): status Fix Committed Fix Released
2013-06-12 14:06:16 Didier Roche bug task added unity-lens-files (Ubuntu Precise)
2013-06-20 21:58:52 Brian Murray unity-lens-files (Ubuntu Precise): status New Fix Committed
2013-06-20 21:58:57 Brian Murray bug added subscriber Ubuntu Stable Release Updates Team
2013-06-20 21:59:03 Brian Murray tags 11.10 dash folders hidden lens ocelot oneiric privacy ubuntu unity unity-files-lens verification-done 11.10 dash folders hidden lens ocelot oneiric privacy ubuntu unity unity-files-lens
2013-06-20 21:59:04 Brian Murray tags 11.10 dash folders hidden lens ocelot oneiric privacy ubuntu unity unity-files-lens 11.10 dash folders hidden lens ocelot oneiric privacy ubuntu unity unity-files-lens verification-needed
2013-07-08 14:30:19 Timo Jyrinki tags 11.10 dash folders hidden lens ocelot oneiric privacy ubuntu unity unity-files-lens verification-needed 11.10 dash folders hidden lens ocelot oneiric privacy ubuntu unity unity-files-lens verification-done
2013-07-08 15:08:14 Launchpad Janitor unity-lens-files (Ubuntu Precise): status Fix Committed Fix Released
2015-10-14 16:19:03 Marco Trevisan (Treviño) tags 11.10 dash folders hidden lens ocelot oneiric privacy ubuntu unity unity-files-lens verification-done 11.10 dash folders hidden lens ocelot oneiric privacy rls-w-incoming ubuntu unity unity-files-lens verification-done