SRU0-Regression: scrollbar displacement caused dash rows to show less icons

Bug #875023 reported by Omer Akram on 2011-10-15
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Robert Carr
unity (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

unity 4.24.0

This update from unity 4.22.0 to 4.24.0 seems to have displaced the scrollbar so the number of icons shown in a dash row have reduced and there is an empty area right next to it. see the attached screenshots for comparision.

(I set the importance to critical as we are expected to introduce a regression through SRU, unless its fixed before the SRU upload is expected)

Omer Akram (om26er) wrote :
Omer Akram (om26er) wrote :

in unity 4.22.0-0ubuntu3

Gord Allott (gordallott) on 2011-10-18
Changed in unity:
assignee: Gord Allott (gordallott) → Robert Carr (robertcarr)
status: Confirmed → Fix Committed
Gord Allott (gordallott) wrote :

Revision 1716 in unity 4.0 trunk reverts the change that causes this problem, because we don't have a branch i'll list the diff here,

=== modified file 'plugins/unityshell/src/LensView.cpp'
--- plugins/unityshell/src/LensView.cpp 2011-10-10 15:53:53 +0000
+++ plugins/unityshell/src/LensView.cpp 2011-10-14 14:30:43 +0000
@@ -145,7 +145,9 @@
 {
   layout_ = new nux::HLayout(NUX_TRACKER_LOCATION);

- layout_->SetHorizontalExternalMargin(8);
+ // Breaks the sizing of the whole dash causing some colums to be clipped from result view.
+ // look in to this for P.
+ // layout_->SetHorizontalExternalMargin(8);

   scroll_view_ = new LensScrollView(new PlacesVScrollBar(NUX_TRACKER_LOCATION),
                                     NUX_TRACKER_LOCATION);

Gord Allott (gordallott) wrote :

SRU Test case:

1, Log in to a unity session on a non netbook machine (if the dash is fullscreen, this should not apply)
2, Open the dash with the ubuntu launcher or by pressing super
3, Navigate to the Apps lens or any lens with a full row of icons
4, Six icons should be in each full row, if the filter bar is opened, then four icons should remain in each row.
5, If less than six icons are in each row or if there is a large space before the end of the row, the test failed

Note; if you have a small monitor (smaller than the normal dash size) or an extremely large monitor (at least greater than 2000 pixels in width) you may see less or more icons in the dash as the dash will change shape to conform to your monitor size, in these cases the test is to make sure that the icons are "flush" with the edge of the dash and there are no large empty spaces

Hello Omer, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Miklos Juhasz (mjuhasz) wrote :

This bug is resolved.
I have unity 4.24.0-0ubuntu2 installed and the testcase in comment #4 passed. There are 6 icons in each row on the Apps lens.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2

---------------
unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Didier Roche <email address hidden> Tue, 18 Oct 2011 12:47:54 +0200

Changed in unity (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2b1

---------------
unity (4.24.0-0ubuntu2b1) oneiric-proposed; urgency=low

  * No-change reupload because of broken powerpc build.

unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Martin Pitt <email address hidden> Tue, 25 Oct 2011 07:01:51 +0200

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2011-12-08
Changed in unity:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Andrea Azzarone (azzar1) wrote :

ho ancora questo problema in trunk.

Andrea Azzarone (azzar1) wrote :

Ops... I forgot to wrote in English :/

I still have this problem in trunk.

Omer Akram (om26er) on 2012-01-20
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers