Launcher - Quicklists don’t have active blur

Reported by Pavol Klačanský on 2011-10-13
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Christopher Townsend
unity (Ubuntu)
Medium
Christopher Townsend

Bug Description

Hi, if I play some video the background of jumplist doesn't change

To Reproduce:

1. Start playing a video on the left side of the screen
2. Open a quicklist on top of the video

What currently incorrectly happens:
- The image from the moment the quicklist was opened is 'frozen' into the quiclist

Correct desired behaviour:
- it should be possible to see the playing video through the transparent background of the quicklist.

Related branches

lp:~townsend/unity/fix-quicklist-active-blur
Merged into lp:unity at revision 3498
PS Jenkins bot: Approve (continuous-integration) on 2013-09-11
Brandon Schaefer: Approve on 2013-09-10
Pavol Klačanský (pavolzetor) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Kai Mast (kai-mast) wrote :

I realized this some time ago too, not sure if this is really a bug or a wishlist-improvement...

Omer Akram (om26er) on 2011-12-08
summary: - background of jumplists is not rendered on the fly
+ quicklists dont have active blur
Changed in unity:
status: New → Confirmed
John Lea (johnlea) on 2011-12-12
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Triaged
tags: added: udp
Changed in unity:
milestone: none → backlog
Tim Penhey (thumper) on 2012-02-08
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
status: Confirmed → Triaged
importance: Undecided → Medium

The new Launcher tooltips suffer the same problem.

summary: - quicklists dont have active blur
+ Quicklists and Launcher tooltips don’t have active blur
Changed in unity (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Daniel van Vugt (vanvugt) wrote :

For tooltips, this bug is fixed by my fix for bug 988079: lp:~vanvugt/unity/regionalDamage

Not yet sure why it doesn't also fix quicklists.

Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)

On Fri, 15 Jun 2012, Daniel van Vugt wrote:

> For tooltips, this bug is fixed by my fix for bug 988079:
> lp:~vanvugt/unity/regionalDamage
>
> Not yet sure why it doesn't also fix quicklists.
>

Hmm, I don't think its really "fixed" by that branch, rather just the
tooltip is being re-rendered completely all the time every time there's
damage underneath it. That still constitutes the usage of
glCopyTexSubImage2D and not doing active blur properly using framebuffer
objects I would think.

> ** Changed in: unity
> Assignee: (unassigned) => Daniel van Vugt (vanvugt)
>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity in Ubuntu.
> https://bugs.launchpad.net/bugs/873387
>
> Title:
> Quicklists and Launcher tooltips don’t have active blur
>
> Status in Ayatana Design:
> Fix Committed
> Status in Unity:
> Triaged
> Status in “unity” package in Ubuntu:
> Triaged
>
> Bug description:
> Hi, if I play some video the background of jumplist doesn't change
>
> To Reproduce:
>
> 1. Start playing a video on the left side of the screen
> 2. Open a quicklist on top of the video
>
> What currently incorrectly happens:
> - The image from the moment the quicklist was opened is 'frozen' into the quiclist
>
>
> Correct desired behaviour:
> - it should be possible to see the playing video through the transparent background of the quicklist.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/873387/+subscriptions
>

I think doing those small blurs in software is proving to be faster than in hardware right now. Certainly I don't see any slowdown redrawing the tooltips this way, but do get a significant slowdown when other /proper/ active blurs are updating.

On Fri, 15 Jun 2012, Daniel van Vugt wrote:

> I think doing those small blurs in software is proving to be faster than
> in hardware right now. Certainly I don't see any slowdown redrawing the
> tooltips this way, but do get a significant slowdown when other /proper/
> active blurs are updating.
>

There will be no slowdown once we merge gles and fbo binds are done just
after glXSwapBuffers

> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity in Ubuntu.
> https://bugs.launchpad.net/bugs/873387
>
> Title:
> Quicklists and Launcher tooltips don’t have active blur
>
> Status in Ayatana Design:
> Fix Committed
> Status in Unity:
> Triaged
> Status in “unity” package in Ubuntu:
> Triaged
>
> Bug description:
> Hi, if I play some video the background of jumplist doesn't change
>
> To Reproduce:
>
> 1. Start playing a video on the left side of the screen
> 2. Open a quicklist on top of the video
>
> What currently incorrectly happens:
> - The image from the moment the quicklist was opened is 'frozen' into the quiclist
>
>
> Correct desired behaviour:
> - it should be possible to see the playing video through the transparent background of the quicklist.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/873387/+subscriptions
>

Splitting this bug in two:

Bug 873387 is for quicklists.
Bug 967112 is for tooltips.

summary: - Quicklists and Launcher tooltips don’t have active blur
+ Quicklists don’t have active blur
Omer Akram (om26er) on 2012-06-27
Changed in unity (Ubuntu):
importance: Low → Medium
John Lea (johnlea) on 2012-10-15
summary: - Quicklists don’t have active blur
+ Launcher - Quicklists don’t have active blur
Changed in unity:
assignee: Daniel van Vugt (vanvugt) → Christopher Townsend (townsend)
milestone: backlog → 7.1.1
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Christopher Townsend (townsend)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.1

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 7.1.0+13.10.20130920-0ubuntu1

---------------
unity (7.1.0+13.10.20130920-0ubuntu1) saucy; urgency=low

  [ Stephen M. Webb ]
  * render the Dash frame all the way to the bottom of the screen (lp:
    #1100120). (LP: #1100120)

  [ Brandon Schaefer ]
  * Ignore mouse movements if the mouse starts over a switcher icon.
    Clicking still works fine, we just wont steal focus from the alt+tab
    work. (LP: #1215630)
  * Make sure we ignore mouse movement over detail icons if the mouse
    starts over it at start. Let the mouse take selection control once
    it moves outside of any icon, vs having to enter a different icon.
    (LP: #1223037, #1223039)
  * Add an option to disable the mouse in the switcher. (LP: #1224048)
  * When the shortcut is open, and we receive a ButtonPress or KeyPress
    hide it. As this causes problems else where, and it really should
    close if the user attempts to do anything (even while holding
    super!). (LP: #932718)
  * Set an upper bound on the amount of icons we go through to check
    tooltips. As the accordion effect was causing the mouse to go
    through the icons to fast, making the test fail.
  * Make sure we move the mouse over the target icon while we are
    dragging the source icon.
  * Get the real shortcut to activate ibus. (LP: #1227056)
  * Only accept focus if the mouse moves in 3 directions on switcher
    start up if the mouse starts over the switcher window. This is an
    attempt to tell the difference between a bump and intentional
    movement. (LP: #1223630)

  [ Marco Trevisan (Treviño) ]
  * DesktopApplicationManager: added new app manager layer so that we
    can emit app events.
  * Application: add desktop_id method, and implement in
    desktop::Application.
  * Launcher: only fade the launcher when in auto-hide and dash is
    opened. (LP: #1223979, #1044926)
  * ApplicationLauncherIcon: log unity zeitgeist events on stick,
    unstick, removal and delete. (LP: #779449)
  * UnityScreen: add support for Super+Arrows shortcuts to manage the
    focused window Super+Arrows shortcut allows to move and maximize /
    restore / minimize the focused window on the screen. (LP: #992697,
    #751050)
  * Launcher: use nux::Animation for all the launcher animations This
    allows to do these when compiz requests to prepare painting, instead
    of using only an idle to perform this. (LP: #1226114, #1224766)
  * ShortcutView: use StaticCairoText instead of StaticText for
    rendering the View Improves the text alignment and visual quality.
  * UnityShell: redraw the dash also if a non-blurred area is damaged If
    the dash is damaged, but not the blurred area, it won't redraw. We
    need to draw it, in order to avoid flickering of its border. Also,
    add the redraw_view_if_damaged utility function to redraw a view if
    really needed. (LP: #1224340)
  * AnimationUtils: add utility functions to handle nux::Animation's
    start and reversion Update the whole code using nux::animation to
    use these facility functions.
  * Launcher: fix style to use postfixed-underscore for private members
    Also remove some tabs and useless members.
  * ...

Read more...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints