Dash/HUD should close on "Spread"

Reported by Alessandro Lazzari on 2011-10-07
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Marco Trevisan (Treviño)
6.0
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Low
Marco Trevisan (Treviño)
Precise
Low
Unassigned

Bug Description

[Test Case]
1. Open a few random apps;
2. Press super key to open dash;
3. Make sure the pointer is positioned over the Dash
4. Press super+W to go in spread mode;
- The Dash should close as soon spread is activated (with super+w)
- Pressing Super+W should perform exactly the same action as pressing the Launcher spread icon while the Dash is open.

[Regression Potential]
Dash hiding when not expected to.

Original description:

1. Open a few random apps;
2. Press super key to open dash;
3. Make sure the pointer is positioned over the Dash
4. Press super+W to go in spread mode;

What happens
- the spread for the opened windows is activated behind the dash

What should happen:
- The Dash should close as soon spread is activated (with super+w)
- Pressing Super+W should perform exactly the same action as pressing the Launcher spread icon while the Dash is open.

This is happening in current oneiric snapshot.
Shouldn't it mimic natty's behaviour, where spread mode is disabled when dash is open?

summary: - dash blur doesn't update when using spread mode
+ Dash blur doesn't update when using spread mode in oneiric.
Omer Akram (om26er) on 2011-10-08
summary: - Dash blur doesn't update when using spread mode in oneiric.
+ Dash should close on "Spread"
Changed in unity:
importance: Undecided → Low
description: updated
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
tags: added: bitesize
John Lea (johnlea) on 2011-10-11
tags: added: onew udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Fix Committed
description: updated
John Lea (johnlea) on 2011-10-18
Changed in unity:
milestone: none → backlog
tags: added: udp
Changed in ayatana-design:
status: Fix Committed → Triaged

As of unity 4.24.0 this is fixed. Marking it as "Fix Released".

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
John Lea (johnlea) on 2011-11-02
description: updated
Mirco Müller (macslow) on 2011-11-02
Changed in unity:
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Changed in unity:
assignee: nobody → Mirco Müller (macslow)
John Lea (johnlea) on 2011-11-02
Changed in ayatana-design:
status: Triaged → Fix Committed
Mirco Müller (macslow) wrote :

The issue is not fully fixed. Only when the mouse is _not_ over the dash it closes as expected. When the mouse-pointer is over the dash and spread is triggered via Super-W the dash stays open, which is not what we want.

Omer Akram (om26er) wrote :

The bug is still there for me. I have updated the description.

description: updated

The bug is not fixed for me neither, regardless of mouse position.

Omer Akram (om26er) wrote :

oops sorry mid-air collision

description: updated
Mirco Müller (macslow) on 2012-01-12
Changed in unity:
status: Confirmed → In Progress
Omer Akram (om26er) on 2012-01-12
Changed in unity:
milestone: backlog → 5.0.0
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Mirco Müller (macslow) wrote :

As of unity trunk (revision 1826, 12.1.2012) this is fixed. Marking it as "Fix Committed".

Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.0.0-0ubuntu1

---------------
unity (5.0.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release.
    - compiz crashed with SIGSEGV in __dynamic_cast() (LP: #853038)
    - unity-panel-service crashed with SIGSEGV in panel_service_show_entry()
      (LP: #861144)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() (LP: #869816)
    - Launcher - Launcher icon for Dash does not highlight when the Alt+F1 key
      shortcut is pressed (LP: #849561)
    - compiz crashed with SIGSEGV in unity::PanelTray::FilterTrayCallback()
      (LP: #868868)
    - [regression] Compiz: Visible tearing is worse in 11.10 than 11.04, even
      when "Sync To VBlank" is enabled, but only when Unity is active.
      (LP: #880707)
    - [regression] All apps have a lower frame rate under Unity. (LP: #861061)
    - compiz crashed with SIGSEGV in
      nux::Property<nux::color::Color>::operator=() from
      unity::switcher::SwitcherController::OnBackgroundUpdate() (LP: #887465)
    - DashSearchBarSpinner.cpp:56: Conditional jump or move depends on
      uninitialised value(s) (LP: #901610)
    - quicklist shows in incorrect position when launched from workspace
      switcher (LP: #914251)
    - Build "show me the desktop" mini-app that adds a show desktop button to
      Launcher (LP: #681348)
    - Select quicklist items with just one right click (LP: #688830)
    - cannot change volume by scrolling on the icon when the SoundMenu is
      opened (LP: #722082)
    - [a11y] Unity launcher buttons are not Actionable (LP: #772573)
    - Ubuntu Start launcher item doesn't start dash with keyboard navigation
      (LP: #825037)
    - multimonitor , window management - Multi-Monitor Maximized Difficulty
      (LP: #843958)
    - [regression] Drag and drop inside dash is very slow with Active Blur
      activated (LP: #851172)
    - Activating an alt-tab icon that holds initially unminimized windows
      should unminimize all windows (LP: #854595)
    - Dash - The Dash category headers are positioned incorrectly
      (LP: #839467)
    - Missing global menu with a semi-maximized window dragged to the right.
      (LP: #861279)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - top bar, integrated menu - when a application is first launched, the
      integrated menu should be displayed for 2 seconds before fading out of
      view (LP: #874254)
    - Window control buttons are not shown when an indicator is opened and the
      pointer is over the top-left corner (LP: #890970)
    - Quicklist item using some special chars doesn't show at all
      (LP: #899677)
    - PanelView.cpp:370: Conditional jump or move depends on uninitialised
      value(s) (LP: #901602)
    - unityshell.cpp:1982,1984: Conditional jump or move depends on
      uninitialised value(s) (LP: #901603)
    - Dash Search spinner sometimes doesn't spin at all (LP: #903090)
    - Point of tooltip is misaligned to focused ap...

Read more...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Tim Penhey (thumper) on 2012-02-01
Changed in unity:
importance: Low → Medium
status: Fix Released → Triaged
milestone: 5.0.0 → 5.4.0
Mirco Müller (macslow) on 2012-02-15
Changed in unity:
status: Triaged → In Progress
Omer Akram (om26er) on 2012-02-17
Changed in unity (Ubuntu):
status: Fix Released → In Progress
importance: Low → Medium
Didier Roche (didrocks) on 2012-02-17
Changed in unity:
milestone: 5.4.0 → 5.6.0
Mirco Müller (macslow) on 2012-02-29
Changed in unity:
status: In Progress → Triaged
Changed in unity (Ubuntu):
status: In Progress → Triaged
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: 5.10.0 → 5.12.0
Mirco Müller (macslow) on 2012-04-20
Changed in unity:
assignee: Mirco Müller (macslow) → nobody
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: 5.12.0 → 5.14.0
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
summary: - Dash should close on "Spread"
+ Dash/HUD should close on "Spread"
Robert Dyer (psybers) wrote :

Note that this also affects the HUD. Press ALT to bring up HUD, then press the keys to spread windows (Super+W) and it will (un)spread behind the HUD. It also types a 'w' into the HUD. Most likely, HUD should hide when the spread happens.

True, for the "w", thing see the more general bug #1013751

Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Triaged → In Progress
Changed in unity:
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
no longer affects: unity/6.0
Changed in unity:
milestone: 5.14.0 → 6.0
milestone: 6.0 → 5.6.0
no longer affects: unity/5.0
Daniel van Vugt (vanvugt) wrote :

I think you meant 5.14, not 5.6.

Changed in unity:
milestone: 5.6.0 → 5.14.0
Changed in unity (Ubuntu Precise):
status: New → Incomplete
Changed in unity (Ubuntu):
importance: Medium → Low
Changed in unity (Ubuntu Precise):
status: Incomplete → In Progress
importance: Undecided → Low

Hello Alessandro, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Alan Pope ㋛ (popey) on 2012-07-24
tags: added: verification-done
removed: verification-needed
description: updated
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity - 5.14.0-0ubuntu1

---------------
unity (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Unity launcher shows internal partitions after they have been unmounted
      (LP: #994163)
    - can't click to dismiss hud in the area where dynamic hud results are
      meant to appear (LP: #962651)
    - Spread/Scale should exit if Dash is invoked (LP: #944033)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dash - The search bar gets the focus when pressing invalid keys
      (LP: #931393)
    - unity crashed with NameError in reset_unity_compiz_profile(): global name
      'GError' is not defined (LP: #778470)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      from unity::UnityWindow::glPaint() (LP: #851982)
    - "Keyboard Shortcuts" overlay can cause annoyance (LP: #934062)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - HUD Draws improperly while searching for results (LP: #932531)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold (LP: #839717)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - dash should open when pressing "super" in scale mode (LP: #1023811)
    - Multimonitor, Launcher - When the Launcher is set to autohide and
      'Sticky edges' are turned off, 'Launcher Edge Stop Overcome Pressure'
      seems to be broken when revealing the Launcher (LP: #987955)
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - Regression: shift+click on a launcher icon to open a new application
      instance gone (LP: #754565)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Duplicated applications icons on quick application restart (LP: #1003574)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - alt-backtick flickers between windows (LP: #987156)
    - [Hud] The result grid is not drawn in proximity of the search entry
      (LP: #1008603)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - [hud] The last button is not rounded (LP: #1008656)
    - Hud flickers when show up (LP: #1011507)
    - Dash maximise button changed location (LP: #987674)
    - launcher reordering "line" doesn't go to the bottom slot (LP: #971421)
    - Dash/HUD should close on "Spread" (LP: #870284)
    - Nothing should be written into the dash/hud searchbar whe...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Cruz Bishop (cruzjbishop) wrote :

This has been fixed.

Changed in ayatana-design:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released

Please do not change status on bugs on Ayatana Design. Thanks!

Changed in ayatana-design:
status: Fix Released → Fix Committed
Changed in ayatana-design:
status: Fix Committed → Won't Fix
status: Won't Fix → Fix Released
tags: added: reviewedbydesignq
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers