Top Bar should have the title "Workspace Switcher" when the WS switcher is open (Super+S)

Reported by Andrea Virgillito on 2011-10-06
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
One Hundred Papercuts
Medium
Unassigned
Unity
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)

Bug Description

1. open a window e.g. terminal
2. click WS switcher in the launcher or press super+s

What happens
the panel shows the title(or name) of the last focused window

----------------------------------

What should happen:

The panel should say "Workspace Switcher"

summary: - Put "Workspace switcher" in the desktop title when switcher option in
- the Dash (or keyboard combo) is enabled
+ Put "Workspace switcher" in the panel title when switcher option in the
+ Dash (or keyboard combo) is enabled

Actually in my setup, If you invoke the Workspace Switcher, the panel stays with the tittle of the last focused application. Not sure if this is a bug or a design choice.

Changed in ayatana-design:
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Andrea Virgillito (andrea900) wrote :

Nicolas you're right. My mistake, sorry :)

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Changed in ayatana-design:
status: Confirmed → New
summary: - Put "Workspace switcher" in the panel title when switcher option in the
- Dash (or keyboard combo) is enabled
+ Panel should have the title "Worspace Swither" when the WS switcher is
+ clicked
description: updated
summary: - Panel should have the title "Worspace Swither" when the WS switcher is
+ Panel should have the title "Workspace Swither" when the WS switcher is
clicked
summary: Panel should have the title "Workspace Swither" when the WS switcher is
- clicked
+ clicked (Super+S)
John Lea (johnlea) on 2011-10-11
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Confirmed
status: Confirmed → Fix Committed
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
tags: added: onew udo
John Lea (johnlea) on 2011-10-11
summary: - Panel should have the title "Workspace Swither" when the WS switcher is
- clicked (Super+S)
+ Top Bar should have the title "Workspace Swither" when the WS switcher
+ is open (Super+S)
summary: - Top Bar should have the title "Workspace Swither" when the WS switcher
+ Top Bar should have the title "Workspace Switcher" when the WS switcher
is open (Super+S)
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Committed → Triaged
John Lea (johnlea) on 2011-11-03
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Medium
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
importance: Undecided → Medium
Andrea Virgillito (andrea900) wrote :

It will be fixed in time for Precise?

Changed in hundredpapercuts:
status: New → Confirmed
Andrea Virgillito (andrea900) wrote :

I've added a screenshot to underline another issue: appmenu remains active when the WS is selected, but it doesn't work at all.

Andrea Virgillito (andrea900) wrote :

I'll change the bug status to "In Progress".
In the latest builds of Unity i saw that, when i pressed the WS selector button in the Springboard, the title in the panel returned to be "Ubuntu Desktop" (not Workspace Switcher), even with a focused window in the desktop.

Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in hundredpapercuts:
status: Confirmed → In Progress
Changed in unity:
status: Confirmed → In Progress
Timothy Arceri (t-fridey) wrote :

In 12.04 it now says "Ubuntu Desktop" is this the intended fix or does it need to say "Workspace Switcher"?

Andrea Virgillito (andrea900) wrote :

It's the same for me.
We could change the bug status to "Fix Released".

Chris Wilson (notgary) on 2012-06-18
Changed in hundredpapercuts:
importance: Undecided → Medium
Chris Wilson (notgary) wrote :

What's the progress on this fix?

Omer Akram (om26er) on 2012-08-05
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
Changed in hundredpapercuts:
status: In Progress → Confirmed
Changed in unity:
status: In Progress → Confirmed
John Lea (johnlea) on 2012-08-07
Changed in hundredpapercuts:
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Chris Wilson (notgary) on 2012-08-08
Changed in hundredpapercuts:
milestone: none → quantal-5-unity
Leonardo Donelli (learts92) wrote :

The panel reports "Ubuntu Desktop" in 13.04 ( Unity 7.0.0daily13.04.18~13.04-0ubuntu1, default version)
Shouldn't be this marked as fixed?

Changed in unity:
status: Triaged → Fix Released
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
status: Triaged → Fix Released
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers