closing a window gives focus to last minimized window

Bug #862719 reported by Omer Akram
76
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Compiz Core
High
Sam Spilsbury
Unity
Fix Released
High
Sam Spilsbury
compiz (Ubuntu)
High
Sam Spilsbury
unity (Ubuntu)
High
Unassigned

Bug Description

unity 4.20.0-0ubuntu1

1. start gnome-terminal
2. start nautilus
3. minimize nautilus
4. close gnome-terminal

What happens
unity panel shows that nautilus is in focus

What should happen nautilus should not get focused.
the app behind gnome-terminal should be focused

Omer Akram (om26er)
Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → ubuntu-11.10
description: updated
Revision history for this message
eric (obrowny06) wrote :

1. start gnome-terminal
2. start firefox
3. minimize firefox
4. close gnome-terminal

Firefox has the focus and you can't restore firefox by clicking on the launcher nor the window buttons.

To be able to restore firefox you need to click the desktop to give it focus and then you are able to restore firefox.

Moreover then firefox is restored on the right hand side of the desktop.

video attached

Revision history for this message
Sam Spilsbury (smspillaz) wrote :

I guess there's still this case which isn't fixed yet. I'll look into it monday.

Changed in compiz-core:
status: New → In Progress
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in compiz-core:
importance: Undecided → High
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.6
Didier Roche (didrocks)
Changed in unity:
status: In Progress → Fix Released
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz-core:
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.6+bzr20110929-0ubuntu2

---------------
compiz (1:0.9.6+bzr20110929-0ubuntu2) oneiric; urgency=low

  * debian/patches/02_fix_autofocus_minimize_window.patch:
    - closing a window gives focus to last minimized window (LP: #862719)
  * debian/patches/03_fix_configureframe.patch:
    - compiz crashed with SIGSEGV in PrivateWindow::configureFrame()
      (LP: #861909)
 -- Didier Roche <email address hidden> Tue, 04 Oct 2011 08:29:38 +0200

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Changed in unity (Ubuntu):
importance: Undecided → High
Revision history for this message
Seth Johnson (sethj) wrote :

Thank you for taking the time to report this bug. We have tried to recreate this on the latest release of Ubuntu and cannot reproduce it. This bug is being marked as Invalid. If you believe the problem to still exist in the latest version of Ubuntu please comment on why that is the case and change the bug status to NEW.

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments