No startup notification when launching applications

Bug #862662 reported by Ric Flomag on 2011-09-29
120
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Light Display Manager
Undecided
Unassigned
Unity
Wishlist
Unassigned
lightdm (Ubuntu)
Oneiric
Low
Unassigned
Precise
Low
Unassigned
openbox (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Steps to reproduce:
 * open a file browser
 * double-click a file to launch its associated app
Or:
 * open Unity file lens
 * clic a file to launch its associated app
Or:
 * open Shotwell, select a photo
 * choose "Open in external editor" to launch your favorite photo editor.
Or:
 * in lubuntu lxde desktop, launch an app from the desktop menu.

Observed:
 * the associated application starts, but the user does not know until its window eventually opens. It might last a fraction of a second (lucky you), or up to ten seconds. You might have deseperatly repeated the action twice or more until then ;)

Expected:
 * some notification immediately informs the user that the app is being launched.

This is a regression, though in previous versions of ubuntu, a spinning cursor was displayed as a notificaction, but only gtk+ applications had it, other (libreoffice, qt apps) didn't (bug #798304, marked as duplicate).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: nautilus 1:3.2.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Thu Sep 29 14:36:03 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Ric Flomag (ricflomag) wrote :
tags: added: regression-release
summary: - No busy cursor when opening files
+ no startup notification when opening files
Changed in nautilus (Ubuntu):
status: New → Confirmed
importance: Undecided → Low

Sebastien,

Thank you for the triaging. I wished this bug had a higher importance though. It might be a detail on fast computers, but on lower end or aging ones, it is really a pain, specially for newcomers.

Sebastien Bacher (seb128) wrote :

there you go ;-)

Changed in nautilus (Ubuntu):
importance: Low → High
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
 https://bugzilla.gnome.org/show_bug.cgi?id=660577

Raising the importance doesn't make any difference, the importance should be low, please refer to https://wiki.ubuntu.com/Bugs/Importances . Thanks.

Changed in nautilus (Ubuntu):
importance: High → Low
status: Confirmed → Triaged
Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Changed in nautilus (Ubuntu Oneiric):
status: Triaged → Won't Fix
Ric Flomag (ricflomag) on 2012-05-23
no longer affects: nautilus (Ubuntu)
affects: nautilus → unity
Changed in unity:
importance: Medium → Undecided
Sebastien Bacher (seb128) wrote :

Ric, don't change status without explanation

affects: unity → nautilus
Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
Sebastien Bacher (seb128) wrote :

that doesn't need design input either, it's a bug

no longer affects: ayatana-ubuntu
Ric Flomag (ricflomag) wrote :

Changing the realm of this bug: it is not a nautilus bug, but a general design bug which affects every desktop i use (unity, gnome, lxde, gnome fallback).

We do not have a startup notification mechanism when applications are launched indirectly (from file browsers, unity lenses, from other app: see the updated description of the bug).

Specially on low to middle range computers, this is really annoying, as most apps last several seconds to start, which is enough time for a user to wonder if the app would eventually start, and repeat her action again and again until three or more windows open :)

affects: nautilus → unity
Changed in unity:
importance: Unknown → Undecided
status: Unknown → New
Ric Flomag (ricflomag) on 2012-05-23
description: updated
summary: - no startup notification when opening files
+ No startup notification when launching applications
Ric Flomag (ricflomag) wrote :

Sebastien: I changed the status before explaining why, sorry, wrong order.

I do believe this needs design input. Unity needs a startup notification mechanism. The busy cursor was one, though it was not perfect. I *suppose* that it has been removed for a reason. The problem is that it has not been replaced by another, better startup notification mechanism in Unity.

Is there a better place than this bug for discussing a consistent, global application startup notification mechanism ?

Inoe (inoe-oke) wrote :

I noticed that in the live session (Oneiric, Precise), the busy cursor works well. Is there a way to enable it?
The lack of startup notification really is a problem, moreover, when other person is using our machine.

Omer Akram (om26er) on 2012-05-28
Changed in unity:
importance: Undecided → Wishlist
status: New → Opinion
Ric Flomag (ricflomag) wrote :

Under a "guest" session (unity, ubuntu 12.10), GTK applications do trigger the busy cursor when opening a file from nautilus or the dash. So does a live session, as mentionned there:
http://askubuntu.com/questions/126872/how-to-get-the-lost-busy-cursor-when-opening-file-app-back, in live sessions

So I suppose that the package "startup-notification" is affected. It seems that the maintener of the package, Josselin Mouette, is not active anymore though.

Ric Flomag (ricflomag) on 2012-12-31
affects: nautilus (Ubuntu Precise) → startup-notification (Ubuntu Precise)
Ric Flomag (ricflomag) wrote :

Some more testing showed that the spinning cursor is displayed only for user sessions that don't need a password to login. That is:
 * a live session.
 * a guest session.
 * a user with a blank password.
 * a user with automatic login activated (only if one does not log out then log back in, in which case a password is required).

Moreover, if gdm is used instead of lightdm, the spinning cursor is displayed independently of the way the user logs in.

Marking lightdm as the affected package.

Any clue of a possible reason why lightdm would cause this bug ?

affects: startup-notification (Ubuntu Precise) → lightdm (Ubuntu Precise)

It's not lightdm. Nor any display manager.

I start the session using dbus-launch from .xinitrc and there's no busy cursor.

I wonder if I may help in such a way...

k9_einzwei (k9-einzwei) wrote :

Solution for GNOME : replacing Metacity with Kwin will enabling startup notification
Or for XFCE : replacing XFWM with Kwin will enabling startup notification
Or for LXDE : replacing Openbox with Kwin will enabling startup notification

Source : http://ubuntuforums.org/showthread.php?t=2154613&p=12692138

LStranger (andrej-rep) wrote :

The bug is still present in Openbox for 13.10.
There is a patch for Openbox to fix this, see this mail - http://icculus.org/pipermail/openbox/2013-July/008059.html

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openbox - 3.5.2-3

---------------
openbox (3.5.2-3) unstable; urgency=low

  * debian/control:
    + fix typo in depends openbox-dev package.

 -- Mateusz Łukasik <email address hidden> Mon, 07 Oct 2013 14:58:17 +0200

Changed in openbox (Ubuntu):
status: New → Fix Released
livram79 (livram79) wrote :

It seems that this bug is still present in LUBUNTU 14.04. Openbox version 3.5.2

robertomrc (marchesinroberto) wrote :

I have the same problem on Lubuntu.

In my honest opinion, it's not a lower bug, but at least MEDIUM!

In fact, Lubuntu often goes on older systems, and when you launch the application and did not see anything happen, may confuse the user and lead the user to press over and over again to start the application.

Really bad ....

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openbox (Ubuntu Oneiric):
status: New → Confirmed
Changed in openbox (Ubuntu Precise):
status: New → Confirmed
Plurtu (kestrel-b) wrote :

Still a situation of click & pray in Lubuntu 13.10 with openbox 3.5.2-3.

Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in openbox (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Ric Flomag (ricflomag) wrote :

Bug still present in Trusty and Utopic. Assigning to lightdm independently of ubuntu version.

Ric Flomag (ricflomag) wrote :

A partial workaround : install package lightdm-gtk-greeter. This will enable startup notifications (spining cursor) for GTK+ apps launched from the dash or opening an associated file. But Qt apps will still lack a startup notification.

source : http://ubuntuforums.org/showthread.php?t=2239534

laci357 (laci357) wrote :

Hi everyone,

this bug is still on in LXDE 14.04, though the latest version of 'lightdm-gtk-greeter' is present by default.

It would be great to have it fixed.

God bless you all!

laci357 (laci357) wrote :

it's LXLE, not LXDE

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers