Dash - "Apps Available for Download" recommends a program that is already installed

Bug #858056 reported by Hernando Torque on 2011-09-24
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Michal Hruby
unity-2d
Undecided
Unassigned
unity-lens-applications
Undecided
Michal Hruby
unity (Ubuntu)
Medium
Michal Hruby
Oneiric
Medium
Michal Hruby
unity-lens-applications (Ubuntu)
Medium
Michal Hruby
Oneiric
Medium
Michal Hruby

Bug Description

There are still duplicates to be found in the Installed and Available categories in Applications lens.

Steps to reproduce:
1) Open the Application lens
2) Search for a KDE-based application in the dash (which is installed on the system - for example Kate)
3) The application is in both Installed & Available cateogries - it should be only in Installed

Hernando Torque (htorque) wrote :
Omer Akram (om26er) on 2011-09-25
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity-lens-applications (Ubuntu):
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
Changed in unity-lens-applications:
status: New → Confirmed
Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
Changed in unity (Ubuntu):
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
Changed in unity-lens-applications (Ubuntu):
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d:
status: New → Confirmed
Michal Hruby (mhr3) on 2011-10-05
Changed in unity:
milestone: none → 4.24.0
assignee: Mikkel Kamstrup Erlandsen (kamstrup) → Michal Hruby (mhr3)
Changed in unity (Ubuntu):
assignee: Mikkel Kamstrup Erlandsen (kamstrup) → Michal Hruby (mhr3)
Changed in unity-lens-applications (Ubuntu):
assignee: Mikkel Kamstrup Erlandsen (kamstrup) → Michal Hruby (mhr3)
Changed in unity-lens-applications:
status: Confirmed → Fix Committed
Changed in unity-2d:
status: Confirmed → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Michal Hruby (mhr3) on 2011-10-06
Changed in unity-lens-applications:
milestone: none → 0.4.12
assignee: nobody → Michal Hruby (mhr3)
Michal Hruby (mhr3) on 2011-10-06
Changed in unity-lens-applications:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-10-06
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 0.4.12-0ubuntu1

---------------
unity-lens-applications (0.4.12-0ubuntu1) oneiric; urgency=low

  [ Paul Sladen ]
  * debian/control: Description: grammar 'into'->'inside'

  [ Didier Roche ]
  * New upstream release.
    - UIFe: download icon: the 'rosette with exclamation mark' next to
      "Apps for Download" becomes a 'circle with a downwards arrow'.
      (LP: #850714)
    - Make sure we don't update the model too soon, otherwise Dash flickers
      (LP: #868192)
    - Dash - "Apps Available for Download" recommends a program that is
      already installed (LP: #858056)
    - Dash: Cannot drag application from 'Most Frquently Used' section to
      desktop (LP: #864016)
 -- Didier Roche <email address hidden> Thu, 06 Oct 2011 14:32:48 +0200

Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Fix Released
Hernando Torque (htorque) wrote :

There still seems to be a problem: two installed KDE applications were shown (Kate and Kile, which had a different icon), and also Unity 2D came up when searching for "Unity". All showed up as "Installed" in the Software Center when clicking on the icons.

Changed in unity-lens-applications (Ubuntu):
status: Fix Released → New
Michal Hruby (mhr3) on 2011-10-07
Changed in unity-lens-applications:
status: Fix Released → In Progress
milestone: 0.4.12 → 0.4.14
Changed in unity:
status: Fix Released → In Progress
Michal Hruby (mhr3) wrote :

We fixed this for KDE apps, but there are still some instances where we'll get a dupe (like Unity2d) because of SC's use of meta-packages.

Changed in unity-lens-applications:
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-10-12
affects: unity (Ubuntu) → ubuntu
Michal Hruby (mhr3) on 2011-10-12
description: updated
description: updated
Didier Roche (didrocks) on 2011-10-14
Changed in unity:
status: Fix Committed → Fix Released

Hello Hernando, or anyone else affected,

Accepted unity-lens-applications into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity-lens-applications (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Hernando Torque (htorque) wrote :

Confirming, fixed for KDE programs.

Martin Pitt (pitti) on 2011-10-14
tags: added: verification-done
removed: verification-needed
Didier Roche (didrocks) on 2011-10-17
Changed in unity-lens-applications:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 0.4.12-0ubuntu2

---------------
unity-lens-applications (0.4.12-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - Dash - "Apps Available for Download" recommends a program that is
      already installed (LP: #858056)
 -- Didier Roche <email address hidden> Fri, 14 Oct 2011 10:56:04 +0200

Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-lens-applications (Ubuntu Oneiric):
status: Fix Committed → Fix Released
affects: ubuntu → unity (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments