[regression] Drag and drop inside dash is very slow with Active Blur activated

Reported by Andrea Azzarone on 2011-09-15
78
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Andrea Azzarone
unity (Ubuntu)
Medium
Andrea Azzarone

Bug Description

With last updates drag and drop inside dash is very slow with "Active Blur" activated. No problem with "No blur".

Related branches

lp:~andyrock/unity/fix-851172
Merged into lp:unity at revision 1747
Tim Penhey (community): Approve on 2011-11-24
Marco Biscaro (community): Approve on 2011-11-23
Daniel van Vugt: Approve on 2011-11-22
Changed in unity:
status: New → Confirmed
Andrea Azzarone (andyrock) wrote :
Omer Akram (om26er) on 2011-09-15
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2011-10-15
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Daniel van Vugt (vanvugt) wrote :

I have a theory this bug probably has the same root cause as bug 861061, and might be solved by the same fix (when one exists).

tags: added: oneiric regression-release
Andrea Azzarone (andyrock) wrote :

@Daniel
I can partially fix this bug... I mean unity should not update the blur if the damage event is caused by the dnd source icon window.

Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Daniel van Vugt (vanvugt) wrote :

Andrea, your fix sounds correct.

The fix for bug 861061 does not solve this bug. But be careful your fix doesn't conflict too much with the fix for bug 861061:
https://code.launchpad.net/~vanvugt/unity/fix-861061-trunk/+merge/82861
because it's the same area of code (blur damage handling).

Daniel van Vugt (vanvugt) wrote :

Oh, I just saw your proposal and it won't conflict. Will test it soon (!)...

summary: - Drag and drop inside dash is very slow with Active Blur activated
+ [regression] Drag and drop inside dash is very slow with Active Blur
+ activated
Andrea Azzarone (andyrock) wrote :

@Daniel
This is a partially fix. If during the dnd the dash is forced to update the dnd is still slow (slower than before but slow). If I'm not wrong this is because handling xdnd events and "blur computation" is done in the same thread.

Andrea Azzarone (andyrock) wrote :

*are done

Daniel van Vugt (vanvugt) wrote :

Understood. The slowness of the active blur code in oneiric has caused multiple bugs; 861061, 880707...

But I don't think we should aim to put it in a thread just because it is slow. In a thread it will still use up the same (too much) CPU/GPU. Instead we should aim to make it fast.

I do wonder why Unity requires hardware shaders (to draw icons !?), and yet when it's really really important to have fast hardware shading we use a slow blurring method that has severe impact in multiple components :(

Andrea Azzarone (andyrock) wrote :

It's use a same CPU/GPU but if it's possible we can continue to handling x event and for instance we can properly update dnd source window position. But I don't know it 's possible because I've not study unity blur too much :)

Andrea Azzarone (andyrock) wrote :

*It uses... :/

Daniel van Vugt (vanvugt) wrote :

Root causes aside, I think your fix for this bug is a good one and should be merged ASAP :)

Bug is still present in Precise Alpha 1.

Daniel van Vugt (vanvugt) wrote :

Yes the bug is still present because the fix has not been committed yet. When the fix reaches an alpha build, the Status in "unity (Ubuntu)" will say "Fix Released".

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed

I just installed compizconfig-settings-manager and tried out the different blur options in the Unity plugin, and found that while active blur produces the worst lag, I still get some noticeable lag and icons slowly trailing behind my mouse cursor with static blur or even no blurring selected. Is this an issue that would still fall under this bug, or is it some other problem I should file a new report for?

Daniel van Vugt (vanvugt) wrote :

Yes I expect you might still see lag with static or no blur. That would be a combination of this bug and the general performance bug 861061.

Omer Akram (om26er) on 2011-12-08
Changed in unity:
milestone: none → 5.0.0
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.0.0-0ubuntu1

---------------
unity (5.0.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release.
    - compiz crashed with SIGSEGV in __dynamic_cast() (LP: #853038)
    - unity-panel-service crashed with SIGSEGV in panel_service_show_entry()
      (LP: #861144)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() (LP: #869816)
    - Launcher - Launcher icon for Dash does not highlight when the Alt+F1 key
      shortcut is pressed (LP: #849561)
    - compiz crashed with SIGSEGV in unity::PanelTray::FilterTrayCallback()
      (LP: #868868)
    - [regression] Compiz: Visible tearing is worse in 11.10 than 11.04, even
      when "Sync To VBlank" is enabled, but only when Unity is active.
      (LP: #880707)
    - [regression] All apps have a lower frame rate under Unity. (LP: #861061)
    - compiz crashed with SIGSEGV in
      nux::Property<nux::color::Color>::operator=() from
      unity::switcher::SwitcherController::OnBackgroundUpdate() (LP: #887465)
    - DashSearchBarSpinner.cpp:56: Conditional jump or move depends on
      uninitialised value(s) (LP: #901610)
    - quicklist shows in incorrect position when launched from workspace
      switcher (LP: #914251)
    - Build "show me the desktop" mini-app that adds a show desktop button to
      Launcher (LP: #681348)
    - Select quicklist items with just one right click (LP: #688830)
    - cannot change volume by scrolling on the icon when the SoundMenu is
      opened (LP: #722082)
    - [a11y] Unity launcher buttons are not Actionable (LP: #772573)
    - Ubuntu Start launcher item doesn't start dash with keyboard navigation
      (LP: #825037)
    - multimonitor , window management - Multi-Monitor Maximized Difficulty
      (LP: #843958)
    - [regression] Drag and drop inside dash is very slow with Active Blur
      activated (LP: #851172)
    - Activating an alt-tab icon that holds initially unminimized windows
      should unminimize all windows (LP: #854595)
    - Dash - The Dash category headers are positioned incorrectly
      (LP: #839467)
    - Missing global menu with a semi-maximized window dragged to the right.
      (LP: #861279)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - top bar, integrated menu - when a application is first launched, the
      integrated menu should be displayed for 2 seconds before fading out of
      view (LP: #874254)
    - Window control buttons are not shown when an indicator is opened and the
      pointer is over the top-left corner (LP: #890970)
    - Quicklist item using some special chars doesn't show at all
      (LP: #899677)
    - PanelView.cpp:370: Conditional jump or move depends on uninitialised
      value(s) (LP: #901602)
    - unityshell.cpp:1982,1984: Conditional jump or move depends on
      uninitialised value(s) (LP: #901603)
    - Dash Search spinner sometimes doesn't spin at all (LP: #903090)
    - Point of tooltip is misaligned to focused ap...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

That's interesting. This bug seems to be solved in unity 4.28 with Sam's big-fbo changes. Even though Andrea's fix for this bug is not in 4.28. It should be even faster in 5.0 where both fixes are present...

tadas (astiktrumpam) wrote :

This bug still exists in 13.04, 13.10 and 14.04 with intel graphics ... Not fixed yet ??? Cmon, a little blurry window lags more than running 10 games at the same time ...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments