(oneiric) menu bar in wrong place and invisible

Bug #845856 reported by Jane Silber on 2011-09-09
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Matthew Paul Thomas
Unity
Fix Released
High
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Oneiric
High
Marco Trevisan (Treviño)

Bug Description

==== SRU Testing ====

- Installed unity 4.24.0 from oneiric-proposed (when it's available)
- Restart your session (logout/login)
- Make sure you have two monitors to test on and both are enabled and *not* in mirror mode. Additionally, make them different sizes (i.e. 1280x800 and 1024x768).
- Confirm you have a panel on both monitors, and the panel works as expected with appmenus and indicator menus.
- Try vertical monitor setup (one above the other), confirm you still have two fully working panels
- In both cases, make sure that at least one panel is showing you the name of the active window, including allowing you to access it's menus. Move the window between monitors to confirm unity is tracking the changes correctly.

=====================

I am running Oneiric Beta 1 on a laptop with an external monitor.

When I have an application on the external monitor, and when it has focus, I expect to see the menu bar on that monitor as the global menu. The app name does appear in the upper left as expected, but even when I move the mouse up there, the menu bar doesn't appear. However, the menu bar is active on the laptop screen but it is unusable because the menu bar doesn't actually appear. If you click where the menu bar should be, you get the drop down menus. But the "File", "Edit", etc don't actually appear.

So,
- the app name appears in the upper left of the correct screen, but the menu bar doesn't
- the menu bar doesn't appear on the wrong screen, but it acts as if it's there (i.e,. you can use the menus)

Expected behaviour:
- the menu bar appears on the screen that is displaying the app
- it actually appears when mouse is there

Related branches

Omer Akram (om26er) on 2011-09-11
tags: added: multimonitor
Jane Silber (silbs) wrote :

The original entry reported this as happening one way (i.e,. window on external monitor, invisible menu on laptop screen). I am now experiencing it the other way around (i.e., window on laptop screen, invisible menu on the external monitor).

David Barth (dbarth) wrote :

Adding ayatana-design to ensure that this case is not the result of conflicting guidelines (ie a bug, not a "feature").

David Barth (dbarth) wrote :

I agree that this behaviour is confusing however

@Neil: is that particular indicator (appmenu) one that can be positioned specifically on the unity-panel, for this bug to be fixed?

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 4.18.0
importance: Undecided → Medium
status: New → Triaged

Even if it is an explicit design decision to put it in the unexpected
place, there is definitely a bug in that the menu doesn't actually
appear. It is there (i.e,. if you click around and try to guess where a
menu should be, you can activate it. But it isn't visibly rendered).

Matthew Paul Thomas (mpt) wrote :

<https://wiki.ubuntu.com/MenuBar#Presence>: "The menu bar should appear at the top of every screen, except those screens where a window is currently in full-screen mode."

<https://wiki.ubuntu.com/MenuBar#Windows_with_recognized_menus>: "Where the active window has its own menus in a menu bar in a supported toolkit, these menus should be presented in the menu bar..."

So, it's not a design decision to put the menus on one display or another. They should be available on every display that has a menu bar.

Changed in ayatana-design:
assignee: nobody → Matthew Paul Thomas (mpt)
status: New → Fix Released
Neil J. Patel (njpatel) wrote :

It's a regression that was on my fix-list but I can't find the bug for some reason. Using this one as the tracker.

Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in unity (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
assignee: nobody → Neil J. Patel (njpatel)
tags: added: regression-release
tags: added: rls-mgr-o-tracking
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
milestone: 4.18.0 → 4.20.0
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
milestone: 4.20.0 → 4.22.0
shadow (arnyek) wrote :

Since yesterday's update I can't see menu bar on my left side monitor only on the right side (dualscreen). This is affect only ubuntu-2d. Ubuntu-3d works well.
See attached screenshot.

Didier Roche (didrocks) on 2011-10-04
Changed in unity:
milestone: 4.22.0 → 4.24.0
Changed in unity (Ubuntu Oneiric):
milestone: ubuntu-11.10 → oneiric-updates

This should be fixed by this commit in unity-3d I guess.

Please check: http://bazaar.launchpad.net/~3v1n0/unity/fix-multiscreen-indicators-geometries/revision/1705

Changed in unity:
assignee: Neil J. Patel (njpatel) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu Oneiric):
assignee: Neil J. Patel (njpatel) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu Oneiric):
status: Triaged → In Progress
Neil J. Patel (njpatel) on 2011-10-11
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu Oneiric):
status: In Progress → Fix Committed
Neil J. Patel (njpatel) on 2011-10-12
description: updated
description: updated
Omer Akram (om26er) on 2011-10-16
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Oneiric):
status: Fix Committed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Oneiric):
status: New → Confirmed
Jonathan Allard (joallard) wrote :

What would be a temporary fix such as restarting the menu? The issue is extremely annoying.

Jonathan Allard (joallard) wrote :

I solved it myself: called `unity` from the prompt

Hello Jane, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed

I've just installed from proposed and it seems to work just fine :)

My external monitor extension is to the right and both screens have different resolutions.

Thanks to those who worked on this problem.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2

---------------
unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Didier Roche <email address hidden> Tue, 18 Oct 2011 12:47:54 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2b1

---------------
unity (4.24.0-0ubuntu2b1) oneiric-proposed; urgency=low

  * No-change reupload because of broken powerpc build.

unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Martin Pitt <email address hidden> Tue, 25 Oct 2011 07:01:51 +0200

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments