multimonitor , window management - Multi-Monitor Maximized Difficulty

Bug #843958 reported by Andy Choens on 2011-09-07
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
Medium
Sam Spilsbury
unity (Ubuntu)
Medium
Sam Spilsbury

Bug Description

When using my laptop with an external monitor attached, Unity behaves in an unexpected manner. Below, is a basic outline of how I have my monitors set up using Gnome3's Display utility.

-------------------------------------
| | -------------------------------------
| External Monitor (#1) || Laptop Screen (#2) |
| || |
------------------------------------- -------------------------------------

I'm not sure what the proper name for the menu/indicator bar that runs across the top of the screen is. Here, I refer to it as the Unity menu bar.

My problem is this - when using multiple monitors, with maximized applications, it is difficult to use the mouse to switch focus from one app to the other. In my mind, the Unity menu bar must act as both a menu bar and a traditional window title border when applications are maximized. In single screen mode, this works as I expect it to. For example, I can reach up to the Unity menu bar and drag down to de-maximize the window.

But, this pattern/metaphor seems to break down when using multiple monitors. Let's say I have Firefox maximized on #1 and Thunderbird maximized #2. I start by using Firefox. Thus, Firefox is the application in focus. As long as continue to interact with Firefox, everything behaves as I expect it to. The problem starts when I want to shift focus to Thunderbird running on #2. If I use Alt-Tab, everything works as expected because Unity properly understands that I have shifted focus to Thunderbird. But, if I use my mouse to switch focus, Unity's behavior is not logical. Let's say I drag my mouse from Firefox to Thunderbird and attempt to interact with the Thunderbird menu, which is in the top-left corner of #2. Because Firefox still has the focus, I can not immediately access Thunderbird's menus. The Unity menu bar stays blank. This is confusing, but not the end of the world. It gets worse when the user discovers that clicking on the Unity menu bar that is positioned above Thunderbird does not cause Thunderbird to obtain focus. In this situation, the idea that the Unity menu bar is a title bar and menu breaks down because I can not give Thunderbird focus using the maximized title bar. The only way to switch focus to Thunderbird involves selecting some non-functional chrome in the Thunderbird window. Once I have clicked on Thunderbird, it has the focus and the menus and title bar behave as expected.

This is similar to bug #716177 but the recent fixes don't seem to have the desired affect.

Metacity had the option to have focus follow the mouse. In most use cases, this is incredibly frustrating. But, when using maximized windows in dual monitor set ups, this is actually much more natural. Unity should have some way of detecting when it should switch gears and allow focus to follow mouse and when it should wait for a click to switch focus.

I hope this all makes sense.

----------------------------------------------------------

Desired solution:

- When a user has a maximised application open on a second monitor, and a different window is in focus, clicking on any empty area in the second monitor top bar should bring the non-focused application that is currently maximised on the second monitor in to focus.

- When a user has a maximised application open on a second monitor, and a different window is in focus, the normal 'drag any empty area in the top bar downwards to shift window from maximised to restored state' behaviour should apply. (see bug https://bugs.launchpad.net/ayatana-design/+bug/723882 for a description of this functionality)

Related branches

Andy Choens (andy-choens) wrote :

I see that my clever ASCII art died when I sent in the report. Sorry for the weird affect. My point was to show that I have an external monitor (#1) that is to the left of my laptop screen (#2).

Andy Choens (andy-choens) wrote :

As a test, I installed ccsm and went to General Options. I went to the Focus and Raise tab and unchecked it. Now, when I move my mouse around, the unity menu bar behaves how I would expect it to, but using this setting results in other less desirable behaviors when interacting with non-maximized applications.

This is more or less a problem created by the new Unity layout, combining the menu and the title bar and then hiding the menu bar, resulting in very little to click on other than application chrome. Traditionally, window managers would not wind up in this situation. Compiz/Unity will have to be smart enough to jump in and out of different focus modes or Unity on a multi-monitor system will feel clumsy.

Omer Akram (om26er) on 2011-09-18
tags: added: multimonitor
David Barth (dbarth) on 2011-09-23
tags: added: mm-dash
Changed in unity:
status: New → Triaged
importance: Undecided → Low
Omer Akram (om26er) on 2011-09-24
Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Triaged
John Lea (johnlea) on 2011-10-07
description: updated
tags: added: onew udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
status: New → Fix Committed
Changed in unity:
importance: Low → Critical
John Lea (johnlea) on 2011-10-07
description: updated
John Lea (johnlea) on 2011-10-07
summary: - Multi-Monitor Maximized Difficulty
+ multimonitor , window management - Multi-Monitor Maximized Difficulty
Changed in unity:
milestone: none → 4.26.0
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
importance: Critical → Medium
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
John Lea (johnlea) on 2011-10-18
Changed in ayatana-design:
status: Fix Committed → Triaged
tags: added: udp
John Lea (johnlea) on 2011-11-03
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
milestone: 4.26.0 → 5.0.0
assignee: Andrea Azzarone (andyrock) → nobody
Changed in ayatana-design:
status: Triaged → Fix Committed
Tim Penhey (thumper) on 2011-11-21
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Omer Akram (om26er) on 2011-12-08
Changed in unity (Ubuntu):
importance: Low → Medium
Bryce Harrington (bryce) wrote :

I'm able to reproduce this bug in today's Unity 4.24 in Ubuntu Precise.

Since this is targeted to milestone 5.0.0, which has an Expected date of 2011-11-10, I gather this issue was fixed in a unity tree not yet uploaded to Ubuntu Precise, but planned to be in before release, and so thus the Fix Committed status. If this is incorrect please update.

Bryce Harrington (bryce) on 2011-12-19
tags: added: precise
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.0.0-0ubuntu1

---------------
unity (5.0.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release.
    - compiz crashed with SIGSEGV in __dynamic_cast() (LP: #853038)
    - unity-panel-service crashed with SIGSEGV in panel_service_show_entry()
      (LP: #861144)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() (LP: #869816)
    - Launcher - Launcher icon for Dash does not highlight when the Alt+F1 key
      shortcut is pressed (LP: #849561)
    - compiz crashed with SIGSEGV in unity::PanelTray::FilterTrayCallback()
      (LP: #868868)
    - [regression] Compiz: Visible tearing is worse in 11.10 than 11.04, even
      when "Sync To VBlank" is enabled, but only when Unity is active.
      (LP: #880707)
    - [regression] All apps have a lower frame rate under Unity. (LP: #861061)
    - compiz crashed with SIGSEGV in
      nux::Property<nux::color::Color>::operator=() from
      unity::switcher::SwitcherController::OnBackgroundUpdate() (LP: #887465)
    - DashSearchBarSpinner.cpp:56: Conditional jump or move depends on
      uninitialised value(s) (LP: #901610)
    - quicklist shows in incorrect position when launched from workspace
      switcher (LP: #914251)
    - Build "show me the desktop" mini-app that adds a show desktop button to
      Launcher (LP: #681348)
    - Select quicklist items with just one right click (LP: #688830)
    - cannot change volume by scrolling on the icon when the SoundMenu is
      opened (LP: #722082)
    - [a11y] Unity launcher buttons are not Actionable (LP: #772573)
    - Ubuntu Start launcher item doesn't start dash with keyboard navigation
      (LP: #825037)
    - multimonitor , window management - Multi-Monitor Maximized Difficulty
      (LP: #843958)
    - [regression] Drag and drop inside dash is very slow with Active Blur
      activated (LP: #851172)
    - Activating an alt-tab icon that holds initially unminimized windows
      should unminimize all windows (LP: #854595)
    - Dash - The Dash category headers are positioned incorrectly
      (LP: #839467)
    - Missing global menu with a semi-maximized window dragged to the right.
      (LP: #861279)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - top bar, integrated menu - when a application is first launched, the
      integrated menu should be displayed for 2 seconds before fading out of
      view (LP: #874254)
    - Window control buttons are not shown when an indicator is opened and the
      pointer is over the top-left corner (LP: #890970)
    - Quicklist item using some special chars doesn't show at all
      (LP: #899677)
    - PanelView.cpp:370: Conditional jump or move depends on uninitialised
      value(s) (LP: #901602)
    - unityshell.cpp:1982,1984: Conditional jump or move depends on
      uninitialised value(s) (LP: #901603)
    - Dash Search spinner sometimes doesn't spin at all (LP: #903090)
    - Point of tooltip is misaligned to focused ap...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: Critical → High
Nick Tait (jnick-tait) on 2012-03-07
tags: added: furtherdesignreviewrequiredp
removed: accessibility mm-dash multimonitor onew precise udo udp usability
Nick Tait (jnick-tait) on 2012-03-07
tags: added: udp
John Lea (johnlea) on 2012-04-26
tags: added: reviewedbydesignp
removed: furtherdesignreviewrequiredp udp
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints